summaryrefslogtreecommitdiff
path: root/dev-vcs/git-big-picture
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-07 04:19:48 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-07 04:19:48 +0000
commit639971d0c3ee4eef36854ab7d9729b6e8c3ac1cb (patch)
treeb91746d94af21bb8d8ea07ac19b0ef7e61a54ce3 /dev-vcs/git-big-picture
parent0e3680e4c16ff28839745eec6711889fc2e8d7e2 (diff)
gentoo auto-resync : 07:11:2023 - 04:19:48
Diffstat (limited to 'dev-vcs/git-big-picture')
-rw-r--r--dev-vcs/git-big-picture/Manifest1
-rw-r--r--dev-vcs/git-big-picture/git-big-picture-1.2.2-r3.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-vcs/git-big-picture/Manifest b/dev-vcs/git-big-picture/Manifest
index 1c3393b96a7e..8f2adc38e127 100644
--- a/dev-vcs/git-big-picture/Manifest
+++ b/dev-vcs/git-big-picture/Manifest
@@ -1,4 +1,5 @@
DIST git-big-picture-1.2.2.tar.gz 2964564 BLAKE2B 39971b21a9c9a0a8d1bf41f37350a158b634d2eaa0add460c1c18b70f643ab226736d53a337d4ed2583903a5d6c3188ab7a1b06f48a3f354e28d57ec74441599 SHA512 62c43727bb688d6572e7caafe9c5da3b782504738dd0d83d5df675ba757e8be22a8630ec1863c07f0fd2e54549b2ccbd1250ba8f367a6f840afa7b8962c487e8
EBUILD git-big-picture-1.2.2-r1.ebuild 946 BLAKE2B d13138ecce59bd926e705a0dc804929e50c6b8f0bb7a4097aa506a07ffd94c602e4cca31d2fb4a810176fb8d255a3949fcc1343afa59fc935340f2534e333e4a SHA512 ca6c462dff061ad399c1a5324c4ee62b6ef7cbfee6f81f21e3e449cc174b57d901e4879997c6f44e977a7cdbe962130cb9c32cc916f405cb879d7f7ac90f6625
EBUILD git-big-picture-1.2.2-r2.ebuild 971 BLAKE2B 9018a6dcdb2a9261c3491a509f979c0602f516070848300c37e79c1bd728dd19c25305abb5e4b429ab98542854e328b50fb9a8db2287eaeb3912d4aac9b36f12 SHA512 338de26ef03ed0b400aba478cd6eba55c4d227b4a0aec37c5b83198e30e3f7127e55d79c4cb4cac85680524de898009d352cc223ce77f3ee2f7f440f90223362
+EBUILD git-big-picture-1.2.2-r3.ebuild 972 BLAKE2B 65b679f7a851faea0f31966115be4ae024559b2f309d5ec4b27c4ef9b89ddf848a9be446fc2a27ea44ed259fe5547a7f32d26042fdfea7a419bacddf39126908 SHA512 b79a5a16c04b9346c031d1faad5fc0171d91a8c1323e18d5e85a2e742913ab7db73d706578e2e2415d65a9597dcadf8b074195ad700af31326545b18d914a5c1
MISC metadata.xml 399 BLAKE2B 5e912fe66108f5588e14b1766b905e2c19aa6bc8529ac855be153efa928222bd455eec6c21cbefbfa62fa005732356f0368b47eebd4bb91cfbb77ba427dbe356 SHA512 790e96e16572a401754dc67f30fd2bca0a1cf11ef95afca4cab8379fc1b2684389a73ce118e05c062c9ec768c0098240ab7ec1cda40e7ed1a81c0a3525ea1ba3
diff --git a/dev-vcs/git-big-picture/git-big-picture-1.2.2-r3.ebuild b/dev-vcs/git-big-picture/git-big-picture-1.2.2-r3.ebuild
new file mode 100644
index 000000000000..36aa2df82403
--- /dev/null
+++ b/dev-vcs/git-big-picture/git-big-picture-1.2.2-r3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{9..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Visualization tool for Git repositories"
+HOMEPAGE="https://github.com/git-big-picture/git-big-picture"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+# NOTE: dev-util/cram explictly does not need [${PYTHON_USEDEP}]
+# since test.cram is a shell session and not Python code
+DEPEND="
+ test? (
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-util/cram
+ )
+"
+# No need for "[python]" or "[${PYTHON_USEDEP}]" with any of these
+# since they are invoked using subprocess
+RDEPEND="
+ dev-vcs/git
+ media-gfx/graphviz[svg]
+"
+
+RESTRICT="!test? ( test )"
+
+python_test() {
+ pytest -vv test.py || die "Tests fail with ${EPYTHON}"
+ cram test.cram || die "Tests fail with ${EPYTHON}"
+}