summaryrefslogtreecommitdiff
path: root/dev-vcs/cvsync/cvsync-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-29 03:22:09 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-29 03:22:09 +0100
commitd4bd6695641f6d2ec7ff8681913d304e995902f5 (patch)
tree6ec8d4c38152bb4f2bb4b93277236ebd9fbbd21d /dev-vcs/cvsync/cvsync-9999.ebuild
parent22910f5d14da606bd7f06e19a2f61c5d1a8fc94b (diff)
gentoo resync : 29.05.2018
Diffstat (limited to 'dev-vcs/cvsync/cvsync-9999.ebuild')
-rw-r--r--dev-vcs/cvsync/cvsync-9999.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/dev-vcs/cvsync/cvsync-9999.ebuild b/dev-vcs/cvsync/cvsync-9999.ebuild
index cda6f4f16922..f638af4de214 100644
--- a/dev-vcs/cvsync/cvsync-9999.ebuild
+++ b/dev-vcs/cvsync/cvsync-9999.ebuild
@@ -1,16 +1,17 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=6
inherit toolchain-funcs
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/cvsync/cvsync.git"
- inherit git-2
+ inherit git-r3
else
SRC_URI="mirror://gentoo/${P}.tar.xz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+ S="${WORKDIR}/${PN}"
fi
DESCRIPTION="portable CVS repository synchronization utility"
@@ -29,8 +30,6 @@ RDEPEND="sys-libs/zlib
)"
DEPEND="${RDEPEND}"
-S="${WORKDIR}/${PN}"
-
maint_pkg_create() {
cd "${S}"
local ver=$(date --date="$(git log -n1 --pretty=format:%ci HEAD)" -u "+%Y.%m.%d.%H%M%S")
@@ -42,7 +41,7 @@ maint_pkg_create() {
src_unpack() {
if [[ ${PV} == "9999" ]] ; then
- git-2_src_unpack
+ git-r3_src_unpack
maint_pkg_create
else
default