summaryrefslogtreecommitdiff
path: root/dev-vcs/cvsync/cvsync-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-vcs/cvsync/cvsync-9999.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-vcs/cvsync/cvsync-9999.ebuild')
-rw-r--r--dev-vcs/cvsync/cvsync-9999.ebuild80
1 files changed, 80 insertions, 0 deletions
diff --git a/dev-vcs/cvsync/cvsync-9999.ebuild b/dev-vcs/cvsync/cvsync-9999.ebuild
new file mode 100644
index 000000000000..f638af4de214
--- /dev/null
+++ b/dev-vcs/cvsync/cvsync-9999.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/cvsync/cvsync.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://gentoo/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+ S="${WORKDIR}/${PN}"
+fi
+
+DESCRIPTION="portable CVS repository synchronization utility"
+HOMEPAGE="https://github.com/cvsync/cvsync"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="gcrypt mhash +openssl"
+REQUIRED_USE="!openssl? ( ^^ ( gcrypt mhash ) )"
+
+RDEPEND="sys-libs/zlib
+ openssl? ( dev-libs/openssl:0= )
+ !openssl? (
+ gcrypt? ( dev-libs/libgcrypt:0= )
+ mhash? ( app-crypt/mhash )
+ )"
+DEPEND="${RDEPEND}"
+
+maint_pkg_create() {
+ cd "${S}"
+ local ver=$(date --date="$(git log -n1 --pretty=format:%ci HEAD)" -u "+%Y.%m.%d.%H%M%S")
+ local tar="${T}/${PN}-${ver}.tar.xz"
+ git archive --prefix "${PN}/" HEAD | xz > "${tar}" || die "creating tar failed"
+ einfo "Packaged tar now available:"
+ einfo "$(du -b "${tar}")"
+}
+
+src_unpack() {
+ if [[ ${PV} == "9999" ]] ; then
+ git-r3_src_unpack
+ maint_pkg_create
+ else
+ default
+ fi
+}
+
+_emake() {
+ # USE flag settings are enforced by REQUIRED_USE.
+ local hash=$(usex openssl openssl $(usex gcrypt gcrypt mhash))
+
+ # Probably want to expand this at some point.
+ local host_os="Linux"
+
+ emake \
+ CC="$(tc-getCC)" \
+ ECHO="echo" \
+ TEST="test" \
+ INSTALL="install" \
+ HASH_TYPE="${hash}" \
+ HOST_OS="${host_os}" \
+ BINOWN="$(id -u)" \
+ BINGRP="$(id -g)" \
+ BINDIR="\$(PREFIX)/usr/bin" \
+ MANDIR="\$(PREFIX)/usr/share/man" \
+ "$@"
+}
+
+src_compile() {
+ _emake PREFIX="${EPREFIX}"
+}
+
+src_install() {
+ dodir /usr/bin /usr/share/man/man1
+ _emake PREFIX="${ED}" install
+ dodoc samples/*.conf
+}