summaryrefslogtreecommitdiff
path: root/dev-vcs/cvsgraph
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-vcs/cvsgraph
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-vcs/cvsgraph')
-rw-r--r--dev-vcs/cvsgraph/Manifest5
-rw-r--r--dev-vcs/cvsgraph/cvsgraph-1.6.1.ebuild42
-rw-r--r--dev-vcs/cvsgraph/cvsgraph-1.7.0.ebuild42
-rw-r--r--dev-vcs/cvsgraph/metadata.xml11
4 files changed, 100 insertions, 0 deletions
diff --git a/dev-vcs/cvsgraph/Manifest b/dev-vcs/cvsgraph/Manifest
new file mode 100644
index 000000000000..1e41f5f9d2a7
--- /dev/null
+++ b/dev-vcs/cvsgraph/Manifest
@@ -0,0 +1,5 @@
+DIST cvsgraph-1.6.1.tar.gz 114337 BLAKE2B 5cd68521e596ca610e9c9b87d6f1ad75b8e77519dcddc51a8e717a280831967021be62e8da3f872dee7911d3a5853ac328339eadeb0446262e0a8404d40a5625 SHA512 6548d43784cd6e2e85777e0158371c6332f96f72fc8d1827dcece8aa54d77139021586e468155ec003d371eaa7095cd57a5004a1ed76bc55db325c3899105e6b
+DIST cvsgraph-1.7.0.tar.gz 202678 BLAKE2B 589195f3642b0bc181a581a8f832eded3e6add44b2c9ee5c76a1a4f347384fbd59cd1f7f22c37d56810636dc13bad900bbe7973f9bfa061c37baa8becdaf35d5 SHA512 b2a5bec073e7fbba2a2b1975bb4583c8fa87d29a985b7bcedcaf556c744b822ea5ff65b5ca3c4bd6da6bb6697f5e023a7ce35cf5084f2d59fdd15297790e7aab
+EBUILD cvsgraph-1.6.1.ebuild 989 BLAKE2B 9f151ae777697e7dbff6a32b11c00369f8964cffbb4b0a588579ea053b136d0e5f2fd06ae2bcde4b5105538db87cc2d8835b60532e07175aeb8dbd308c65d9de SHA512 dc1f9f05fec2502bad47d6dc15a4095cbfeb70135f758243f11ab2ecb256d6e16ec21e0d4f9a9ead01780c2c572b685b1bd929076ea743be04b4b20e84e3b0cc
+EBUILD cvsgraph-1.7.0.ebuild 996 BLAKE2B b8b1296b3b212f429cdf8986d03aef3a44870103d816f9a341862c9d812581e399c97639ef7c6167e4769f8a4ee0acd95492393a81194877bb1424ef9fcf077a SHA512 99f8bad8da445143ac4e54e875b04357413fa3013fe8f5a510d5a2b9039d32d56ea34d428971bda2bac4ffa62ad44cc50152da986985bb78dda95e867a2bd889
+MISC metadata.xml 493 BLAKE2B 0e09276d91cc147bcb1b5eef8b13d9941cc1940a24e98413a9a5ba6d76bb98183fe55594bdfda4cb3787a73a32d893169a46924d61ea4b9030046005927d4a71 SHA512 8f12f7ce3e9039383476cb5802de8ab3e8ac01cb61ad25510e2c4e4ff3f075da0373197745365074c33fcafb33b680f121dc07a77499075e98896f8b4f5d26ba
diff --git a/dev-vcs/cvsgraph/cvsgraph-1.6.1.ebuild b/dev-vcs/cvsgraph/cvsgraph-1.6.1.ebuild
new file mode 100644
index 000000000000..564e2b19c8f7
--- /dev/null
+++ b/dev-vcs/cvsgraph/cvsgraph-1.6.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=0
+
+DESCRIPTION="CVS/RCS repository grapher"
+HOMEPAGE="http://www.akhphd.au.dk/~bertho/cvsgraph"
+SRC_URI="http://www.akhphd.au.dk/~bertho/cvsgraph/release/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-alpha amd64 -ia64 ppc sparc x86"
+IUSE="gif jpeg nls png truetype zlib"
+
+DEPEND="media-libs/gd
+ zlib? ( sys-libs/zlib )
+ gif? ( media-libs/giflib )
+ png? ( media-libs/libpng )
+ jpeg? ( virtual/jpeg )
+ truetype? ( media-libs/freetype )"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable gif) \
+ $(use_enable png) \
+ $(use_enable jpeg) \
+ $(use_enable truetype) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install () {
+ dobin cvsgraph
+ insinto /etc
+ doins cvsgraph.conf
+ doman cvsgraph.1 cvsgraph.conf.5
+ dodoc ChangeLog README contrib/*.php3
+ docinto automatic_documentation ; dodoc contrib/automatic_documentation/*
+}
diff --git a/dev-vcs/cvsgraph/cvsgraph-1.7.0.ebuild b/dev-vcs/cvsgraph/cvsgraph-1.7.0.ebuild
new file mode 100644
index 000000000000..ada216280c8b
--- /dev/null
+++ b/dev-vcs/cvsgraph/cvsgraph-1.7.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=0
+
+DESCRIPTION="CVS/RCS repository grapher"
+HOMEPAGE="http://www.akhphd.au.dk/~bertho/cvsgraph"
+SRC_URI="http://www.akhphd.au.dk/~bertho/cvsgraph/release/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-alpha amd64 -ia64 ppc sparc x86"
+IUSE="gif jpeg nls png truetype zlib"
+
+DEPEND="media-libs/gd
+ zlib? ( sys-libs/zlib )
+ gif? ( media-libs/giflib )
+ png? ( media-libs/libpng )
+ jpeg? ( virtual/jpeg )
+ truetype? ( media-libs/freetype )"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable gif) \
+ $(use_enable png) \
+ $(use_enable jpeg) \
+ $(use_enable truetype) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install () {
+ dobin cvsgraph
+ insinto /etc
+ doins cvsgraph.conf
+ doman cvsgraph.1 cvsgraph.conf.5
+ dodoc ChangeLog README AUTHORS contrib/*.php
+ docinto automatic_documentation ; dodoc contrib/automatic_documentation/*
+}
diff --git a/dev-vcs/cvsgraph/metadata.xml b/dev-vcs/cvsgraph/metadata.xml
new file mode 100644
index 000000000000..8c51f3e8f767
--- /dev/null
+++ b/dev-vcs/cvsgraph/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <longdescription lang="en">
+ CvsGraph is a utility to make a graphical representation of all
+ revisions and branches of a file in a CVS/RCS repository. It has been
+ inspired by the 'graph' option in WinCVS, but I could not find a
+ stand-alone version of this graph code. So, it was time to write one.
+ </longdescription>
+</pkgmetadata>