summaryrefslogtreecommitdiff
path: root/dev-vcs/cvs-fast-export
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-vcs/cvs-fast-export
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-vcs/cvs-fast-export')
-rw-r--r--dev-vcs/cvs-fast-export/Manifest2
-rw-r--r--dev-vcs/cvs-fast-export/cvs-fast-export-1.59.ebuild46
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-vcs/cvs-fast-export/Manifest b/dev-vcs/cvs-fast-export/Manifest
index fab4e87f2ded..35ba9c47aaa8 100644
--- a/dev-vcs/cvs-fast-export/Manifest
+++ b/dev-vcs/cvs-fast-export/Manifest
@@ -1,3 +1,5 @@
DIST cvs-fast-export-1.57.tar.gz 503473 BLAKE2B 06d5b03d550be9604a04b4f03cd19d06abbe84efb6fbb424a3ae8c58f2964dff31e1718baf61adf70fe17c2beb6753cdd0fba9e0e1a5ba5e9d8ae7b87721a336 SHA512 bb129d58a66ca8aa9feb6dcdf6d83553ed1099d6023041c4fb8fa9b923461b6eb9e59ec304b3443f754d7710a2655fd2c104cbaa5ac604ee471de727b92fc091
+DIST cvs-fast-export-1.59.tar.gz 514934 BLAKE2B 2e9f42eb948c917785f80596bf176cde8265555c8808fa8c7a297217dba6eb36f8de6cebc192ebb0bd513e3c288beefad01d04cd59a72176377851b00a25419a SHA512 3fd4455c61b9065b784396683bea6ca6fcae8509fabd72531d1dba7d733e1fedeb9307b99d02f03eb3d19e9b024f2c53e2a15062b46d96fe58ab90651ff94bc5
EBUILD cvs-fast-export-1.57.ebuild 931 BLAKE2B 439b7f5ba4c6bdc8c09dc0f8906db1faba85dc08eaf63a3c3c9859f6d10781bb5857493a7580da3167e7d87c185eb7dff502a98b1335f0b8b19719742b1b64b0 SHA512 d53f87163c8447025b3cb5e3fd7b3474c4cf0bf832f9d027a0b878daf73314cd304652235d33b956e960fe094d4c19683d797c9c48507b6b026deb3949a02960
+EBUILD cvs-fast-export-1.59.ebuild 931 BLAKE2B e4b6b099b2e570496a696e645618e60916a7d68dd3d94e8ce839bfea15e7ab5948201fdee0a0e63906dbe29b8d6496acbce87d9d8485dfd36f0fd8a36582a58b SHA512 d2e614eba89ba9dbb79ffede1b982089dfdf768230f3179bb5f5f73a64a67f6869a0f0e7308ccc96f12d18592554eee177bc5ed1201348846c00ba901518d137
MISC metadata.xml 293 BLAKE2B a23e078dca5e12f97e109f3baee0973164fa61746c1b985fa9c16f45daad1a3b59d95c5cce106c6aab4aed4de36c61ad5268bc96b334483d54a395ef01d2931f SHA512 58d4ab23405aeaee6a2d0de49d39e4809dae6a016984532fd43b00744fc5d4e1d52057730448a50210ecfad8938e37d5474f4caaf3dbf806aa82edc958abece8
diff --git a/dev-vcs/cvs-fast-export/cvs-fast-export-1.59.ebuild b/dev-vcs/cvs-fast-export/cvs-fast-export-1.59.ebuild
new file mode 100644
index 000000000000..abce092aa5b5
--- /dev/null
+++ b/dev-vcs/cvs-fast-export/cvs-fast-export-1.59.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="fast-export history from a CVS repository or RCS collection"
+HOMEPAGE="http://www.catb.org/~esr/cvs-fast-export/"
+SRC_URI="http://www.catb.org/~esr/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+BDEPEND="app-text/asciidoc"
+
+RESTRICT=test # upstream does not ship some tests in tarball
+
+src_prepare() {
+ default
+
+ tc-export CC
+ export prefix="${EPREFIX}"/usr
+
+ # respect CC, CFLAGS and LDFLAGS
+ sed \
+ -e 's/cc /$(CC) $(LDFLAGS) /' \
+ -e 's/^CFLAGS += -O/#&/' \
+ -e 's/CFLAGS=/CFLAGS+=/' \
+ -i Makefile || die
+}
+
+src_compile() {
+ # '.adoc.html' rules can't be executed in parallel
+ # as they reuse the same 'docbook-xsl.css' file name.
+ emake -j1 html
+ # Allow full parallelism for the rest
+ emake
+}
+
+src_install() {
+ default
+ dodoc README.adoc
+}