summaryrefslogtreecommitdiff
path: root/dev-vcs/colorcvs/colorcvs-1.4-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-vcs/colorcvs/colorcvs-1.4-r2.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-vcs/colorcvs/colorcvs-1.4-r2.ebuild')
-rw-r--r--dev-vcs/colorcvs/colorcvs-1.4-r2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-vcs/colorcvs/colorcvs-1.4-r2.ebuild b/dev-vcs/colorcvs/colorcvs-1.4-r2.ebuild
new file mode 100644
index 000000000000..2f2076b0e8dc
--- /dev/null
+++ b/dev-vcs/colorcvs/colorcvs-1.4-r2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit prefix
+
+DESCRIPTION="A tool based on colorgcc to beautify cvs output"
+HOMEPAGE="https://packages.gentoo.org/package/dev-vcs/colorcvs"
+SRC_URI="https://dev.gentoo.org/~jlec/distfiles/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+DEPEND=""
+RDEPEND="
+ dev-lang/perl
+ dev-vcs/cvs
+"
+
+src_prepare() {
+ # fix typo
+ sed -i -e 's:compiler_pid:cvs_pid:' ${PN} || die "sed failed"
+ eapply "${FILESDIR}"/${P}-prefix.patch
+ eprefixify colorcvs
+ default
+}
+
+src_install() {
+ insinto /etc/profile.d
+ doins "${FILESDIR}/${PN}-profile.sh"
+
+ dobin colorcvs
+ dodoc colorcvsrc-sample
+}
+
+pkg_postinst() {
+ echo
+ einfo "An alias to colorcvs was installed for the cvs command."
+ einfo "In order to immediately activate it do:"
+ einfo "\tsource /etc/profile"
+ echo
+}