summaryrefslogtreecommitdiff
path: root/dev-util
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-21 00:38:34 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-21 00:38:34 +0000
commitd39430b96ad12b39a0ce35745f3d45d980d1b328 (patch)
treefef90d0b467c23d538da717540b56a1be7ec29f0 /dev-util
parenta075e288474a3a53905a044068223546c5360298 (diff)
gentoo auto-resync : 21:03:2023 - 00:38:34
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/Manifest.gzbin68389 -> 68392 bytes
-rw-r--r--dev-util/gnome-builder/Manifest2
-rw-r--r--dev-util/gnome-builder/gnome-builder-44.1.ebuild275
-rw-r--r--dev-util/scons/Manifest3
-rw-r--r--dev-util/scons/scons-4.5.1-r1.ebuild (renamed from dev-util/scons/scons-4.5.1.ebuild)18
5 files changed, 287 insertions, 11 deletions
diff --git a/dev-util/Manifest.gz b/dev-util/Manifest.gz
index 182c061ef355..727dafa66fd8 100644
--- a/dev-util/Manifest.gz
+++ b/dev-util/Manifest.gz
Binary files differ
diff --git a/dev-util/gnome-builder/Manifest b/dev-util/gnome-builder/Manifest
index 09fb8f1bf8ff..bf0b87b623b8 100644
--- a/dev-util/gnome-builder/Manifest
+++ b/dev-util/gnome-builder/Manifest
@@ -1,5 +1,7 @@
DIST gnome-builder-43.4.tar.xz 10284936 BLAKE2B 50af653566b35525a751d1ab0698c42e205aa8ab3205b390d10625f67a984986f24e5c0a5512629d81c082265435d5f39380de2c675d64e9f0b6d47c2fc62451 SHA512 c8600aea7bd01fb8a75baf321d8670600aa0ac77f7a42cccc7107fd9d2addd0264f132a4e36c2ae66ad7dbd8dc94dfc52421655254eee93d0a3298aa2cc224db
DIST gnome-builder-43.6.tar.xz 10289396 BLAKE2B e9b8c98f5463906e0ec522307f0ec07c130045288db5b1295b56320ac36814019ee3350f73543c8a1655812dcd8b26da4cbe9d1b5bd3bda8cc7a943f308a91ee SHA512 e444843e1eae2a901048dc6f2ff7683c3693fcbceeb113ebd28e7a51d1ea9c3b7e317e28ceae9b659dc89cf3b75cabd526fff9483b81c623d809ca268a2c9a45
+DIST gnome-builder-44.1.tar.xz 9785408 BLAKE2B 43a41aa4856f3bbd84b6bab6686cd128d697d54e539d6b88e668a088eb256d11459d058046428564a706bf6e3766e3f61f9ff503151f16647f82bbbe400ab3fa SHA512 92653392fcd6c3a83f78c500037e8b8be05663cc8918e5521baacfbf5d251896358a284e7b37e4c49428c921b7f0cc2a96afa029cd00589b48f40b365e4decbc
EBUILD gnome-builder-43.4.ebuild 8733 BLAKE2B 4fcfccd449d726ffb335101546cc1d8610fa48f93247413ac5c87b3207e005c61194c9963a3ef6896819861b3712b3e920ee7e7e926f157da66be6a2c2ab3cde SHA512 b90fea7c51cd3cc40f1ef4a2c4bca0852d9fa662b977f404832856f9eaa3759ac510550f89d5afe19fc58263533d3f4bff842140c18717264caa331c66ea0c54
EBUILD gnome-builder-43.6.ebuild 8734 BLAKE2B dd1e2fc4af766378c4884d1642907421a89d468f12f3ff1feeb0c39fe6546ecf178a3762397727817a86f0210be07d67156546bfbf41be3f75bc901a2fbf6829 SHA512 d5bf9352f64e5a3e7b2c08cc5e91aa52b17490806906c28be0fee60b585dc9c437597c92c89309c6532bd200acbb43ac4052b9d42895b90d1fca91eb73129038
+EBUILD gnome-builder-44.1.ebuild 8982 BLAKE2B e21d41fbd298d8b62b4c124e9d0123899f0bd14540db06be7f436c5b4265f8a5656a038aec50e1cb77550465f75269f13f72170e7037596a2933959899a3a017 SHA512 64eef400246e57efe70bea3b23f0ea4e754ffa53f4473bce7606980a0dfb38639d96f36278254644892a9dd3ef4c506fa2b633df6bb7030fb837dd96b8770fab
MISC metadata.xml 1095 BLAKE2B e32e4a52f11c192e37b0593106b2938b3d8ded0cbb60859b7f30e9195667ef46b6ddb9b180e3aaa4459d6560027b3a85cb04b92930e191031966635d0bce4f42 SHA512 468bee5867936afa6d47cf4b7fcc36cb807fc2ad1d5a54e63013a1c862a157da35d051f12980331fece8f473ad5696c7a1c24e8bd53e2c41dd057250017b36b2
diff --git a/dev-util/gnome-builder/gnome-builder-44.1.ebuild b/dev-util/gnome-builder/gnome-builder-44.1.ebuild
new file mode 100644
index 000000000000..1961588e03a8
--- /dev/null
+++ b/dev-util/gnome-builder/gnome-builder-44.1.ebuild
@@ -0,0 +1,275 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{9..11} )
+DISABLE_AUTOFORMATTING=1
+FORCE_PRINT_ELOG=1
+
+inherit gnome.org gnome2-utils llvm meson optfeature python-single-r1 readme.gentoo-r1 virtualx xdg
+
+DESCRIPTION="An IDE for writing GNOME-based software"
+HOMEPAGE="https://wiki.gnome.org/Apps/Builder https://gitlab.gnome.org/GNOME/gnome-builder"
+
+# FIXME: Review licenses at some point
+LICENSE="GPL-3+ GPL-2+ LGPL-3+ LGPL-2+ MIT CC-BY-SA-3.0 CC0-1.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="clang doc +d-spy flatpak +git gtk-doc spell +sysprof test +webkit"
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ flatpak? ( git )
+"
+
+# When bumping, pay attention to all the included plugins/*/meson.build (and other) build files and the requirements within.
+# `grep -rI dependency * --include='meson.build'` can give a good initial idea for external deps and their double checking.
+# The listed RDEPEND order should roughly match that output as well, with toplevel one first then sorted by file path.
+# Most plugins have no extra requirements and default to enabled; we need to handle the ones with extra requirements. Many of
+# them have optional runtime dependencies, for which we try to at least notify the user via DOC_CONTENTS (but not all small
+# things); `grep -rI -e 'command-pattern.*=' -e 'push_arg'` can give a (spammy) idea, plus python imports in try/except.
+
+# Editorconfig needs old pcre, with vte migrating away, might want it optional or ported to pcre2?
+# An introspection USE flag of a dep is required if any introspection based language plugin wants to use it (grep for gi.repository). Last full check at 3.28.4
+
+# TODO: Handle llvm slots via llvm.eclass; see plugins/clang/meson.build
+RDEPEND="
+ >=dev-libs/glib-2.75.0:2
+ >=gui-libs/gtk-4.8:4[introspection]
+ >=gui-libs/libadwaita-1.3.0:1
+ >=gui-libs/libpanel-1.1.2:1
+ >=gui-libs/gtksourceview-5.7.2:5[introspection]
+ >=dev-libs/json-glib-1.2.0
+ >=dev-libs/jsonrpc-glib-3.43.0:=
+ >=dev-libs/libdex-0.1.1:=
+ >=dev-libs/libpeas-1.34.0[python,${PYTHON_SINGLE_USEDEP}]
+ dev-libs/libportal:=[gtk,introspection]
+ >=dev-libs/template-glib-3.36.1:=[introspection]
+ >=gui-libs/vte-0.70.0:2.91-gtk4[introspection]
+ >=dev-libs/libxml2-2.9.0
+ webkit? ( >=net-libs/webkit-gtk-2.38.0:6=[introspection] )
+ >=app-text/cmark-0.29.0:0=
+ d-spy? ( >=dev-util/d-spy-1.4.0:1 )
+ app-text/editorconfig-core-c
+ flatpak? (
+ dev-util/ostree
+ >=net-libs/libsoup-3:3.0
+ >=sys-apps/flatpak-1.10.2
+ )
+ git? (
+ dev-libs/libgit2:=[ssh,threads]
+ >=dev-libs/libgit2-glib-1.1.0[ssh]
+ )
+
+ >=dev-libs/gobject-introspection-1.54.0:=
+ $(python_gen_cond_dep '
+ >=dev-python/pygobject-3.22.0:3[${PYTHON_USEDEP}]
+ ')
+ ${PYTHON_DEPS}
+ clang? ( sys-devel/clang:= )
+ spell? (
+ app-text/enchant:2
+ dev-libs/icu:=
+ )
+ sysprof? (
+ >=dev-util/sysprof-capture-3.46.0:4
+ >=dev-util/sysprof-3.46.0:0/4
+ )
+"
+DEPEND="${RDEPEND}"
+# TODO: runtime ctags path finding..
+
+# desktop-file-utils required for tests, but we have it in deptree for xdg update-desktop-database anyway, so be explicit and unconditional
+# appstream-glib needed for validation with appstream-util with FEATURES=test
+BDEPEND="
+ doc? (
+ $(python_gen_cond_dep '
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx-rtd-theme[${PYTHON_USEDEP}]
+ ')
+ )
+ gtk-doc? (
+ dev-util/gi-docgen
+ app-text/docbook-xml-dtd:4.3
+ )
+ test? (
+ dev-libs/appstream-glib
+ sys-apps/dbus
+ )
+ dev-util/desktop-file-utils
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+DOC_CONTENTS='gnome-builder can use various other dependencies on runtime to provide
+extra capabilities beyond these expressed via USE flags. Some of these
+that are currently available with packages include:
+
+* dev-util/ctags with exuberant-ctags selected via "eselect ctags" for
+ C, C++, Python, JavaScript, CSS, HTML and Ruby autocompletion, semantic
+ highlighting and symbol resolving support.
+* dev-python/python-lsp-server for more accurate Python
+ autocompletion support.
+* dev-util/valgrind for integration with valgrind.
+* dev-util/meson for integration with the Meson build system.
+* virtual/rust for integration with the Rust Cargo build system.
+* dev-util/cmake for integration with the CMake build system.
+* net-libs/nodejs[npm] for integration with the NPM package system.
+'
+# FIXME: Package codespell and mention here
+# FIXME: Package gnome-code-assistance and mention here, or maybe USE flag and default enable because it's rather important
+# eslint for additional diagnostics in JavaScript files (what package has this? At least something via NPM..)
+# jhbuild support
+# rust support via rust-analyzer; Go via go-langserver
+# autotools stuff for autotools plugin; gtkmm/autoconf-archive for C++ template
+# gjs/gettext/mono/PHPize stuff, but most of these are probably installed for other reasons anyways, when needed inside IDE
+# stylelint for stylesheet (CSS and co) linting
+# gvls for vala language-server integration
+
+llvm_check_deps() {
+ has_version "sys-devel/clang:${LLVM_SLOT}"
+}
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ use clang && llvm_pkg_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dchannel=other
+
+ -Ddevelopment=false
+ -Dtracing=false
+ -Dprofiling=false # not passing -pg to CFLAGS
+ -Dtcmalloc=false
+ -Dwith_safe_path=''
+ -Dgnome_sdk_version=master
+ $(meson_use doc help)
+ $(meson_use gtk-doc docs)
+ -Dnetwork_tests=false
+ -Dctags_path=''
+ $(meson_feature webkit)
+
+ -Dplugin_autotools=true
+ -Dplugin_bash_language_server=true
+ -Dplugin_blueprint=true
+ -Dplugin_buildstream=true
+ -Dplugin_c_pack=true
+ -Dplugin_cargo=true
+ $(meson_use clang plugin_clang)
+ $(meson_use clang plugin_clangd)
+ $(meson_use clang plugin_clang_format)
+ -Dplugin_cmake=true
+ -Dplugin_codesearch=true
+ -Dplugin_codeshot=true
+ -Dplugin_codespell=true
+ -Dplugin_code_index=true
+ -Dplugin_copyright=true
+ -Dplugin_ctags=true
+ -Dplugin_deviced=false # libdeviced not packaged?
+ $(meson_use d-spy plugin_dspy)
+ -Dplugin_dub=true
+ -Dplugin_editorconfig=true
+ -Dplugin_eslint=true
+ -Dplugin_file_search=true
+ $(meson_use flatpak plugin_flatpak)
+ -Dplugin_gdb=true
+ -Dplugin_gdiagnose=true
+ -Dplugin_gettext=true
+ $(meson_use git plugin_git)
+ -Dplugin_glsl_language_server=true
+ -Dplugin_golang=true
+ -Dplugin_gopls=true
+ -Dplugin_gradle=true
+ -Dplugin_grep=true
+ -Dplugin_hadolint=true
+ -Dplugin_html_completion=true
+ $(meson_use webkit plugin_html_preview)
+ -Dplugin_intelephense=true
+ -Dplugin_jdtls=true
+ -Dplugin_jedi_language_server=false
+ -Dplugin_jhbuild=true
+ -Dplugin_lua_language_server=true
+ -Dplugin_make=true
+ -Dplugin_make_templates=true
+ $(meson_use webkit plugin_markdown_preview)
+ $(meson_use webkit plugin_markdown_indenter)
+ -Dplugin_maven=true
+ -Dplugin_meson=true
+ -Dplugin_meson_templates=true
+ -Dplugin_modelines=true
+ -Dplugin_mono=true
+ -Dplugin_newcomers=true
+ -Dplugin_notification=true
+ -Dplugin_npm=true
+ -Dplugin_phpize=true
+ -Dplugin_podman=true
+ -Dplugin_pygi=true
+ -Dplugin_python_lsp_server=true
+ -Dplugin_qemu=true
+ -Dplugin_quick_highlight=true
+ -Dplugin_retab=true
+ -Dplugin_rstcheck=true
+ -Dplugin_rubocop=true
+ -Dplugin_rust_analyzer=false # rust-analyzer not packaged
+ -Dplugin_serve_d=true
+ -Dplugin_shellcheck=true
+ -Dplugin_shellcmd=true
+ -Dplugin_sourcekit_lsp=true
+ $(meson_use spell plugin_spellcheck)
+ $(meson_use webkit plugin_sphinx_preview)
+ -Dplugin_stylelint=true
+ -Dplugin_swift=true
+ -Dplugin_swiftformat=true
+ -Dplugin_swiftlint=true
+ $(meson_use sysprof plugin_sysprof)
+ -Dplugin_todo=true
+ -Dplugin_ts_language_server=true
+ -Dplugin_update_manager=true
+ -Dplugin_valac=true
+ -Dplugin_vala_indenter=true
+ -Dplugin_vala_language_server=true
+ -Dplugin_valgrind=true
+ -Dplugin_waf=true
+ -Dplugin_words=true
+ -Dplugin_xml_pack=true
+ -Dplugin_zls=true
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ python_optimize
+ if use doc; then
+ rm "${ED}"/usr/share/doc/gnome-builder/en/.buildinfo || die
+ rm "${ED}"/usr/share/doc/gnome-builder/en/objects.inv || die
+ # custom docdir in build system, blocked by https://github.com/mesonbuild/meson/issues/825
+ mv "${ED}"/usr/share/doc/gnome-builder/en "${ED}"/usr/share/doc/${PF}/html || die
+ # _sources subdir left in on purpose, as HTML links to the rst files as "View page source". Additionally default docompress exclusion of /html/ already ensures they aren't compressed, thus linkable as-is.
+ rmdir "${ED}"/usr/share/doc/gnome-builder/ || die
+ fi
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+ readme.gentoo_print_elog
+
+ optfeature_header "Language support"
+ optfeature "Rust's Cargo build system" virtual/rust
+ optfeature "CMake" dev-util/cmake
+ optfeature "Java Maven build system" dev-java/maven-bin
+ optfeature "Meson Build system" dev-util/meson
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}
+
+src_test() {
+ virtx dbus-run-session meson test -C "${BUILD_DIR}"
+}
diff --git a/dev-util/scons/Manifest b/dev-util/scons/Manifest
index f9a67b4b2e1f..6ad7d87b1abd 100644
--- a/dev-util/scons/Manifest
+++ b/dev-util/scons/Manifest
@@ -5,10 +5,11 @@ DIST SCons-4.5.1.tar.gz 3194371 BLAKE2B 830e3365be99e38aec0f3b99d406bb7547d3d8b7
DIST scons-4.4.0-user.html 1608381 BLAKE2B ff4eb1e0f9c5e8ea7ca44cc00dc37e3e2dd38c24cb09a857c691e6a48f11e5fc86a55740037cc295e6b23df2a1c1b600adf0462320ec87cc26d4bcf919b07342 SHA512 8c1d6578270054efba34c56ddc07b4314bf62630f6a445f5b9f865cc48d593f6c92101a8d216dece201b8d6cb5bce59ff4adb51caaa40128e96b6235087f748c
DIST scons-4.4.0-user.pdf 2964111 BLAKE2B 45b37c99c3f3d0e9969a16506e27aeabfd562155405f5a59ba79c24404b14e5588fbd0673d86e2266adbd25eca140c9e1cf86e271228658591c0d9285474f078 SHA512 57330f685e7c775cb1c782e40f711c2b2322fad19212a22a920aff92db974610cc78f276e1606fb827660bb488ce803e2458bb9d93c452fa0600df4478f03d06
DIST scons-4.4.0.gh.tar.gz 5808265 BLAKE2B f6ce757f2edc40551b05285098626bb62def6abda2380d4885ee4443868e715e53aaa34f26c09dc689bb6ade26d1b0e276046fe3b1d2ddf8eb40400bca9ea164 SHA512 01fcd40bf818ca22a278973af1cda3024efb74cf877f15d46607fda860448fbd577fc96ba33fef2bed3d145e662a0371f55e8c927e7ac44feea7f3081791ce11
+DIST scons-4.5.1-mergeflags.patch 10518 BLAKE2B ea059c4347cfa8dcd99353c1f6b6c1d3aae1c6225b4683e421f3f3ea9181d5597862603c2491abff40dd1599094638239f34bf88458e7c44a8f28908eb91934c SHA512 11771c99d64cee413311f595faec8d2025152a7871ef53bdf0b22be45ffefc0d0c4bf49d185a10c1d3d2fb76ac94b04d992990375dc144587b101761a5d985a4
DIST scons-4.5.1-user.html 1655168 BLAKE2B 644c808f129d2d83f40b1ef2c8c12781b697a0120dfc00f5f0425e88e23c609290ecf2c8b6daad556c876ae3a86e8b262c53915b05d69c6e3c79f58395789362 SHA512 171d9330df520a75fbc124bf646c55c5868b24343ff46755a6283fe444ad4e090f5658dafa7239e708b4ff8b910e81201c27655674bdaffd20e8cc6ffb81d633
DIST scons-4.5.1-user.pdf 3023817 BLAKE2B caa782f77fac668eee0ccd76f3e96168ae3d61c9c3e80123c34bc45625182f77973fbab24170c5f67f133c6124412eadbf02c3497373211560c58a348d6b00ab SHA512 41fddff58032b6364ff3935259d4bf81a0d69398cd52158c42be71e4ff6efaebd2faaf1354781f7336ba1aa4f0cf99f0f37edcd72baf325f9ced7ec88b76ce88
DIST scons-4.5.1.gh.tar.gz 5844118 BLAKE2B 88a82e12a034f6d0748555d0d33716e5af6ff957a9345d5b0ba87c2a36544bae0965ea0a29e3cc80d6d2493f3f8bf0bd314bed5824dc609123972f640b19a53a SHA512 160089342b93197237b9f0c5f0ada42126f3e5c83e0026f6dc121aaae85c94774b01ea3b0b0fc56edf3effd87d91612b2167d004abe7a00bd8d107d5415f5d4a
EBUILD scons-4.4.0-r1.ebuild 3748 BLAKE2B 8a0d34afdd7ff554764e41608d75cece47bb47988371da296f5739d2aa2e3d0c7cd589d519edd089b26bae7385727005ab459e23549bd0d3c1a77be4a11faba2 SHA512 c7ae3e2a735b0e3adcd7b2fad1bc030eb3c557a51cc200bd38026e06c6e4adadffba236bceca0b79c47626aaf12e6da5ab74313766434927eaa9381ac069a2d0
EBUILD scons-4.4.0.ebuild 3659 BLAKE2B 1bd5799550b7874e8885f538d7ddc68b77c50012a03c8e8f71a1f68f8c3d38aacb8e851754bf1b9c0044d520049231e12630a8b372ae8316bc1da29f364934ef SHA512 1e289c45de9c534f56c851da908bf2d4bc05129b054faa35ba4fe6050077cabcf45b8048cd34e347218345df01ea0b95eee0c1634a4dd291f4be3c47647b84ea
-EBUILD scons-4.5.1.ebuild 3863 BLAKE2B 50b42ce30b6d28f47e8394a754ca781c307acee255005d32c95282a41baf5fffc6cf728854319d437ca8f6a803ad1f4c0fdf5c43e15f830b47a406278f105b1f SHA512 fe8df981334f50724d914b2d0923b4f12b2f23c5e997c471a74b1589295679db03f28eeb082e4d9b32e6e39f33b4ceb9a967265889527f248ded3c19928d2cc9
+EBUILD scons-4.5.1-r1.ebuild 3935 BLAKE2B f666846a43e32a19f60ada0354e0b688668ae66f209bac0a1d3eb45b9fe228fc5d2d33cd01f85c22e0418505b1caaeeb3a796e4520497a78ee898e6fb53be608 SHA512 2a760d90c90d2389f4070c8588922ffa80ae1359aed5249de443c61a3f8144bf81e688747366797dbf1fe660f1f4f29c6c10f4628ca4f051115f7e4f07cd741b
MISC metadata.xml 803 BLAKE2B 17a1596fb7b6991a9c4732c8e8c1231cd57ba42ae9e0b65a475f4a00503bacba23ae671df112909688574f836962951dcd2fd7a35bc83c34a0eeb72ecb96bbc2 SHA512 c1451442bdf49d7c85cc84831ea3a8a540581680858dc1ac117080b6a8558419d004952ade0410c0b31d9d241ae3d5eef1c81525ecb80c40cdc380b50f49e1ad
diff --git a/dev-util/scons/scons-4.5.1.ebuild b/dev-util/scons/scons-4.5.1-r1.ebuild
index 87c03687ce2a..d12cdf7c1bd8 100644
--- a/dev-util/scons/scons-4.5.1.ebuild
+++ b/dev-util/scons/scons-4.5.1-r1.ebuild
@@ -18,16 +18,16 @@ HOMEPAGE="
"
SRC_URI="
https://downloads.sourceforge.net/project/${PN}/${PN}/${PV}/${MY_P}.tar.gz
+ https://github.com/SCons/scons/pull/4322.patch
+ -> ${P}-mergeflags.patch
+ https://github.com/SCons/scons/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
doc? (
https://www.scons.org/doc/${PV}/PDF/${PN}-user.pdf
-> ${P}-user.pdf
https://www.scons.org/doc/${PV}/HTML/${PN}-user.html
-> ${P}-user.html
)
- test? (
- https://github.com/SCons/scons/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
- )
"
S="${WORKDIR}/${P}/src"
@@ -45,6 +45,9 @@ BDEPEND="
"
PATCHES=(
+ # https://bugs.gentoo.org/900971
+ "${DISTDIR}/${P}-mergeflags.patch"
+
# support env passthrough for Gentoo ebuilds
"${FILESDIR}"/scons-4.1.0-env-passthrough.patch
# respect CC, CXX, C*FLAGS, LDFLAGS by default
@@ -54,12 +57,7 @@ PATCHES=(
src_unpack() {
# use the git directory structure, but put pregenerated release
# inside src/ subdirectory to make our life easier
- if use test; then
- unpack "${P}.gh.tar.gz"
- else
- mkdir -p "${P}"/src || die
- fi
-
+ unpack "${P}.gh.tar.gz"
tar -C "${P}"/src --strip-components=1 -xzf "${DISTDIR}/${MY_P}.tar.gz" || die
}