summaryrefslogtreecommitdiff
path: root/dev-util
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-04-01 01:33:27 +0100
committerV3n3RiX <venerix@koprulu.sector>2025-04-01 01:33:27 +0100
commit9cb5d77a6732fadf391fd38da00e6921f3e23112 (patch)
tree30f5c59801151fa131da4743ca598f950b2e5b4b /dev-util
parent033286afc1eb2e64a87a58798a0c620d8b56f497 (diff)
gentoo auto-resync : 01:04:2025 - 01:33:27
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/Manifest.gzbin64976 -> 64974 bytes
-rw-r--r--dev-util/diffoscope/Manifest2
-rw-r--r--dev-util/diffoscope/diffoscope-293.ebuild140
-rw-r--r--dev-util/kdevelop-pg-qt/Manifest2
-rw-r--r--dev-util/kdevelop-pg-qt/kdevelop-pg-qt-2.3.0.ebuild27
-rw-r--r--dev-util/packer/Manifest3
-rw-r--r--dev-util/packer/packer-1.12.0.ebuild35
7 files changed, 180 insertions, 29 deletions
diff --git a/dev-util/Manifest.gz b/dev-util/Manifest.gz
index 2b86f36f5e73..ed45e2b2c25c 100644
--- a/dev-util/Manifest.gz
+++ b/dev-util/Manifest.gz
Binary files differ
diff --git a/dev-util/diffoscope/Manifest b/dev-util/diffoscope/Manifest
index 2705de875eb9..9c2f5a3f3538 100644
--- a/dev-util/diffoscope/Manifest
+++ b/dev-util/diffoscope/Manifest
@@ -1,5 +1,7 @@
DIST diffoscope-288.tar.bz2 3157674 BLAKE2B 546cf9cca9ca1f81470cfa347517054cc00a5195eb90b3aa72b6fdfde23e1385d4264f6c2c3b3c462a8ef4547fc136c6c758e240423deecb0689721057786bac SHA512 c93849f6bfa7173981b783e68114dfda44938629d5152ce67751b341ce3153c9dbc188dbf95c6d3bc69bfc3d303ab081db70ac37c5e30def3b364351ffd9d88b
DIST diffoscope-289.tar.bz2 3157044 BLAKE2B bd7c705098857251883a4506d483e23c24c845ecc624e7487afc111e01a8aee710862abf0ea1638c9c2455812d4cf6a2f491e63bfa6389d4dc9ff053a30de30b SHA512 e47538aed4136ef0891d569a0723c45d294757592762f20281fe6061aa52a4f926f49e7e491cb0a746f6f60bc14834762d1de968879db49b8a9a3b0e01a1ffc6
+DIST diffoscope-293.tar.bz2 3157506 BLAKE2B eb52326fafb8a1c8642170828f4cee10ad055c4dc586a28648806c748e2368d3fffc7a5be088be0c4792b8daf81199f4aefbf0e573cc6bc1a16068c70a697f81 SHA512 39e0d8895207d6cb108cb2483508bfded7fa55aa15dfff6bf5d293e149a9359cdf5159d3657f0f584da98889375f65ae26b0a87d6f62938cfcbd438d29d83b30
EBUILD diffoscope-288.ebuild 3937 BLAKE2B 38da064a3715a2c13b3a674416dc4ef91b39024e81ee13e01ff1ef788a988a5c946ec363df8d6b62cf11609a830c592e68c84a04f0f7d2fe9822e37c9d4be28d SHA512 97537df18723a72b2e91390bf7f4406b38b864ac695795597874686f360307841ea570a3d60ca11c94c0efe0fe13ec888699fe46d7fee21e639ef0674b4ce9c2
EBUILD diffoscope-289.ebuild 3938 BLAKE2B 1fe168439f96d6c496b2ebcc7352b6d35a7d4f9348e86639e93825a15d7aaa1564f89ce67d58ec31848d64f19d8f48266b5b57c20f121d0a0f3bc2e8fab0a820 SHA512 a580e39916e09c66bb9d243347654cb69850d2feaf64e7144254b07be4a614bfec562e952bed52cec7d81fbf7f8406e9d72f5ab2d99f888655c8ed6552336e2e
+EBUILD diffoscope-293.ebuild 3938 BLAKE2B 1fe168439f96d6c496b2ebcc7352b6d35a7d4f9348e86639e93825a15d7aaa1564f89ce67d58ec31848d64f19d8f48266b5b57c20f121d0a0f3bc2e8fab0a820 SHA512 a580e39916e09c66bb9d243347654cb69850d2feaf64e7144254b07be4a614bfec562e952bed52cec7d81fbf7f8406e9d72f5ab2d99f888655c8ed6552336e2e
MISC metadata.xml 2086 BLAKE2B 75fdcf3b9bb7b9dd6222f07a04a96b2166c9a819ca5c6358daf4451bf73951b443596e05548ebdc163338eafbc75574e47635b3920ee8125690a310bf5185cf2 SHA512 552933e0c0e9cf23a8f3435a2587c6738f26e5153d773a745159ab1623ad5f39ef5d2647368918b9fdb25d61aab6a02a860c0f815740c1b70c973aa0a48a11ce
diff --git a/dev-util/diffoscope/diffoscope-293.ebuild b/dev-util/diffoscope/diffoscope-293.ebuild
new file mode 100644
index 000000000000..6f5fc7ca5b80
--- /dev/null
+++ b/dev-util/diffoscope/diffoscope-293.ebuild
@@ -0,0 +1,140 @@
+# Copyright 2022-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+PYTHON_REQ_USE="ncurses"
+inherit distutils-r1 toolchain-funcs
+
+DESCRIPTION="Will try to get to the bottom of what makes files or directories different"
+HOMEPAGE="https://diffoscope.org/ https://pypi.org/project/diffoscope/"
+# We could use pypi, but upstream provide distribution tarballs, so let's use those.
+# TODO: verify-sig
+SRC_URI="https://diffoscope.org/archive/${P}.tar.bz2"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="acl binutils bzip2 libcaca colord cpio +diff docx dtc e2fsprogs file
+find gettext gif gpg haskell hdf5 hex imagemagick iso java llvm lzma
+mono opendocument pascal pdf postscript R rpm sqlite squashfs
+ssh tar test tcpdump zip zlib zstd"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ || (
+ dev-python/python-magic[${PYTHON_USEDEP}]
+ sys-apps/file[python,${PYTHON_USEDEP}]
+ )
+ dev-python/libarchive-c[${PYTHON_USEDEP}]
+ dev-python/distro[${PYTHON_USEDEP}]
+ dev-python/python-tlsh[${PYTHON_USEDEP}]
+ acl? ( sys-apps/acl )
+ binutils? ( sys-devel/binutils )
+ bzip2? ( app-arch/bzip2 )
+ libcaca? ( media-libs/libcaca )
+ colord? ( x11-misc/colord )
+ cpio? ( app-alternatives/cpio )
+ diff? ( sys-apps/diffutils )
+ docx? ( app-text/docx2txt )
+ dtc? ( sys-apps/dtc )
+ e2fsprogs? ( sys-fs/e2fsprogs )
+ file? ( sys-apps/file )
+ find? ( sys-apps/findutils )
+ gettext? ( sys-devel/gettext )
+ gif? ( media-libs/giflib )
+ gpg? ( app-crypt/gnupg )
+ haskell? ( dev-lang/ghc )
+ hdf5? ( sci-libs/hdf5 )
+ hex? ( app-editors/vim-core )
+ imagemagick? ( media-gfx/imagemagick )
+ iso? ( app-cdr/cdrtools )
+ java? ( virtual/jdk )
+ llvm? ( llvm-core/llvm )
+ lzma? ( app-arch/xz-utils )
+ mono? ( dev-lang/mono )
+ opendocument? ( app-text/odt2txt )
+ pascal? ( dev-lang/fpc )
+ pdf? (
+ app-text/pdftk
+ app-text/poppler
+ dev-python/pypdf[${PYTHON_USEDEP}]
+ )
+ postscript? ( app-text/ghostscript-gpl )
+ R? ( dev-lang/R )
+ rpm? ( app-arch/rpm )
+ sqlite? ( dev-db/sqlite:3 )
+ squashfs? ( sys-fs/squashfs-tools )
+ ssh? ( virtual/openssh )
+ tar? ( app-arch/tar )
+ tcpdump? ( net-analyzer/tcpdump )
+ zip? ( app-arch/unzip )
+ zlib? ( app-arch/gzip )
+ zstd? ( app-arch/zstd )
+"
+
+# pull in optional tools for tests:
+# img2txt: bug #797688
+# docx2txt: bug #797688
+BDEPEND="
+ test? (
+ app-arch/p7zip
+ app-text/docx2txt
+ app-text/html2text
+ media-libs/libcaca
+ virtual/imagemagick-tools[jpeg]
+ )
+"
+
+EPYTEST_DESELECT=(
+ # Test seems to use different tarball
+ tests/test_presenters.py::test_text_proper_indentation
+
+ # Needs triage
+ tests/comparators/test_binary.py::test_with_compare_details_and_tool_not_found
+ tests/comparators/test_rlib.py::test_item3_deflate_llvm_bitcode
+ tests/comparators/test_gif.py::test_has_visuals
+
+ # img2txt based failures, bug #797688
+ tests/comparators/test_ico_image.py::test_diff
+ tests/comparators/test_ico_image.py::test_diff_meta
+ tests/comparators/test_ico_image.py::test_diff_meta2
+ tests/comparators/test_ico_image.py::test_has_visuals
+ tests/comparators/test_jpeg_image.py::test_diff
+ tests/comparators/test_jpeg_image.py::test_compare_non_existing
+ tests/comparators/test_jpeg_image.py::test_diff_meta
+ tests/comparators/test_jpeg_image.py::test_has_visuals
+
+ # docx2txt based falures, bug #797688
+ tests/comparators/test_docx.py::test_diff
+
+ # Formatting
+ tests/test_source.py::test_code_is_black_clean
+
+ # Fails on ZFS
+ tests/test_main.py::test_non_unicode_filename
+
+ # Fails on (unreleased) LLVM 16 with minor difference
+ #tests/comparators/test_macho.py::test_llvm_diff
+ #tests/comparators/test_elf.py::test_libmix_differences
+)
+
+distutils_enable_tests pytest
+
+src_test() {
+ case $(tc-get-ptr-size) in
+ 4)
+ EPYTEST_IGNORE+=(
+ # Needs fixing in Perl itself (bug #934443)
+ tests/comparators/test_epub.py
+ tests/comparators/test_zip.py
+ )
+ ;;
+ *)
+ ;;
+ esac
+
+ distutils-r1_src_test
+}
diff --git a/dev-util/kdevelop-pg-qt/Manifest b/dev-util/kdevelop-pg-qt/Manifest
index 2ed15549cd46..9966b1fb7114 100644
--- a/dev-util/kdevelop-pg-qt/Manifest
+++ b/dev-util/kdevelop-pg-qt/Manifest
@@ -1,5 +1,3 @@
-DIST kdevelop-pg-qt-2.3.0.tar.xz 660164 BLAKE2B 4167068e8f8348c428e4260061abbd24a4c490588414a8a566d84b61913bfc6cb06292900cb881327b5ecdd3c0cf92aa02f6361cd870f9d8bc79f8ff295aa89a SHA512 27bd102cf64f9cd7b27940be02cb81b620732a11e2416327104a18edc6990e43b2a57281bec91697466c3ab3ac8d322412dd06673329e04583e3bc90862b43b9
DIST kdevelop-pg-qt-2.4.0.tar.xz 668916 BLAKE2B a6082d6f8fe9803884aea0dcf6faae0c56fd482812011b1fdcf7048c4937566677f6c19890415a2417156ac11713f3dccececb031554320b69264ec3c88c9ebf SHA512 bf4c4517c59202c2a13bdae2eaf93073a6de5445fa350555c79484f4936b71e7ea042a414ad5f72b656d767f8dbedf5dcceca40254fc6b8b1956cb47933c3ec5
-EBUILD kdevelop-pg-qt-2.3.0.ebuild 572 BLAKE2B 41c5d27e04478c981a3a55577d5cf57fd02687a57b6037500efbb7edfaa5957a4ba51e4ede5d2bd113998a4cf081a78bc414fd4066d3adb825a554eb53b5427f SHA512 0d84c7b41fa7ca4d1a792442514eee03939b457b63adb5f8ad7171285c6a650c102b38b0361624763f58108efb7d17fcaf549d6a8c560d62d628ff16dc868988
EBUILD kdevelop-pg-qt-2.4.0.ebuild 570 BLAKE2B daf4ff861a94d243c19f52b68da06d1f71afa4ad427e49bae899e081fb8dc46dbf3fde20719f5228f4a9e9a51e5bfe4142eb02199525d1ce6e33c47afdbc4676 SHA512 ec50e45506591df4a36c53ac7d1a5017adf4ee978320ce88c591b762e9d8ba3dc348c6044268c5b4e5a2514979b6f279a2182c3302eaae72e1c722c01e3cb1cc
MISC metadata.xml 415 BLAKE2B c17c05d83780bc439104be31933640a85543a827ea5b0d14db77897de0aa2858a0399a1e86f0689509abf0239073dff64bedbcaf8cf2871190fe42541e2a1560 SHA512 0409c5398ac0d32b33f39a24a3112c25682fd3afd2226fc37e66bb7db2219975aef44f1d9c9d3edbf518b48238aac6f8aeac62a3d5c30ebef2a50ecec02d2fe3
diff --git a/dev-util/kdevelop-pg-qt/kdevelop-pg-qt-2.3.0.ebuild b/dev-util/kdevelop-pg-qt/kdevelop-pg-qt-2.3.0.ebuild
deleted file mode 100644
index 6b08846e030b..000000000000
--- a/dev-util/kdevelop-pg-qt/kdevelop-pg-qt-2.3.0.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-ECM_TEST="true"
-KDE_ORG_CATEGORY="kdevelop"
-KFMIN=6.3.0
-inherit ecm kde.org
-
-if [[ ${KDE_BUILD_TYPE} = release ]]; then
- SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.xz"
- KEYWORDS="amd64 arm64"
-fi
-
-DESCRIPTION="LL(1) parser generator used mainly by KDevelop language plugins"
-HOMEPAGE="https://www.kdevelop.org/"
-
-LICENSE="LGPL-2+ LGPL-2.1+"
-SLOT="0"
-IUSE=""
-
-RDEPEND+=" !${CATEGORY}/${PN}:6"
-BDEPEND="
- app-alternatives/lex
- app-alternatives/yacc
-"
diff --git a/dev-util/packer/Manifest b/dev-util/packer/Manifest
index 0dce90bd05ac..47b2cd326e1a 100644
--- a/dev-util/packer/Manifest
+++ b/dev-util/packer/Manifest
@@ -1,7 +1,10 @@
DIST packer-1.11.0-deps.tar.xz 274685472 BLAKE2B 211e076e5032c5199597bda8d05a4f13d15db321d78f58ac3e5775f8ba16b0bd7dd348a396bb6bed41c039924d288e5ea6abd5a140558f25d1edbc75d39c4ba0 SHA512 200d2aa56b834202bd3b1506991f6ea4686e95345fed09eea923fbf00577d8ac2454cfd567c89926b9e99f777203b3ee908c30a4d9f7e71f2370061f09d53603
DIST packer-1.11.0.tar.gz 2296683 BLAKE2B 8b8eee2294109d305b94186829995f881d1b8a1a0db4a57e117e4473705f3a8e7e589ec7bb3d7efa10acbecc967623404902aeecdcd1474e266bc9c43410604c SHA512 304dbacfaf59fcc35876754f6a6766cc89e052b64970f42aa315c1141f349d6437538195512dc8cd7626d467faaf0bd68575cc8310f9fc8e7606faabd7cf748d
+DIST packer-1.12.0-deps.tar.xz 291033108 BLAKE2B 94681b4eb341e8d7083ae598854841d3252649ec3c672a6fbdb8cf99f9fb330305613d3d572540c087f5a8fb6c7054ddb959f1b3383927e1cbce5a46005d68e9 SHA512 05d77be70679500e87702be902e02eca6a7e00e2b4e4d3e805e7df522f381fb9ab8039d07e30f175164b1c58d92fc452c510ca2be1bd82e21fd3e7eccdde3b92
+DIST packer-1.12.0.tar.gz 2385746 BLAKE2B 0141dcb3a1f2424fd9cc1732b35ca7b500e98b6622582721d738d33ce77f259f5f1852b552624b3fb4b657cd9b9dd6a6ebee2fcfc80aaadab01c683dce9902ec SHA512 c539955105ffeebdb18978b12724224416386f61125b1f46d631c980caf7d9c4270752f39d23bfa6e42b43005aecd5814a89dffebe5bf8aaf265ccf6afaa7c20
DIST packer-1.9.5-deps.tar.xz 373922748 BLAKE2B 793b0e5501bca56849a2471fbe2892c4775c3aa2d3ad6346e65f3d0cf1e3d86339a64371a35e4fddb0053082e98e2ec527b4f052b901bf8d35bd5db08a577ee4 SHA512 1f49b45841308dba95fcce2139d21931708e099102cc0870be00f2142cfb0d0e8ce9e2c729c9556ca68c1036e224f120fe0cd8833715a62cc212eead2448a6e3
DIST packer-1.9.5.tar.gz 2302965 BLAKE2B dc0b8fedd83a477594c7235ffe6ca2052ba389e105bd451ad6c3987cea68c37f9c3153957012339f2a09045f20ac81ff6a59ed33834247408a3539643d9ecedf SHA512 7df1a85d0746e400c42f2b2a52b14ef5a806bcd2dc346eceaf5f8928b42a8b046ff8da7b45e5af0486bd444d8325e1cabdcd15f7b28711241a46034c9781a279
EBUILD packer-1.11.0.ebuild 796 BLAKE2B fc5cef26af01da085fd4d667e9ae156f715148ebc3aa7ffa0f3fd1ce14591c5b85a27990c1ea01174257088b635a7da3f4f7b03e497a6692cfdc16a6f8b3a176 SHA512 e1e5f535529e5ecca4151edfa5c197f328473f5991fcc3933ce968fe813332bd2610027de6d7666c7b28ec9995b10be7e325daf5304ce2f4cd2a3766d3b2cca6
+EBUILD packer-1.12.0.ebuild 807 BLAKE2B 28c5a5439e90ab9e2c09f0b007b7c5f2edbb7ed450c06d0d31ef3970015ecf7b3474548cb148ca3111f6aee150aa281d2b8bab681f49e60624f3eba30c3b8a69 SHA512 f2026f8ce363589b7c5bf888f72f5b0156b92b2026b21b1f7899dc93a9ee9a1c2d52c268cb5b0f2ca71d1735fe5fc51b9e43e742319bfc3c5c41a653b02d918e
EBUILD packer-1.9.5.ebuild 762 BLAKE2B c970a797ba9409c0403873b4378de49c195d03662a0b8af2b52d854b9f2010a262cb1247d57032780595add9372acd20c6fd4e947c2cac4688cdc8ba0feda099 SHA512 cf116262ea2fbed1d19d6d29da6130e153eee4d5fadb35fcd560566f71cbd92109792dd54fba0bc568f6f8b5ac587bebe116e41798fcaca11e4182004ae32c9b
MISC metadata.xml 1408 BLAKE2B 04204c3ac4c45b58a23e611fbd34014423fd1839829101f7a30a188fc8b4588532f72b05c41a77f093170c6a6d9bd804c47bc831a8006ecbda5d3a30ccf6ade6 SHA512 2a45870ccadf85968c81c3129cfffa16184c3cc6ed135b716a84e545d9c80ed35064be231386b0bbfbe6fb7f9a12704c25d7fabc9383b3211d61720691c2ae9b
diff --git a/dev-util/packer/packer-1.12.0.ebuild b/dev-util/packer/packer-1.12.0.ebuild
new file mode 100644
index 000000000000..a0dddc98fa6d
--- /dev/null
+++ b/dev-util/packer/packer-1.12.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="A tool to create identical machine images for multiple platforms"
+HOMEPAGE="https://www.packer.io"
+SRC_URI="https://github.com/hashicorp/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://gentoo.neutroniak.com/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0 BSD MIT MPL-2.0 unicode Unicode-DFS-2016 ISC BUSL-1.1 CC-BY-4.0 GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv"
+
+DOCS=( {README,CHANGELOG}.md )
+
+RESTRICT+=" test"
+
+src_compile() {
+ ego build \
+ -mod=readonly \
+ -ldflags "${go_ldflags}" \
+ -work -o "bin/${PN}" ./ || die
+}
+
+src_install() {
+ dobin bin/packer
+
+ einstalldocs
+
+ insinto /usr/share/zsh/site-functions
+ doins contrib/zsh-completion/_packer
+}