summaryrefslogtreecommitdiff
path: root/dev-util
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-28 19:13:18 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-28 19:13:18 +0000
commit9173ac495b70d91abace8e732906b844522cdb3b (patch)
treed4dced96e0b1f492507e987b1ced7cf582a985e4 /dev-util
parentac4d0ec6279a51ce08af9e3293666bc339be6b6f (diff)
gentoo auto-resync : 28:03:2024 - 19:13:18
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/Manifest.gzbin65256 -> 65251 bytes
-rw-r--r--dev-util/bugbite-cli/Manifest1
-rw-r--r--dev-util/bugbite-cli/bugbite-cli-0.0.7-r1.ebuild48
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-util/Manifest.gz b/dev-util/Manifest.gz
index 77b1b0752734..641423f8fb92 100644
--- a/dev-util/Manifest.gz
+++ b/dev-util/Manifest.gz
Binary files differ
diff --git a/dev-util/bugbite-cli/Manifest b/dev-util/bugbite-cli/Manifest
index 0be966153ca9..c063ddb04c69 100644
--- a/dev-util/bugbite-cli/Manifest
+++ b/dev-util/bugbite-cli/Manifest
@@ -1,3 +1,4 @@
DIST bugbite-cli-0.0.7.tar.xz 28365584 BLAKE2B e1f38972e6ca43ae24761baf4c5c4675a171663c7347783134962d090bb12860fab84a3730bf894e86235f26f625a765c323fc659b90b729131d780bb6771856 SHA512 6330e1dd86ab1958681e14104da2e854fa3223c585fe14b913fb3777318a8b367579aa483c158a03fd89811ad4a28624d9629e8ea8682cffa5d2adb769a53d2f
+EBUILD bugbite-cli-0.0.7-r1.ebuild 1302 BLAKE2B f19fc183604c26ff94f01db667889aa177a726cce2a13db9818567df403aa7dbfee396879bb5be8c56da6e8d54bae8d394812e7e1bd68dab709d8772d96bd4ed SHA512 6fe8422c1107de755aa2c380381c94350b2014f19d7af7964256150048c022ba5680a4a35364b0214b3e9641b327eb4688ab861aacc6e72c6d1745a80587430a
EBUILD bugbite-cli-0.0.7.ebuild 887 BLAKE2B f029a0554e288d98ef42e8b29fc44b587c5a79635b55b4597bcc7ba809a5d2faf157e19b4c7f15c271ff1b5ddabd351d5b7587ac6705e388ebf9aff6f272a39c SHA512 f694f8471c960d28dbcdd68930f094231d8215a427ed694b1ed9ba6529444a18711668a51fdef6715b9d39de0e6064d7574830094a3028f31cea418843560027
MISC metadata.xml 493 BLAKE2B 99fd8405920676653bbb75a4d71b81789d03638b4ad3970a23d3335c9af73fad4947000f40f6a211fc3ab9e1362d5cd19eeb26d80e93bc8d0838fdddaf179ed9 SHA512 5ad93bfef807b5d88adec2773e6496a4462f7e000ac15d4d4e7ea9b0646d530290bd9d7be23de31c5bfd33e352b2ea66fc3937ef417ffcc93232842132db3b6d
diff --git a/dev-util/bugbite-cli/bugbite-cli-0.0.7-r1.ebuild b/dev-util/bugbite-cli/bugbite-cli-0.0.7-r1.ebuild
new file mode 100644
index 000000000000..8389e8b00161
--- /dev/null
+++ b/dev-util/bugbite-cli/bugbite-cli-0.0.7-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cargo edo shell-completion
+
+DESCRIPTION="A command line tool for bug, issue, and ticket mangling"
+HOMEPAGE="https://github.com/radhermit/bugbite"
+SRC_URI="https://github.com/radhermit/bugbite/releases/download/${P}/${P}.tar.xz"
+LICENSE="0BSD Apache-2.0 Apache-2.0-with-LLVM-exceptions BSD BSD-2 Boost-1.0 CC0-1.0 ISC MIT MPL-2.0 Unicode-DFS-2016 Unlicense ZLIB"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="static test"
+RESTRICT="!test? ( test ) "
+
+BDEPEND="
+ >=virtual/rust-1.75
+ test? ( dev-util/cargo-nextest )
+"
+
+QA_FLAGS_IGNORED="usr/bin/bite"
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != binary ]] && use static ; then
+ local rust_target=$( rustc -vV 2>/dev/null | sed -n 's|^host: ||p' )
+ [[ -z ${rust_target} ]] && die "Failed to read host target from rustc!"
+ export RUSTFLAGS="-C target-feature=+crt-static ${RUSTFLAGS}"
+ export static_stuff="--target ${rust_target}"
+ fi
+}
+
+src_configure() {
+ cargo_src_configure ${static_stuff}
+}
+
+src_test() {
+ edo cargo nextest run $(usev !debug '--release') --color always --all-features --tests ${static_stuff}
+}
+
+src_install() {
+ cargo_src_install
+
+ doman man/*
+ dofishcomp shell/bite.fish
+ dozshcomp shell/_bite
+ newbashcomp shell/bite.bash bite
+}