summaryrefslogtreecommitdiff
path: root/dev-util/yamllint
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-13 01:35:20 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-13 01:35:20 +0100
commitc5806fcd6b740ecbd62f4fb2e09d8c8dfa2966fc (patch)
tree32b0c57abadad13ba25305af959e636eb410bee0 /dev-util/yamllint
parentad4a5451f677f33e2de05548b45fb92a8b3d04da (diff)
gentoo auto-resync : 13:07:2022 - 01:35:20
Diffstat (limited to 'dev-util/yamllint')
-rw-r--r--dev-util/yamllint/Manifest2
-rw-r--r--dev-util/yamllint/yamllint-1.27.1.ebuild23
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-util/yamllint/Manifest b/dev-util/yamllint/Manifest
index 4636674177aa..cd3fd2e07b88 100644
--- a/dev-util/yamllint/Manifest
+++ b/dev-util/yamllint/Manifest
@@ -1,3 +1,5 @@
DIST yamllint-1.26.3.tar.gz 126746 BLAKE2B 37d4293a90b2ee7192e26c5dbb1448a2c22a47e8dae7113211bb5601f0ef0c01eabd85fe4df44b32b8226b2b805c1da11ef1e118f5e33a2a7bab137141f9853c SHA512 c5ed17ecec102324bec077484dcede6fbf8c01a37a9292929a52163a4a9d9e9989809879c29b69c45b7cce8cbeefc830d4542118f617e846702f216f49d9db5b
+DIST yamllint-1.27.1.tar.gz 129052 BLAKE2B 37021bd577384821b75ddd747f1dd3c4261317582d42179e0731214cb67f79bf9302c34acaa721440edb118ef8900cc2952d1f8e441def9e3143b57e03af87bd SHA512 c00fcb5da35f79b0f877f1b8c3e5f1ff8c5d161dd795d3a2657e44e27d8b943961984bf15c294be263e00bf9dfcaf3dbf16ef8fd7354bedc8ed92e3e24ce4baf
EBUILD yamllint-1.26.3-r1.ebuild 595 BLAKE2B 3a669b2813aad8bd7fc719a019db4fa5280defeda317d0bc967ff7d9b8c1b5120518748e94d6ad199b4af3022e5e46f86edc654e9315f85fe8178c907ec92770 SHA512 dafafcaa9c358fc9f1f256f968fcd2b3fce0bef452be8c2f68a6ff823416a365463e7d15b80372a9d1f4031657a95f3a67d26f3c023535edfb4cc35c96c79cfe
+EBUILD yamllint-1.27.1.ebuild 596 BLAKE2B 7469661a4cad539c96a01d9ef32ab7be46acf050983ecb61600d960b01acf0df6754ed064b5c958f4ffa03b3fece9bc8e07adf9f84b058f6a748f54ea9463f30 SHA512 85cbc2c06a0e93a0719d56c94b134cd7c67a9dcbace55c2f0cffa3635fd241ab5391e4eee91ad3c14dc3358b1085b80fb50d8486fa2e925ac2aa4616efa2d29b
MISC metadata.xml 401 BLAKE2B a521c886cfd44743e875bcb3a5901f555bf13829b1697a4673c99d728559959460a150b717b6568a3fdcf82c73a8425997bafae1f5f8afaa30a0d43862e7a730 SHA512 52b259b62b147104c3150477c41b37697ad55ac5ce074be70568d001c15c1da099a1f2877a193164ccb9871d7fb6275bef12aba110cf83d5f04c4dfb30e156c9
diff --git a/dev-util/yamllint/yamllint-1.27.1.ebuild b/dev-util/yamllint/yamllint-1.27.1.ebuild
new file mode 100644
index 000000000000..7ebbb2e782d0
--- /dev/null
+++ b/dev-util/yamllint/yamllint-1.27.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="A linter for YAML files"
+HOMEPAGE="https://pypi.org/project/yamllint/ https://github.com/adrienverge/yamllint/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND=">=dev-python/pathspec-0.5.3[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest