summaryrefslogtreecommitdiff
path: root/dev-util/yamllint
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-16 17:15:17 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-16 17:15:17 +0100
commit6e356edde093fb3589ab7a5859685e85c2873ab0 (patch)
tree5f17cc7bfbddda45678967fdc0a5f9f35fa9c02a /dev-util/yamllint
parentacb0389058b8ef612d851b1ab54fa37376c4b7f7 (diff)
gentoo auto-resync : 16:09:2022 - 17:15:17
Diffstat (limited to 'dev-util/yamllint')
-rw-r--r--dev-util/yamllint/Manifest2
-rw-r--r--dev-util/yamllint/yamllint-1.28.0.ebuild23
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-util/yamllint/Manifest b/dev-util/yamllint/Manifest
index 424f8ffe9ede..54074ed6ba1c 100644
--- a/dev-util/yamllint/Manifest
+++ b/dev-util/yamllint/Manifest
@@ -1,3 +1,5 @@
DIST yamllint-1.27.1.tar.gz 129052 BLAKE2B 37021bd577384821b75ddd747f1dd3c4261317582d42179e0731214cb67f79bf9302c34acaa721440edb118ef8900cc2952d1f8e441def9e3143b57e03af87bd SHA512 c00fcb5da35f79b0f877f1b8c3e5f1ff8c5d161dd795d3a2657e44e27d8b943961984bf15c294be263e00bf9dfcaf3dbf16ef8fd7354bedc8ed92e3e24ce4baf
+DIST yamllint-1.28.0.tar.gz 121934 BLAKE2B 6c93b7f45cab49159f6a36aa24ac303455432734fcb90f75cf80551eb2c5a78c9695e76f968aa7e22ad976accd0257567d85d7ac24474695dbe3e4dcf7f6eea3 SHA512 9d811616f5a2c8c9574ef74afd2548c415881386932e4ee9b29311c3ef32150ed868943bcef19b31226d9a31f0be384e0ee3b3ec86cebf0d7c4216696a6b0161
EBUILD yamllint-1.27.1.ebuild 612 BLAKE2B 5e441c366ff621f05e27940e382b9912dd4adfaf7eec3bdc883c9e71cd6c5130e5ba2712ff3028326ff6a5ec2df1a88fc14405b747df514c4e0d6b09fe88cf1c SHA512 d169033f5da10947c7dfa768af65929f035b6551a99c146f7c03774563465515735fb806fd43d10e7a74c5c92a72b76a601bcec19f5a31844a6529c8ab3c9bb9
+EBUILD yamllint-1.28.0.ebuild 613 BLAKE2B 333eb7ba0465e57f53bfa953df0f00dfdf998588711f04c7fc2989f09dff7f28c0968b647f5d540e82bc5193ff7d8848f18f66a0947710a8b2aca693f2f1803e SHA512 3f8e25365c8ac2cc394c42eee666eab1ef399a99dff7ecb62fc2bb4b0b174dbaed29b2003d856f1a3046166281711c13c488bfd6181e5504f0e524ece65c894e
MISC metadata.xml 401 BLAKE2B a521c886cfd44743e875bcb3a5901f555bf13829b1697a4673c99d728559959460a150b717b6568a3fdcf82c73a8425997bafae1f5f8afaa30a0d43862e7a730 SHA512 52b259b62b147104c3150477c41b37697ad55ac5ce074be70568d001c15c1da099a1f2877a193164ccb9871d7fb6275bef12aba110cf83d5f04c4dfb30e156c9
diff --git a/dev-util/yamllint/yamllint-1.28.0.ebuild b/dev-util/yamllint/yamllint-1.28.0.ebuild
new file mode 100644
index 000000000000..69cc6355b3e2
--- /dev/null
+++ b/dev-util/yamllint/yamllint-1.28.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="A linter for YAML files"
+HOMEPAGE="https://pypi.org/project/yamllint/ https://github.com/adrienverge/yamllint/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND=">=dev-python/pathspec-0.5.3[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest