summaryrefslogtreecommitdiff
path: root/dev-util/wstool
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-util/wstool
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-util/wstool')
-rw-r--r--dev-util/wstool/Manifest4
-rw-r--r--dev-util/wstool/wstool-0.1.18.ebuild43
-rw-r--r--dev-util/wstool/wstool-9999.ebuild43
3 files changed, 36 insertions, 54 deletions
diff --git a/dev-util/wstool/Manifest b/dev-util/wstool/Manifest
index 4621847ffc79..d8b73ff27ee1 100644
--- a/dev-util/wstool/Manifest
+++ b/dev-util/wstool/Manifest
@@ -1,4 +1,4 @@
DIST wstool-0.1.18.tar.gz 80595 BLAKE2B ed90fc5c63ab5d775dfb49ddacc6da6e285aeb5078cf471c0d504659a9e322fde27797e4d05fd56dff4b9958558200cf05e46cf7ae71fd1231ab63048e668808 SHA512 fda9c679183c605048ed024a57b07fd2d9b644978a3e4ff89c3716b74d8e4ba0124779bcdf88a75fdbbf47c765b7ab63db7c84a55a6e1744fc6f955649590c48
-EBUILD wstool-0.1.18.ebuild 1435 BLAKE2B cce676217e08bdec531eb15ff9ca203cf9e983dcc2876b4c60f0dbf5c8a18c22dbd9226e818758a01164d6a49fa7c9d184d653ecf2eb93f2f18bb38ec30dcddf SHA512 bb18b857666e08828835c8bb94cfab06c1749490a0f12078f4aeed753b61538165dd89c008ebec03a6c7fd5cce584417480a5d7b5dbc5139cd23ce6789ff569b
-EBUILD wstool-9999.ebuild 1435 BLAKE2B cce676217e08bdec531eb15ff9ca203cf9e983dcc2876b4c60f0dbf5c8a18c22dbd9226e818758a01164d6a49fa7c9d184d653ecf2eb93f2f18bb38ec30dcddf SHA512 bb18b857666e08828835c8bb94cfab06c1749490a0f12078f4aeed753b61538165dd89c008ebec03a6c7fd5cce584417480a5d7b5dbc5139cd23ce6789ff569b
+EBUILD wstool-0.1.18.ebuild 1256 BLAKE2B 94a2e2aeb7134b290741cfde5d1802332489ec0af3a5f3792fcb3e8a5ae0625f457b8d9f63b447bd08f006bdbc7648b1a30e8c87d2f87e3cd605e952990e5c94 SHA512 02b08b0dd6cf15db7de57f8f942b2a60b91d9ea844a179a605ba8200aee4cbb4cc1263cb95b333411971f10f21a0d7a34a3025fa898ebaa8d381e2e52f870427
+EBUILD wstool-9999.ebuild 1256 BLAKE2B 94a2e2aeb7134b290741cfde5d1802332489ec0af3a5f3792fcb3e8a5ae0625f457b8d9f63b447bd08f006bdbc7648b1a30e8c87d2f87e3cd605e952990e5c94 SHA512 02b08b0dd6cf15db7de57f8f942b2a60b91d9ea844a179a605ba8200aee4cbb4cc1263cb95b333411971f10f21a0d7a34a3025fa898ebaa8d381e2e52f870427
MISC metadata.xml 330 BLAKE2B 621e47f88d4d67ce9b72775dac0e6066b1f56e0683585e72f70a820ed655c80d76fa4c451e9a5ca179d176c8fb9ab29a4949c26c2cfbf97ef31e4c767c8960ff SHA512 fef9cedb34e14f5fdbbc9e244d01c82f953fea9b299512352c11d9315d1748b8ffb63469caf1e00a0122b70f8376593e6a58ab20928865f35a57f511eb903634
diff --git a/dev-util/wstool/wstool-0.1.18.ebuild b/dev-util/wstool/wstool-0.1.18.ebuild
index 48cc34f6d138..643dad95a575 100644
--- a/dev-util/wstool/wstool-0.1.18.ebuild
+++ b/dev-util/wstool/wstool-0.1.18.ebuild
@@ -1,21 +1,18 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{3_7,3_8} )
-SCM=""
-if [ "${PV#9999}" != "${PV}" ] ; then
- SCM="git-r3"
- EGIT_REPO_URI="https://github.com/vcstools/wstool"
-fi
-
-inherit ${SCM} distutils-r1
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_IN_SOURCE_BUILD="yes"
+inherit distutils-r1
DESCRIPTION="Commands to manage several local SCM repositories for ROS"
HOMEPAGE="https://wiki.ros.org/wstool"
-if [ "${PV#9999}" != "${PV}" ] ; then
- SRC_URI=""
+
+if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/vcstools/wstool"
else
SRC_URI="http://download.ros.org/downloads/${PN}/${P}.tar.gz
https://github.com/vcstools/wstool/archive/${PV}.tar.gz -> ${P}.tar.gz
@@ -25,38 +22,32 @@ fi
LICENSE="BSD"
SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND="
dev-python/pyyaml[${PYTHON_USEDEP}]
>=dev-python/vcstools-0.1.38[${PYTHON_USEDEP}]
"
-DEPEND="${RDEPEND}
+BDEPEND="${RDEPEND}
+ dev-python/sphinx
test? (
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/coverage[${PYTHON_USEDEP}]
dev-vcs/git
dev-vcs/bzr
dev-vcs/mercurial
dev-vcs/subversion
)
"
-BDEPEND="
- dev-python/sphinx
-"
-DISTUTILS_IN_SOURCE_BUILD="yes"
+distutils_enable_tests nose
-python_test() {
+src_test() {
# From travis.yml
# Set git config to silence some stuff in the tests
- git config --global user.email "foo@example.com"
- git config --global user.name "Foo Bar"
+ git config --global user.email "foo@example.com" || die
+ git config --global user.name "Foo Bar" || die
# Set the hg user
- echo -e "[ui]\nusername = Your Name <your@mail.com>" >> ~/.hgrc
+ echo -e "[ui]\nusername = Your Name <your@mail.com>" >> ~/.hgrc || die
# Set the bzr user
- bzr whoami "Your Name <name@example.com>"
+ bzr whoami "Your Name <name@example.com>" || die
# command to run tests
- nosetests --with-coverage --cover-package=wstool || die
+ distutils-r1_src_test
}
diff --git a/dev-util/wstool/wstool-9999.ebuild b/dev-util/wstool/wstool-9999.ebuild
index 48cc34f6d138..643dad95a575 100644
--- a/dev-util/wstool/wstool-9999.ebuild
+++ b/dev-util/wstool/wstool-9999.ebuild
@@ -1,21 +1,18 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{3_7,3_8} )
-SCM=""
-if [ "${PV#9999}" != "${PV}" ] ; then
- SCM="git-r3"
- EGIT_REPO_URI="https://github.com/vcstools/wstool"
-fi
-
-inherit ${SCM} distutils-r1
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_IN_SOURCE_BUILD="yes"
+inherit distutils-r1
DESCRIPTION="Commands to manage several local SCM repositories for ROS"
HOMEPAGE="https://wiki.ros.org/wstool"
-if [ "${PV#9999}" != "${PV}" ] ; then
- SRC_URI=""
+
+if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/vcstools/wstool"
else
SRC_URI="http://download.ros.org/downloads/${PN}/${P}.tar.gz
https://github.com/vcstools/wstool/archive/${PV}.tar.gz -> ${P}.tar.gz
@@ -25,38 +22,32 @@ fi
LICENSE="BSD"
SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND="
dev-python/pyyaml[${PYTHON_USEDEP}]
>=dev-python/vcstools-0.1.38[${PYTHON_USEDEP}]
"
-DEPEND="${RDEPEND}
+BDEPEND="${RDEPEND}
+ dev-python/sphinx
test? (
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/coverage[${PYTHON_USEDEP}]
dev-vcs/git
dev-vcs/bzr
dev-vcs/mercurial
dev-vcs/subversion
)
"
-BDEPEND="
- dev-python/sphinx
-"
-DISTUTILS_IN_SOURCE_BUILD="yes"
+distutils_enable_tests nose
-python_test() {
+src_test() {
# From travis.yml
# Set git config to silence some stuff in the tests
- git config --global user.email "foo@example.com"
- git config --global user.name "Foo Bar"
+ git config --global user.email "foo@example.com" || die
+ git config --global user.name "Foo Bar" || die
# Set the hg user
- echo -e "[ui]\nusername = Your Name <your@mail.com>" >> ~/.hgrc
+ echo -e "[ui]\nusername = Your Name <your@mail.com>" >> ~/.hgrc || die
# Set the bzr user
- bzr whoami "Your Name <name@example.com>"
+ bzr whoami "Your Name <name@example.com>" || die
# command to run tests
- nosetests --with-coverage --cover-package=wstool || die
+ distutils-r1_src_test
}