summaryrefslogtreecommitdiff
path: root/dev-util/wstool
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-util/wstool
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/wstool')
-rw-r--r--dev-util/wstool/Manifest7
-rw-r--r--dev-util/wstool/files/prefix2.patch26
-rw-r--r--dev-util/wstool/metadata.xml11
-rw-r--r--dev-util/wstool/wstool-0.1.13.ebuild61
-rw-r--r--dev-util/wstool/wstool-0.1.17.ebuild61
-rw-r--r--dev-util/wstool/wstool-9999.ebuild61
6 files changed, 227 insertions, 0 deletions
diff --git a/dev-util/wstool/Manifest b/dev-util/wstool/Manifest
new file mode 100644
index 000000000000..32fa552af5e0
--- /dev/null
+++ b/dev-util/wstool/Manifest
@@ -0,0 +1,7 @@
+AUX prefix2.patch 1031 BLAKE2B 489bc334d6119f1175bf4ea671644ae1878a680b237c424f73ae99ebc20e398d070716bce1df2fa554da382882385693ead202b19af1aaf979b4eff3639dc5b5 SHA512 747b973ec84a31213de84fc15f40d4d9dce854a32602b3dffaac088992578a07f48047358bf7c38b6ca597c251232f48432404836cb2304f5423db4ddf2f9345
+DIST wstool-0.1.13.tar.gz 75188 BLAKE2B 6a34aa04e4a076a75dacf24faf789d5295f6ad9afbbdddae480d8cdd11db63940faeca2c5936a2432aeccae5274e2e9e4e824f303460fe96f95c0d17abeeb9c1 SHA512 4d54f78ca044d31d927de1c3387536d0447ece77672c555845adf54e47f07adb67e6e9c866bc2719aae468aeeb26c900b3784e0ec7cf014c8118e841a92dca14
+DIST wstool-0.1.17.tar.gz 76168 BLAKE2B 4862df0ff16a5102e42d3ed683dbd9e8eb432aaf44f6e641fba6bb6f5d962645685b0fc9ca11f3c8adbe15dbef33086b93e3f9136073f7f181b5da37522e28fa SHA512 13533354a40723137baadc125425a2ec3d6a441da4870f04a9e17c53509ee4d3dc27df1a59edc2c3985a05fbd66a045539e9814f73509ee527fb763f8a804626
+EBUILD wstool-0.1.13.ebuild 1455 BLAKE2B 4e6426b563f90641ec27db893bb7980a8cb90bf3527f05a88bd65bb1ba6407abef549831b08ee54339a95810f065ed0456cbfb0decab86be3479b322cf1249fa SHA512 b92eaabaf6197e82d72ec20faf6af57a36912192a13576e5bcd52c88c99cb08c75f6cf5958b64d3c931c28201c1f15371c93c83529093d6d49c9883af878c5cf
+EBUILD wstool-0.1.17.ebuild 1459 BLAKE2B 9598cc74373117ea94f5eb862a7f2bbe11932f1d43d750651354280da580ed01d6b1ba0b905b411916821d365aa6eb7829c1dc64ecb801c112212e8c548cf138 SHA512 83e34adf6f66c2fd00eae5a327f29e5dccf8798c139eba5a49aa65791d8186a4d1bce56bc0e246576e500c2b2c1643a0445c8f93f2d94e2d9f507db768f2d9bb
+EBUILD wstool-9999.ebuild 1459 BLAKE2B 9598cc74373117ea94f5eb862a7f2bbe11932f1d43d750651354280da580ed01d6b1ba0b905b411916821d365aa6eb7829c1dc64ecb801c112212e8c548cf138 SHA512 83e34adf6f66c2fd00eae5a327f29e5dccf8798c139eba5a49aa65791d8186a4d1bce56bc0e246576e500c2b2c1643a0445c8f93f2d94e2d9f507db768f2d9bb
+MISC metadata.xml 329 BLAKE2B ffdb449cef2fa449771425241f9a03b49d915bed8abc73329586e9a2873e41ac669e4a347ed6f2cabc92b7132a741d5fcc79f13a9d900f7fced17fba322c460c SHA512 7bedf1430c3a2e5a8c98701ef48ce3a97ac59bebe3d42e19da193480c97ef0b2020916c7582f4083ebbf361b5c66b17ad1bfa7889e8aa62d3c945ba8dcf5b62f
diff --git a/dev-util/wstool/files/prefix2.patch b/dev-util/wstool/files/prefix2.patch
new file mode 100644
index 000000000000..934443f98707
--- /dev/null
+++ b/dev-util/wstool/files/prefix2.patch
@@ -0,0 +1,26 @@
+Index: wstool-0.1.13/setup.py
+===================================================================
+--- wstool-0.1.13.orig/setup.py
++++ wstool-0.1.13/setup.py
+@@ -26,18 +26,11 @@ def _resolve_prefix(prefix, type):
+ # issue: https://github.com/vcstools/wstool/issues/81
+ osx_system_prefix = '/System/Library/Frameworks/Python.framework/Versions'
+ if type == 'man':
+- if prefix == '/usr':
+- return '/usr/share'
+- if sys.prefix.startswith(osx_system_prefix):
+- return '/usr/local/share'
++ return os.path.join(prefix, 'share')
+ elif type == 'bash_comp':
+- if prefix == '/usr':
+- return '/'
+- if sys.prefix.startswith(osx_system_prefix):
+- return '/usr/local'
++ return os.path.join(prefix, '../')
+ elif type == 'zsh_comp':
+- if sys.prefix.startswith(osx_system_prefix):
+- return '/usr/local'
++ return os.path.join(prefix, '../')
+ else:
+ raise ValueError('not supported type')
+ return prefix
diff --git a/dev-util/wstool/metadata.xml b/dev-util/wstool/metadata.xml
new file mode 100644
index 000000000000..8df7d893c82b
--- /dev/null
+++ b/dev-util/wstool/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">vcstools/wstool</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-util/wstool/wstool-0.1.13.ebuild b/dev-util/wstool/wstool-0.1.13.ebuild
new file mode 100644
index 000000000000..68bf771bb166
--- /dev/null
+++ b/dev-util/wstool/wstool-0.1.13.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/vcstools/wstool"
+fi
+
+inherit ${SCM} distutils-r1
+
+DESCRIPTION="Commands to manage several local SCM repositories for ROS"
+HOMEPAGE="http://wiki.ros.org/wstool"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://download.ros.org/downloads/${PN}/${P}.tar.gz
+ https://github.com/vcstools/wstool/archive/${PV}.tar.gz -> ${P}.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/vcstools-0.1.38[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/sphinx
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-vcs/git
+ dev-vcs/bzr
+ dev-vcs/mercurial
+ dev-vcs/subversion
+ )
+"
+
+PATCHES=( "${FILESDIR}/prefix2.patch" )
+DISTUTILS_IN_SOURCE_BUILD="yes"
+
+python_test() {
+ # From travis.yml
+ # Set git config to silence some stuff in the tests
+ git config --global user.email "foo@example.com"
+ git config --global user.name "Foo Bar"
+ # Set the hg user
+ echo -e "[ui]\nusername = Your Name <your@mail.com>" >> ~/.hgrc
+ # Set the bzr user
+ bzr whoami "Your Name <name@example.com>"
+ # command to run tests
+ nosetests --with-coverage --cover-package=wstool || die
+}
diff --git a/dev-util/wstool/wstool-0.1.17.ebuild b/dev-util/wstool/wstool-0.1.17.ebuild
new file mode 100644
index 000000000000..0c19d47c0322
--- /dev/null
+++ b/dev-util/wstool/wstool-0.1.17.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/vcstools/wstool"
+fi
+
+inherit ${SCM} distutils-r1
+
+DESCRIPTION="Commands to manage several local SCM repositories for ROS"
+HOMEPAGE="http://wiki.ros.org/wstool"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://download.ros.org/downloads/${PN}/${P}.tar.gz
+ https://github.com/vcstools/wstool/archive/${PV}.tar.gz -> ${P}.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/vcstools-0.1.38[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/sphinx
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-vcs/git
+ dev-vcs/bzr
+ dev-vcs/mercurial
+ dev-vcs/subversion
+ )
+"
+
+PATCHES=( "${FILESDIR}/prefix2.patch" )
+DISTUTILS_IN_SOURCE_BUILD="yes"
+
+python_test() {
+ # From travis.yml
+ # Set git config to silence some stuff in the tests
+ git config --global user.email "foo@example.com"
+ git config --global user.name "Foo Bar"
+ # Set the hg user
+ echo -e "[ui]\nusername = Your Name <your@mail.com>" >> ~/.hgrc
+ # Set the bzr user
+ bzr whoami "Your Name <name@example.com>"
+ # command to run tests
+ nosetests --with-coverage --cover-package=wstool || die
+}
diff --git a/dev-util/wstool/wstool-9999.ebuild b/dev-util/wstool/wstool-9999.ebuild
new file mode 100644
index 000000000000..0c19d47c0322
--- /dev/null
+++ b/dev-util/wstool/wstool-9999.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/vcstools/wstool"
+fi
+
+inherit ${SCM} distutils-r1
+
+DESCRIPTION="Commands to manage several local SCM repositories for ROS"
+HOMEPAGE="http://wiki.ros.org/wstool"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://download.ros.org/downloads/${PN}/${P}.tar.gz
+ https://github.com/vcstools/wstool/archive/${PV}.tar.gz -> ${P}.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/vcstools-0.1.38[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/sphinx
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-vcs/git
+ dev-vcs/bzr
+ dev-vcs/mercurial
+ dev-vcs/subversion
+ )
+"
+
+PATCHES=( "${FILESDIR}/prefix2.patch" )
+DISTUTILS_IN_SOURCE_BUILD="yes"
+
+python_test() {
+ # From travis.yml
+ # Set git config to silence some stuff in the tests
+ git config --global user.email "foo@example.com"
+ git config --global user.name "Foo Bar"
+ # Set the hg user
+ echo -e "[ui]\nusername = Your Name <your@mail.com>" >> ~/.hgrc
+ # Set the bzr user
+ bzr whoami "Your Name <name@example.com>"
+ # command to run tests
+ nosetests --with-coverage --cover-package=wstool || die
+}