summaryrefslogtreecommitdiff
path: root/dev-util/wstool
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-util/wstool
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-util/wstool')
-rw-r--r--dev-util/wstool/Manifest6
-rw-r--r--dev-util/wstool/files/prefix2.patch26
-rw-r--r--dev-util/wstool/metadata.xml11
-rw-r--r--dev-util/wstool/wstool-0.1.13.ebuild61
-rw-r--r--dev-util/wstool/wstool-9999.ebuild61
5 files changed, 165 insertions, 0 deletions
diff --git a/dev-util/wstool/Manifest b/dev-util/wstool/Manifest
new file mode 100644
index 000000000000..c5ee6cf3d1d4
--- /dev/null
+++ b/dev-util/wstool/Manifest
@@ -0,0 +1,6 @@
+AUX prefix2.patch 1031 SHA256 6a20d84bf6bce6a56e9221ae179a57bdc0b705a0badc4f2148b5bef295c73e60 SHA512 747b973ec84a31213de84fc15f40d4d9dce854a32602b3dffaac088992578a07f48047358bf7c38b6ca597c251232f48432404836cb2304f5423db4ddf2f9345 WHIRLPOOL ca0bec5536de06c4f9bc868afb9ccc3d2ccd219079cb07a2cb84645912473e40bc1a8da7037ffceddbdcb61ab67aa076202a7993c0c66c63861f3220b02cb688
+DIST wstool-0.1.13.tar.gz 75188 SHA256 97db71105728b3bed1828c85becfb1216b95f8b2776d94e280ad1875f2196160 SHA512 4d54f78ca044d31d927de1c3387536d0447ece77672c555845adf54e47f07adb67e6e9c866bc2719aae468aeeb26c900b3784e0ec7cf014c8118e841a92dca14 WHIRLPOOL 3ef703a5eafc2ac8f80b76fdb91de789921c89fa15b3f8457979e84dafc86a9d2d957d053e430dc75784d85912008617bd1c2418432e60873bb199af561e845b
+EBUILD wstool-0.1.13.ebuild 1455 SHA256 6a987a5b0a131e3c20fadfda7349d08f14c39fce9e30f06fe26e7c4871ebf51a SHA512 b92eaabaf6197e82d72ec20faf6af57a36912192a13576e5bcd52c88c99cb08c75f6cf5958b64d3c931c28201c1f15371c93c83529093d6d49c9883af878c5cf WHIRLPOOL d9344ba1853b506073bf82431e455607fc294e4acc903840d231bd04aa813970f00f16245ded0b83a8af5c20c21219e645f64d2e12f69a46a46bed3d0b6c9d98
+EBUILD wstool-9999.ebuild 1455 SHA256 6a987a5b0a131e3c20fadfda7349d08f14c39fce9e30f06fe26e7c4871ebf51a SHA512 b92eaabaf6197e82d72ec20faf6af57a36912192a13576e5bcd52c88c99cb08c75f6cf5958b64d3c931c28201c1f15371c93c83529093d6d49c9883af878c5cf WHIRLPOOL d9344ba1853b506073bf82431e455607fc294e4acc903840d231bd04aa813970f00f16245ded0b83a8af5c20c21219e645f64d2e12f69a46a46bed3d0b6c9d98
+MISC ChangeLog 2354 SHA256 2d939f5224ecb8c52e8343b3cb44e19a95a4676cec248193d0292675b3284371 SHA512 d20e0f9019b2713f88116819175171f7bbfddde0e1f92d437586839751230482b2fbcd65a55f8b9b0b3f230f3e3c6336084f77817b8e3f1bc74e71e3b52b86ba WHIRLPOOL 69207e236b43601e3d726ec76f903ec6bf8ac4039602f5fef6ea4e9656deb0120bea8349e24f6fbce12ce4f8e0f95405ff35de4c088e2474266887e70e14fdb2
+MISC metadata.xml 329 SHA256 1651f6e2c507421d71e90852d8e60dca21d711863e6394519938d0ad264bac45 SHA512 7bedf1430c3a2e5a8c98701ef48ce3a97ac59bebe3d42e19da193480c97ef0b2020916c7582f4083ebbf361b5c66b17ad1bfa7889e8aa62d3c945ba8dcf5b62f WHIRLPOOL 8aa9a793f15450def2a6148543d024e61b04a214742e782db0264908d5739423342bbc7ea574671593c7ccdaef33bb106b1c9396c274c6db0a017149984314e7
diff --git a/dev-util/wstool/files/prefix2.patch b/dev-util/wstool/files/prefix2.patch
new file mode 100644
index 000000000000..934443f98707
--- /dev/null
+++ b/dev-util/wstool/files/prefix2.patch
@@ -0,0 +1,26 @@
+Index: wstool-0.1.13/setup.py
+===================================================================
+--- wstool-0.1.13.orig/setup.py
++++ wstool-0.1.13/setup.py
+@@ -26,18 +26,11 @@ def _resolve_prefix(prefix, type):
+ # issue: https://github.com/vcstools/wstool/issues/81
+ osx_system_prefix = '/System/Library/Frameworks/Python.framework/Versions'
+ if type == 'man':
+- if prefix == '/usr':
+- return '/usr/share'
+- if sys.prefix.startswith(osx_system_prefix):
+- return '/usr/local/share'
++ return os.path.join(prefix, 'share')
+ elif type == 'bash_comp':
+- if prefix == '/usr':
+- return '/'
+- if sys.prefix.startswith(osx_system_prefix):
+- return '/usr/local'
++ return os.path.join(prefix, '../')
+ elif type == 'zsh_comp':
+- if sys.prefix.startswith(osx_system_prefix):
+- return '/usr/local'
++ return os.path.join(prefix, '../')
+ else:
+ raise ValueError('not supported type')
+ return prefix
diff --git a/dev-util/wstool/metadata.xml b/dev-util/wstool/metadata.xml
new file mode 100644
index 000000000000..8df7d893c82b
--- /dev/null
+++ b/dev-util/wstool/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">vcstools/wstool</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-util/wstool/wstool-0.1.13.ebuild b/dev-util/wstool/wstool-0.1.13.ebuild
new file mode 100644
index 000000000000..68bf771bb166
--- /dev/null
+++ b/dev-util/wstool/wstool-0.1.13.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/vcstools/wstool"
+fi
+
+inherit ${SCM} distutils-r1
+
+DESCRIPTION="Commands to manage several local SCM repositories for ROS"
+HOMEPAGE="http://wiki.ros.org/wstool"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://download.ros.org/downloads/${PN}/${P}.tar.gz
+ https://github.com/vcstools/wstool/archive/${PV}.tar.gz -> ${P}.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/vcstools-0.1.38[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/sphinx
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-vcs/git
+ dev-vcs/bzr
+ dev-vcs/mercurial
+ dev-vcs/subversion
+ )
+"
+
+PATCHES=( "${FILESDIR}/prefix2.patch" )
+DISTUTILS_IN_SOURCE_BUILD="yes"
+
+python_test() {
+ # From travis.yml
+ # Set git config to silence some stuff in the tests
+ git config --global user.email "foo@example.com"
+ git config --global user.name "Foo Bar"
+ # Set the hg user
+ echo -e "[ui]\nusername = Your Name <your@mail.com>" >> ~/.hgrc
+ # Set the bzr user
+ bzr whoami "Your Name <name@example.com>"
+ # command to run tests
+ nosetests --with-coverage --cover-package=wstool || die
+}
diff --git a/dev-util/wstool/wstool-9999.ebuild b/dev-util/wstool/wstool-9999.ebuild
new file mode 100644
index 000000000000..68bf771bb166
--- /dev/null
+++ b/dev-util/wstool/wstool-9999.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/vcstools/wstool"
+fi
+
+inherit ${SCM} distutils-r1
+
+DESCRIPTION="Commands to manage several local SCM repositories for ROS"
+HOMEPAGE="http://wiki.ros.org/wstool"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://download.ros.org/downloads/${PN}/${P}.tar.gz
+ https://github.com/vcstools/wstool/archive/${PV}.tar.gz -> ${P}.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/vcstools-0.1.38[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/sphinx
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-vcs/git
+ dev-vcs/bzr
+ dev-vcs/mercurial
+ dev-vcs/subversion
+ )
+"
+
+PATCHES=( "${FILESDIR}/prefix2.patch" )
+DISTUTILS_IN_SOURCE_BUILD="yes"
+
+python_test() {
+ # From travis.yml
+ # Set git config to silence some stuff in the tests
+ git config --global user.email "foo@example.com"
+ git config --global user.name "Foo Bar"
+ # Set the hg user
+ echo -e "[ui]\nusername = Your Name <your@mail.com>" >> ~/.hgrc
+ # Set the bzr user
+ bzr whoami "Your Name <name@example.com>"
+ # command to run tests
+ nosetests --with-coverage --cover-package=wstool || die
+}