summaryrefslogtreecommitdiff
path: root/dev-util/wstool
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-16 17:34:21 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-16 17:34:21 +0000
commit02e2208f46f4e2c00fb9743cbc47350bdd233bfa (patch)
tree132dd60828854db4f65f30f9230f43d9602507ff /dev-util/wstool
parent8be70107efbb417f839292165ee39d07a062046f (diff)
gentoo resync : 16.01.2018
Diffstat (limited to 'dev-util/wstool')
-rw-r--r--dev-util/wstool/Manifest2
-rw-r--r--dev-util/wstool/wstool-0.1.17.ebuild61
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-util/wstool/Manifest b/dev-util/wstool/Manifest
index dcde5918d169..adaa9e2cf272 100644
--- a/dev-util/wstool/Manifest
+++ b/dev-util/wstool/Manifest
@@ -1,5 +1,7 @@
AUX prefix2.patch 1031 BLAKE2B 489bc334d6119f1175bf4ea671644ae1878a680b237c424f73ae99ebc20e398d070716bce1df2fa554da382882385693ead202b19af1aaf979b4eff3639dc5b5 SHA512 747b973ec84a31213de84fc15f40d4d9dce854a32602b3dffaac088992578a07f48047358bf7c38b6ca597c251232f48432404836cb2304f5423db4ddf2f9345
DIST wstool-0.1.13.tar.gz 75188 BLAKE2B 6a34aa04e4a076a75dacf24faf789d5295f6ad9afbbdddae480d8cdd11db63940faeca2c5936a2432aeccae5274e2e9e4e824f303460fe96f95c0d17abeeb9c1 SHA512 4d54f78ca044d31d927de1c3387536d0447ece77672c555845adf54e47f07adb67e6e9c866bc2719aae468aeeb26c900b3784e0ec7cf014c8118e841a92dca14
+DIST wstool-0.1.17.tar.gz 76168 BLAKE2B 4862df0ff16a5102e42d3ed683dbd9e8eb432aaf44f6e641fba6bb6f5d962645685b0fc9ca11f3c8adbe15dbef33086b93e3f9136073f7f181b5da37522e28fa SHA512 13533354a40723137baadc125425a2ec3d6a441da4870f04a9e17c53509ee4d3dc27df1a59edc2c3985a05fbd66a045539e9814f73509ee527fb763f8a804626
EBUILD wstool-0.1.13.ebuild 1455 BLAKE2B 4e6426b563f90641ec27db893bb7980a8cb90bf3527f05a88bd65bb1ba6407abef549831b08ee54339a95810f065ed0456cbfb0decab86be3479b322cf1249fa SHA512 b92eaabaf6197e82d72ec20faf6af57a36912192a13576e5bcd52c88c99cb08c75f6cf5958b64d3c931c28201c1f15371c93c83529093d6d49c9883af878c5cf
+EBUILD wstool-0.1.17.ebuild 1455 BLAKE2B 074eb1dcbe01cab0a3ae86279207642ba5051603c19077ed0ea52ae0cfa9003623dcd8562458bba60ce1a16be996eaf0433840856a2011c7c66602a790e444e0 SHA512 f59f23d2669288f3234f5e69421c4d496258d5e8264a9731741698791c3fadfd6e3f44280fcbb4d1bf1f48d3b4ba209f2b679cf2fabe82cafc5115bbd5ad7815
EBUILD wstool-9999.ebuild 1455 BLAKE2B 4e6426b563f90641ec27db893bb7980a8cb90bf3527f05a88bd65bb1ba6407abef549831b08ee54339a95810f065ed0456cbfb0decab86be3479b322cf1249fa SHA512 b92eaabaf6197e82d72ec20faf6af57a36912192a13576e5bcd52c88c99cb08c75f6cf5958b64d3c931c28201c1f15371c93c83529093d6d49c9883af878c5cf
MISC metadata.xml 329 BLAKE2B ffdb449cef2fa449771425241f9a03b49d915bed8abc73329586e9a2873e41ac669e4a347ed6f2cabc92b7132a741d5fcc79f13a9d900f7fced17fba322c460c SHA512 7bedf1430c3a2e5a8c98701ef48ce3a97ac59bebe3d42e19da193480c97ef0b2020916c7582f4083ebbf361b5c66b17ad1bfa7889e8aa62d3c945ba8dcf5b62f
diff --git a/dev-util/wstool/wstool-0.1.17.ebuild b/dev-util/wstool/wstool-0.1.17.ebuild
new file mode 100644
index 000000000000..5615dbd2b241
--- /dev/null
+++ b/dev-util/wstool/wstool-0.1.17.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/vcstools/wstool"
+fi
+
+inherit ${SCM} distutils-r1
+
+DESCRIPTION="Commands to manage several local SCM repositories for ROS"
+HOMEPAGE="http://wiki.ros.org/wstool"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://download.ros.org/downloads/${PN}/${P}.tar.gz
+ https://github.com/vcstools/wstool/archive/${PV}.tar.gz -> ${P}.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/vcstools-0.1.38[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/sphinx
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-vcs/git
+ dev-vcs/bzr
+ dev-vcs/mercurial
+ dev-vcs/subversion
+ )
+"
+
+PATCHES=( "${FILESDIR}/prefix2.patch" )
+DISTUTILS_IN_SOURCE_BUILD="yes"
+
+python_test() {
+ # From travis.yml
+ # Set git config to silence some stuff in the tests
+ git config --global user.email "foo@example.com"
+ git config --global user.name "Foo Bar"
+ # Set the hg user
+ echo -e "[ui]\nusername = Your Name <your@mail.com>" >> ~/.hgrc
+ # Set the bzr user
+ bzr whoami "Your Name <name@example.com>"
+ # command to run tests
+ nosetests --with-coverage --cover-package=wstool || die
+}