summaryrefslogtreecommitdiff
path: root/dev-util/wiggle/wiggle-1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-util/wiggle/wiggle-1.0.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/wiggle/wiggle-1.0.ebuild')
-rw-r--r--dev-util/wiggle/wiggle-1.0.ebuild64
1 files changed, 0 insertions, 64 deletions
diff --git a/dev-util/wiggle/wiggle-1.0.ebuild b/dev-util/wiggle/wiggle-1.0.ebuild
deleted file mode 100644
index 22f8dc34ed81..000000000000
--- a/dev-util/wiggle/wiggle-1.0.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit fixheadtails toolchain-funcs
-
-DESCRIPTION="tool for applying patches that patch cannot apply because of conflicting changes"
-HOMEPAGE="https://neil.brown.name/wiggle https://neil.brown.name/git?p=wiggle"
-SRC_URI="https://neil.brown.name/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-# The 'p' tool does support bitkeeper, but I'm against just dumping it in here
-# due to it's size. I've explictly listed every other dependancy here due to
-# the nature of the shell program 'p'
-RDEPEND="
- dev-util/diffstat
- dev-util/patchutils
- sys-apps/diffutils
- sys-apps/findutils
- virtual/awk
- sys-apps/grep
- sys-apps/less
- sys-apps/sed
- sys-apps/coreutils
- sys-devel/patch
- sys-libs/ncurses:0=
- "
-DEPEND="${RDEPEND}
- sys-apps/groff
- virtual/pkgconfig
- test? ( sys-process/time )"
-
-PATCHES=( "${FILESDIR}"/${P}-cflags.patch )
-
-src_prepare() {
- default
-
- # Fix the reference to the help file so `p help' works
- sed -i "s:\$0.help:${EPREFIX}/usr/share/wiggle/p.help:" p || die "sed failed on p"
-
- ht_fix_file p
-}
-
-src_compile() {
- emake CC="$(tc-getCC)" ${PN}
-}
-
-src_test() {
- # Use prefixed time binary
- emake TIME_CMD="${EPREFIX}/usr/bin/time" test
-}
-
-src_install() {
- dobin wiggle p
- doman wiggle.1
- dodoc ANNOUNCE INSTALL TODO DOC/Algorithm notes
- insinto /usr/share/wiggle
- doins p.help
-}