summaryrefslogtreecommitdiff
path: root/dev-util/watchman/files/watchman-2022.02.28.00-libatomic.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-util/watchman/files/watchman-2022.02.28.00-libatomic.patch
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-util/watchman/files/watchman-2022.02.28.00-libatomic.patch')
-rw-r--r--dev-util/watchman/files/watchman-2022.02.28.00-libatomic.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-util/watchman/files/watchman-2022.02.28.00-libatomic.patch b/dev-util/watchman/files/watchman-2022.02.28.00-libatomic.patch
new file mode 100644
index 000000000000..0067e9ade7f2
--- /dev/null
+++ b/dev-util/watchman/files/watchman-2022.02.28.00-libatomic.patch
@@ -0,0 +1,36 @@
+ld.lld: error: undefined symbol: __atomic_is_lock_free
+>>> referenced by atomic_base.h:436 (/usr/lib/gcc/x86_64-pc-linux-gnu/11.2.1/include/g++-v11/bits/atomic_base.h:436)
+>>> CMakeFiles/watchman.dir/watchman/ChildProcess.cpp.o:(void folly::futures::detail::waitImpl<folly::SemiFuture<w_string>, w_string>(folly::SemiFuture<w_string>&))
+>>> referenced by atomic_base.h:436 (/usr/lib/gcc/x86_64-pc-linux-gnu/11.2.1/include/g++-v11/bits/atomic_base.h:436)
+>>> CMakeFiles/watchman.dir/watchman/ChildProcess.cpp.o:(void folly::futures::detail::waitImpl<folly::SemiFuture<w_string>, w_string>(folly::SemiFuture<w_string>&))
+>>> referenced by atomic_base.h:436 (/usr/lib/gcc/x86_64-pc-linux-gnu/11.2.1/include/g++-v11/bits/atomic_base.h:436)
+>>> CMakeFiles/watchman.dir/watchman/ChildProcess.cpp.o:(folly::futures::detail::WaitExecutor::WaitExecutor())
+
+and
+ld.lld: error: undefined symbol: __atomic_is_lock_free
+>>> referenced by atomic_base.h:436 (/usr/lib/gcc/x86_64-pc-linux-gnu/11.2.1/include/g++-v11/bits/atomic_base.h:436)
+>>> CMakeFiles/cache.t.dir/watchman/test/CacheTest.cpp.o:(void folly::futures::detail::waitImpl<folly::SemiFuture<folly::Unit>, folly::Unit>(folly::SemiFuture<folly::Unit>&))
+>>> referenced by atomic_base.h:436 (/usr/lib/gcc/x86_64-pc-linux-gnu/11.2.1/include/g++-v11/bits/atomic_base.h:436)
+>>> CMakeFiles/cache.t.dir/watchman/test/CacheTest.cpp.o:(void folly::futures::detail::waitImpl<folly::SemiFuture<folly::Unit>, folly::Unit>(folly::SemiFuture<folly::Unit>&))
+>>> referenced by atomic_base.h:436 (/usr/lib/gcc/x86_64-pc-linux-gnu/11.2.1/include/g++-v11/bits/atomic_base.h:436)
+>>> CMakeFiles/cache.t.dir/watchman/test/CacheTest.cpp.o:(folly::futures::detail::WaitExecutor::WaitExecutor())
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -716,6 +716,7 @@ target_link_libraries(
+ jansson
+ wildmatch
+ third_party_deps
++ atomic
+ )
+
+ if (WIN32)
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -747,6 +747,7 @@ function(t_test NAME)
+ ${NAME}.t
+ testsupport wildmatch third_party_deps
+ ${LIBGMOCK_LIBRARIES}
++ atomic
+ )
+ target_compile_definitions(${NAME}.t
+ PUBLIC WATCHMAN_TEST_SRC_DIR=\"${CMAKE_CURRENT_SOURCE_DIR}\")