summaryrefslogtreecommitdiff
path: root/dev-util/vulkan-tools/vulkan-tools-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-29 10:15:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-29 10:15:54 +0100
commit9aa80713372911cec499b3adb2cd746790920916 (patch)
treeb8e99dc5dd60ac2094a27cc52f74aada8df38f05 /dev-util/vulkan-tools/vulkan-tools-9999.ebuild
parentb4d43e8c611df4a8061b6f88d9e9f6b1e3c83903 (diff)
gentoo resync : 29.06.2021
Diffstat (limited to 'dev-util/vulkan-tools/vulkan-tools-9999.ebuild')
-rw-r--r--dev-util/vulkan-tools/vulkan-tools-9999.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-util/vulkan-tools/vulkan-tools-9999.ebuild b/dev-util/vulkan-tools/vulkan-tools-9999.ebuild
index e9b91a71bdd7..217cda131c45 100644
--- a/dev-util/vulkan-tools/vulkan-tools-9999.ebuild
+++ b/dev-util/vulkan-tools/vulkan-tools-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -26,7 +26,7 @@ SLOT="0"
IUSE="cube wayland +X"
# Cube demo only supports one window system at a time
-REQUIRED_USE="!cube? ( || ( X wayland ) ) cube? ( ^^ ( X wayland ) )"
+REQUIRED_USE="cube? ( ^^ ( X wayland ) )"
BDEPEND="${PYTHON_DEPS}
>=dev-util/cmake-3.10.2
@@ -65,11 +65,11 @@ multilib_src_configure() {
-DBUILD_WSI_WAYLAND_SUPPORT=$(usex wayland)
-DBUILD_WSI_XCB_SUPPORT=$(usex X)
-DBUILD_WSI_XLIB_SUPPORT=$(usex X)
- -DVULKAN_HEADERS_INSTALL_DIR="${EPREFIX}/usr"
+ -DVULKAN_HEADERS_INSTALL_DIR="${ESYSROOT}/usr"
)
use cube && mycmakeargs+=(
- -DGLSLANG_INSTALL_DIR="${EPREFIX}/usr"
+ -DGLSLANG_INSTALL_DIR="${ESYSROOT}/usr"
-DCUBE_WSI_SELECTION=$(usex X XCB WAYLAND)
)