summaryrefslogtreecommitdiff
path: root/dev-util/vulkan-headers
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
commitbd4aeefe33e63f613512604e47bfca7b2187697d (patch)
treeadb35b5a9a00ee7ea591ab0c987f70167c23b597 /dev-util/vulkan-headers
parent48ece6662cbd443015f5a57ae6d8cbdbd69ef37c (diff)
gentoo resync : 03.11.2019
Diffstat (limited to 'dev-util/vulkan-headers')
-rw-r--r--dev-util/vulkan-headers/Manifest4
-rw-r--r--dev-util/vulkan-headers/vulkan-headers-1.1.125.ebuild31
-rw-r--r--dev-util/vulkan-headers/vulkan-headers-9999.ebuild22
3 files changed, 48 insertions, 9 deletions
diff --git a/dev-util/vulkan-headers/Manifest b/dev-util/vulkan-headers/Manifest
index b56dd1273c0c..92f1c096aa7f 100644
--- a/dev-util/vulkan-headers/Manifest
+++ b/dev-util/vulkan-headers/Manifest
@@ -1,4 +1,6 @@
DIST vulkan-headers-1.1.114.tar.gz 596033 BLAKE2B 707b820ab37e7de92540196c181dea7a0ef1461e15f2b39f4a8355f265ec8d422e69987f3e49f210b8e9f8ebe20f99a682805b2c9b94755f94d2a1b2213b67d5 SHA512 6da91d7207575437f4322ddcacda25f85910266012625a2485124d8dc7d91d88386cc8d93ae5ded4f9e7d862b7139573118df550022ec912a5b2685048cbc6ce
+DIST vulkan-headers-1.1.125.tar.gz 662594 BLAKE2B 7cd18b74ff804ed02df3378485f0783332bd09bf898769c48ded20f7a6495b5208cfae3616de401e17ffcec30421b48222520dcd90b03ad83b548405fd8a656c SHA512 355df13347aaa3b32ad62185810c20d1b2f358525d9d8036f6bc7643e7505a25c087a51e05fa7b0758e4ee63221bb39d01d6e14bfb7f99a53cb2127ca5db5d67
EBUILD vulkan-headers-1.1.114.ebuild 627 BLAKE2B f3f2eb31d94953b415ae94c4ca5ba2b45eb65d348645c66f55c8e00473f861a30e85779d27f3413fc9fa4ab59048f7ca0f9aec958c8551b3980f30099e72fd7a SHA512 bcb14b626aae1c5264ac3eb708ed4baf62a591b55ba97a24308dee64b19517b7fb197b978b84f9cc7eaeaf48078b37c6b30b3800298895f999c27b3a676194c4
-EBUILD vulkan-headers-9999.ebuild 728 BLAKE2B 880211ab2cde0320426f6048c2b6743fd57c1e1169b809d8512fffe09a0e99aa5d991d93a6c2656a62db0af83252213223ef7cdab0aaa8c33a4a26e3382f19e4 SHA512 4c103ce4a085d44b77c411aea833bce8962d24a9c50b611d3fc0bed545021d7e9342f86db333671e21fe58bf22087cda88f6d69a3196be34eec921959cbd1225
+EBUILD vulkan-headers-1.1.125.ebuild 784 BLAKE2B c47201396af371bc6882a6159441906242ea78af661f237c6267fb830d48c4a6ff63f129e94d979dc727778a0517c9b648fc2b79a7bacd6aeaeeb746762520c9 SHA512 e9a29f6b59b818b9fc2645a7cdce3703622aaf1e7791b9c9b83946bf7d9f95d262f94b56e095528c5a101f854e190677e0c0f2a1cb595e926a5de24be34da5c9
+EBUILD vulkan-headers-9999.ebuild 784 BLAKE2B c47201396af371bc6882a6159441906242ea78af661f237c6267fb830d48c4a6ff63f129e94d979dc727778a0517c9b648fc2b79a7bacd6aeaeeb746762520c9 SHA512 e9a29f6b59b818b9fc2645a7cdce3703622aaf1e7791b9c9b83946bf7d9f95d262f94b56e095528c5a101f854e190677e0c0f2a1cb595e926a5de24be34da5c9
MISC metadata.xml 432 BLAKE2B e6c1f4f34e41862d3739bad772b910b21348dce97dbde38cc7fbc9cb42993a493881dd100a0c21be3615805f27d3987259233ae5830ef56e2d1dd928c285c09f SHA512 f4f93b16ad29f813a2c0397ec46c6decf7c9bdb3f4a376e1f24a29724c136feabd230d0558d37a502f2795f71c959833a662e6d2544a78704408b3be9be314fc
diff --git a/dev-util/vulkan-headers/vulkan-headers-1.1.125.ebuild b/dev-util/vulkan-headers/vulkan-headers-1.1.125.ebuild
new file mode 100644
index 000000000000..4dfe2c54e31d
--- /dev/null
+++ b/dev-util/vulkan-headers/vulkan-headers-1.1.125.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/KhronosGroup/Vulkan-Headers.git"
+ inherit git-r3
+else
+ if [[ -z ${SNAPSHOT_COMMIT} ]]; then
+ MY_PV=v${PV}
+ MY_P=Vulkan-Headers-${PV}
+ else
+ MY_PV=${SNAPSHOT_COMMIT}
+ MY_P=Vulkan-Headers-${SNAPSHOT_COMMIT}
+ fi
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/KhronosGroup/Vulkan-Headers/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/${MY_P}
+fi
+
+RDEPEND="!<dev-util/vulkan-tools-1.1.124
+ !<media-libs/vulkan-layers-1.1.125"
+
+DESCRIPTION="Vulkan Header files and API registry"
+HOMEPAGE="https://github.com/KhronosGroup/Vulkan-Headers"
+
+LICENSE="Apache-2.0"
+SLOT="0"
diff --git a/dev-util/vulkan-headers/vulkan-headers-9999.ebuild b/dev-util/vulkan-headers/vulkan-headers-9999.ebuild
index 06f98f73c88e..4dfe2c54e31d 100644
--- a/dev-util/vulkan-headers/vulkan-headers-9999.ebuild
+++ b/dev-util/vulkan-headers/vulkan-headers-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit cmake-utils
@@ -9,17 +9,23 @@ if [[ "${PV}" == "9999" ]]; then
EGIT_REPO_URI="https://github.com/KhronosGroup/Vulkan-Headers.git"
inherit git-r3
else
- EGIT_COMMIT="b1577d5fbd5424c863710aa156aaafa77cae3de8"
+ if [[ -z ${SNAPSHOT_COMMIT} ]]; then
+ MY_PV=v${PV}
+ MY_P=Vulkan-Headers-${PV}
+ else
+ MY_PV=${SNAPSHOT_COMMIT}
+ MY_P=Vulkan-Headers-${SNAPSHOT_COMMIT}
+ fi
KEYWORDS="~amd64 ~x86"
- SRC_URI="https://github.com/KhronosGroup/Vulkan-Headers/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}/Vulkan-Headers-${EGIT_COMMIT}"
+ SRC_URI="https://github.com/KhronosGroup/Vulkan-Headers/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/${MY_P}
fi
+RDEPEND="!<dev-util/vulkan-tools-1.1.124
+ !<media-libs/vulkan-layers-1.1.125"
+
DESCRIPTION="Vulkan Header files and API registry"
HOMEPAGE="https://github.com/KhronosGroup/Vulkan-Headers"
LICENSE="Apache-2.0"
SLOT="0"
-
-# Old packaging will cause file collisions
-RDEPEND="!<=media-libs/vulkan-loader-1.1.70.0-r999"