summaryrefslogtreecommitdiff
path: root/dev-util/vulkan-headers/vulkan-headers-1.2.170.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-util/vulkan-headers/vulkan-headers-1.2.170.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-util/vulkan-headers/vulkan-headers-1.2.170.ebuild')
-rw-r--r--dev-util/vulkan-headers/vulkan-headers-1.2.170.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-util/vulkan-headers/vulkan-headers-1.2.170.ebuild b/dev-util/vulkan-headers/vulkan-headers-1.2.170.ebuild
new file mode 100644
index 000000000000..9eea670b13dc
--- /dev/null
+++ b/dev-util/vulkan-headers/vulkan-headers-1.2.170.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN=Vulkan-Headers
+inherit cmake
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/KhronosGroup/${MY_PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/KhronosGroup/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+ S="${WORKDIR}"/${MY_PN}-${PV}
+fi
+
+DESCRIPTION="Vulkan Header files and API registry"
+HOMEPAGE="https://github.com/KhronosGroup/Vulkan-Headers"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+BDEPEND=">=dev-util/cmake-3.10.2"