summaryrefslogtreecommitdiff
path: root/dev-util/vint
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-util/vint
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-util/vint')
-rw-r--r--dev-util/vint/Manifest5
-rw-r--r--dev-util/vint/metadata.xml17
-rw-r--r--dev-util/vint/vint-0.3.13-r1.ebuild46
-rw-r--r--dev-util/vint/vint-0.3.14.ebuild51
4 files changed, 119 insertions, 0 deletions
diff --git a/dev-util/vint/Manifest b/dev-util/vint/Manifest
new file mode 100644
index 000000000000..e2534c4cf242
--- /dev/null
+++ b/dev-util/vint/Manifest
@@ -0,0 +1,5 @@
+DIST vint-0.3.13.tar.gz 91599 SHA256 7cb00bf3d83a093857db9a9bcc7d316a9fa52704cbeff991130eb34ed2d27df5 SHA512 ef0b811df0250899e23e30ee4b240cf8b54e510231353ca86202661fd5f0826b9faeacc9268849e51bd6a1c71c1514498dec04a7a4ed79f00a5098811525e3d4 WHIRLPOOL 0c0a12c8a17ac2a4ab664b8aee03597a5e77b8a6b03458d4767c841d3adc03955bcbb0f876de09b2c4e194a94c9ab1d162a1902b6e49b146c4d8493ffe750e2d
+DIST vint-0.3.14.tar.gz 92565 SHA256 4e0792cf83ef65ca83e09d6b3fe715cd397d635bc8380eb42302fb05d542014e SHA512 61509320e11d410cad56368fcc92d7596bd3e090dfb3950ba01886c37c3b83af69c168a71aeeb0e3221a9802a8e878a4b04a5aa6069189c5027ec1ad7070799b WHIRLPOOL 98bbf8ad3b1572a25fc6c22fad9a1b16bdfae6bfe915a30fb0f765f8a8dca2c854660a779bedf137cdd641d919cff910f38a9ccaa0879863507b5e2796601b8e
+EBUILD vint-0.3.13-r1.ebuild 1282 SHA256 5ff133261badd98b850128c443753e2610010ec81845738cd08514d70744dbb4 SHA512 1cbf63bf0a347168501ec98a386a0d2b91eb4615074f6b8b14027b88f132410b683af3b3ca513c0a4970f7f67856c07ef6e4f2ee9cf14d4d94800f00cbfdc2a7 WHIRLPOOL 61fcff7e39a72b73c79493a899bb009aa18c5435d32ab1ee3408d432570d559de194acf514244bb2e26b744309b9fc540bc4fa6dd674c2289e3bfd7986fe3003
+EBUILD vint-0.3.14.ebuild 1493 SHA256 f4914b06910a629a2787c4c45cb825e8411665592b8b3ee3de05bdc142d00f0e SHA512 9e5de8e9c79b569344db07fbe96c21e36706d1dfb471dc24725d9bf85180927f75d44f96655bfd0dd5ca85fec032f45ab13210f3be2548d797b8d612b16daa3e WHIRLPOOL 1d04d03fc4bbac5287e8393d47b8f3ae98fee69482e00cc404cf117afbda42ff124d5ff58ef7bd3dd692c9161a7de5881c671c1a1963aeba53ae082c57bc7db0
+MISC metadata.xml 555 SHA256 ae87adaae56dfce0801002076b4344b642423a42a938cfd304df446be0bf237d SHA512 ed3b8b8054f549adb826668dc08d364b02e86e0ec83d5455c8a9adc21702a143b488d028a8d12135a28f66bb673c3281d0f79fe20773ec1f78b632a86c859129 WHIRLPOOL 87f3232d42b024b979cffc9e35338341ac6f6e4b306ddd6a191cf5a36072d25b91f35bb1f0fc4d1feffbe8387922ae6ece34c6f398f8c7787d1acbd0e0c2ea26
diff --git a/dev-util/vint/metadata.xml b/dev-util/vint/metadata.xml
new file mode 100644
index 000000000000..b2d24cbd66c5
--- /dev/null
+++ b/dev-util/vint/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>itumaykin+gentoo@gmail.com</email>
+ <name>Coacher</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <changelog>https://github.com/Kuniwak/vint/releases</changelog>
+ <remote-id type="github">Kuniwak/vint</remote-id>
+ <remote-id type="pypi">vim-vint</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-util/vint/vint-0.3.13-r1.ebuild b/dev-util/vint/vint-0.3.13-r1.ebuild
new file mode 100644
index 000000000000..36f8aa8e66b2
--- /dev/null
+++ b/dev-util/vint/vint-0.3.13-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Lint tool for Vim script language"
+HOMEPAGE="https://github.com/Kuniwak/vint https://pypi.python.org/pypi/vim-vint/"
+SRC_URI="https://github.com/Kuniwak/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/ansicolor-0.2.4[${PYTHON_USEDEP}]
+ >=dev-python/chardet-2.3.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.11[${PYTHON_USEDEP}]
+ virtual/python-enum34[${PYTHON_USEDEP}]
+ virtual/python-pathlib[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-python/coverage-3.7.1[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.6.4[${PYTHON_USEDEP}]
+ >=dev-python/pytest-cov-1.8.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]' python2_7)
+ )
+"
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ # Don't try to use an installed vint executable.
+ # See https://github.com/Kuniwak/vint/issues/22
+ sed -i -e "s|'vint'|'bin/vint'|" test/acceptance/test_cli{,_vital}.py || die
+}
+
+python_test() {
+ py.test -v || die "Test suite failed with ${EPYTHON}"
+}
diff --git a/dev-util/vint/vint-0.3.14.ebuild b/dev-util/vint/vint-0.3.14.ebuild
new file mode 100644
index 000000000000..a64b9b754639
--- /dev/null
+++ b/dev-util/vint/vint-0.3.14.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Lint tool for Vim script language"
+HOMEPAGE="https://github.com/Kuniwak/vint https://pypi.python.org/pypi/vim-vint/"
+SRC_URI="https://github.com/Kuniwak/vint/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/ansicolor-0.2.4[${PYTHON_USEDEP}]
+ >=dev-python/chardet-2.3.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.11[${PYTHON_USEDEP}]
+ virtual/python-enum34[${PYTHON_USEDEP}]
+ virtual/python-pathlib[${PYTHON_USEDEP}]
+ virtual/python-typing[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-python/coverage-3.7.1[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.6.4[${PYTHON_USEDEP}]
+ >=dev-python/pytest-cov-1.8.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]' python2_7)
+ )
+"
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ # Don't try to use an installed vint executable.
+ # See https://github.com/Kuniwak/vint/issues/22
+ sed -i -e "s|'vint'|'bin/vint'|" test/acceptance/test_cli{,_vital}.py || die
+
+ # Don't blindly require typing. It's already shipped with Python>=3.5.
+ # See https://github.com/Kuniwak/vint/issues/238
+ sed -i -e '/typing/d' requirements.txt || die
+}
+
+python_test() {
+ py.test -v || die "Test suite failed with ${EPYTHON}"
+}