summaryrefslogtreecommitdiff
path: root/dev-util/vint
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-10-01 20:54:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-10-01 20:54:53 +0100
commit391b5b359a346aff490103da7dddc85047f83830 (patch)
tree29eea460a0bd7e1ff21d43b9d6df9af4d8a175e1 /dev-util/vint
parentc719fdcee603a5a706a45d10cb598762d56a727d (diff)
gentoo resync : 01.10.2021
Diffstat (limited to 'dev-util/vint')
-rw-r--r--dev-util/vint/Manifest5
-rw-r--r--dev-util/vint/files/vint-0.3.21-fix-py3.8.patch29
-rw-r--r--dev-util/vint/metadata.xml1
-rw-r--r--dev-util/vint/vint-0.3.21.ebuild18
4 files changed, 39 insertions, 14 deletions
diff --git a/dev-util/vint/Manifest b/dev-util/vint/Manifest
index 54ea16210c46..469fcb0d51a2 100644
--- a/dev-util/vint/Manifest
+++ b/dev-util/vint/Manifest
@@ -1,3 +1,4 @@
+AUX vint-0.3.21-fix-py3.8.patch 1428 BLAKE2B f45cf44b458a779a0e6ee27822fcb65c5c5594673c2d59e540c7fbd0fc3b31f3b0f17dacaf932e9a7837d93f47d6c267cd2ce1bb8487d2a0268ea6a3c7fd96fb SHA512 7421bc4dd6de228e60ae0d421912dcaaf1814c4d5216ae09198da65b4f56e90bf1c944fc3aebfe773f7a4abcdfc439481246a611613df302fc914a42cd610668
DIST vint-0.3.21.tar.gz 96747 BLAKE2B 926b46493030dc0daa477ded3cb70f2b825b4eb8054c14a4b824b97e7df60d0141cf1bcf4c33893afd870f51308b7156fb6e5870f320f8c9449fdca8fe78774f SHA512 47e832d382952cb16bcc233eefa1f06ca74f95eb445d7f96d6804391b91a2c8a8e7b749b7f33f65aed9d3bdc1ff5e5332a62c3935969395f16a854f0f66e383b
-EBUILD vint-0.3.21.ebuild 886 BLAKE2B 50abf8d296e0470e98b46f881bd4093c54684d7d93b64d19ac03d86e4c89fbf8dab74bf7c7e87e28d90195e9688991bfcf57db39f776c9966945f94f31805cd0 SHA512 c54bd92dfbd9400728c2dffa8fffca797d5270bace822c662ec18d04030114315114aad16b5ad48b27fcfef253cca6571a47686f540e6fbda37578abe068ae20
-MISC metadata.xml 584 BLAKE2B 6ec51a7ca523def44ec9edeb96e64fc13762f233eafb8a40d1f4d06bcf815bdcee3ebfcbfa1952ad46b6bcc4670588d6644ffe7338b3d733addd1f8a369af9df SHA512 d576672a31098c2a115c7d1ebfca6aff349056696cefb7bcb14305a1bb214c843d06e1e04a32447ba31165326be92789e0ce426117dc1eb981f7edaf391472ae
+EBUILD vint-0.3.21.ebuild 646 BLAKE2B 1f1a15fcf7d74e76c276cab6b969fc3548f9e7e39cd22fac44dc589c82cf06178242ffca4d4f956d1e12a88845c48639d2f22ef6751cbfe5d03ad8e3779a55f2 SHA512 c5569269b6f078879e25078c326d36643528d2da4021927e36f19b9dc8dabf199b03291efd61b861f7049fc918da3807ab2eb37923caba73fe3f69384eb57677
+MISC metadata.xml 608 BLAKE2B 2a483186140621bc5e54219df1ca31114f4d410b308883e80c84a35a273e9aeb57968f78e608481e66d7535d137c36a192ed493c385c9b98bd9cf405554dc68e SHA512 5cece77f9c71170d519d3a11d292639c25fba403d4c8c8932c093b04d375433ae9279b23d1ef9c0c6fcb0c477b08d6559f8a3bf9521e7151c2de11b4e1ac6a0a
diff --git a/dev-util/vint/files/vint-0.3.21-fix-py3.8.patch b/dev-util/vint/files/vint-0.3.21-fix-py3.8.patch
new file mode 100644
index 000000000000..af97c51cf2c4
--- /dev/null
+++ b/dev-util/vint/files/vint-0.3.21-fix-py3.8.patch
@@ -0,0 +1,29 @@
+From f8bae710ba74dcc55a3b95995fe73139cf949b75 Mon Sep 17 00:00:00 2001
+From: Daniel Hahler <git@thequod.de>
+Date: Mon, 25 Nov 2019 06:41:39 +0100
+Subject: [PATCH] Fix SyntaxWarning with py38 (#334)
+
+> SyntaxWarning: "is not" with a literal. Did you mean "!="?
+--- a/vint/ast/plugin/scope_plugin/scope_linker.py
++++ b/vint/ast/plugin/scope_plugin/scope_linker.py
+@@ -406,14 +406,17 @@ def _handle_function_node(self, func_node): # type: (Dict[str, Any]) -> None
+ # We can access "a:firstline" and "a:lastline" if the function is
+ # declared with an attribute "range". See :func-range
+ attr = func_node['attr']
+- is_declared_with_range = attr['range'] is not 0
++ is_declared_with_range = attr['range'] != 0
+ if is_declared_with_range:
+ self._scope_tree_builder.handle_new_range_parameters_found()
+
+ # We can access "l:self" is declared with an attribute "dict" or
+ # the function is a member of a dict. See :help self
+- is_declared_with_dict = attr['dict'] is not 0 \
+- or NodeType(func_name_node['type']) in FunctionNameNodesDeclaringVariableSelf
++ is_declared_with_dict = (
++ attr["dict"] != 0
++ or NodeType(func_name_node["type"])
++ in FunctionNameNodesDeclaringVariableSelf
++ )
+ if is_declared_with_dict:
+ self._scope_tree_builder.handle_new_dict_parameter_found()
+
diff --git a/dev-util/vint/metadata.xml b/dev-util/vint/metadata.xml
index 5bcd8159db53..a3cc2f0b5eed 100644
--- a/dev-util/vint/metadata.xml
+++ b/dev-util/vint/metadata.xml
@@ -9,6 +9,7 @@
<email>proxy-maint@gentoo.org</email>
<name>Proxy Maintainers</name>
</maintainer>
+ <stabilize-allarches/>
<upstream>
<changelog>https://github.com/Kuniwak/vint/releases</changelog>
<remote-id type="github">Kuniwak/vint</remote-id>
diff --git a/dev-util/vint/vint-0.3.21.ebuild b/dev-util/vint/vint-0.3.21.ebuild
index f07e7a81f734..44cd40dc8e15 100644
--- a/dev-util/vint/vint-0.3.21.ebuild
+++ b/dev-util/vint/vint-0.3.21.ebuild
@@ -1,11 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Lint tool for Vim script language"
@@ -22,12 +20,8 @@ RDEPEND="
>=dev-python/pyyaml-3.11[${PYTHON_USEDEP}]
"
-distutils_enable_tests pytest
+PATCHES=(
+ "${FILESDIR}/${P}-fix-py3.8.patch"
+)
-python_test() {
- # Tests fail due to python 3.8 warnings in stderr that appear when
- # compiled byte code is disabled
- # https://github.com/Vimjas/vint/issues/355
- [[ "${EPYTHON}" == python3.8 ]] && return
- pytest -vv || die "Tests fail with ${EPYTHON}"
-}
+distutils_enable_tests pytest