summaryrefslogtreecommitdiff
path: root/dev-util/valgrind/valgrind-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-02 15:59:12 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-02 15:59:12 +0000
commit06a7b5647e11a8ddf69b1c3d3ded6a8ba28b923e (patch)
tree8d58c1f4b049da677b33209b072f2b3057268fe0 /dev-util/valgrind/valgrind-9999.ebuild
parent99abbc5e5a6ecd3fc981b45646fd8cb5d320377b (diff)
gentoo resync : 02.03.2018
Diffstat (limited to 'dev-util/valgrind/valgrind-9999.ebuild')
-rw-r--r--dev-util/valgrind/valgrind-9999.ebuild20
1 files changed, 10 insertions, 10 deletions
diff --git a/dev-util/valgrind/valgrind-9999.ebuild b/dev-util/valgrind/valgrind-9999.ebuild
index 855bd8a16c29..2b96d5f5150c 100644
--- a/dev-util/valgrind/valgrind-9999.ebuild
+++ b/dev-util/valgrind/valgrind-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=6
inherit autotools flag-o-matic toolchain-funcs multilib pax-utils
DESCRIPTION="An open-source memory debugger for GNU/Linux"
@@ -39,7 +39,7 @@ src_prepare() {
}
src_configure() {
- local myconf
+ local myconf=()
# Respect ar, bug #468114
tc-export AR
@@ -61,23 +61,23 @@ src_configure() {
replace-flags -ggdb3 -ggdb2
if use amd64 || use ppc64; then
- ! has_multilib_profile && myconf="${myconf} --enable-only64bit"
+ ! has_multilib_profile && myconf+=("--enable-only64bit")
fi
# Force bitness on darwin, bug #306467
- use x86-macos && myconf="${myconf} --enable-only32bit"
- use x64-macos && myconf="${myconf} --enable-only64bit"
+ use x86-macos && myconf+=("--enable-only32bit")
+ use x64-macos && myconf+=("--enable-only64bit")
# Don't use mpicc unless the user asked for it (bug #258832)
if ! use mpi; then
- myconf="${myconf} --without-mpicc"
+ myconf+=("--without-mpicc")
fi
- econf ${myconf}
+ econf "${myconf[@]}"
}
src_install() {
- emake DESTDIR="${D}" install
+ default
if [[ ${PV} == "9999" ]]; then
# Otherwise FAQ.txt won't exist:
@@ -85,7 +85,7 @@ src_install() {
mv docs/FAQ.txt . || die "Couldn't move FAQ.txt"
fi
- dodoc AUTHORS FAQ.txt NEWS README*
+ dodoc FAQ.txt
pax-mark m "${ED}"/usr/$(get_libdir)/valgrind/*-*-linux