summaryrefslogtreecommitdiff
path: root/dev-util/unifdef/unifdef-2.12.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
commitceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (patch)
tree9f47ee47c31a0f13f9496879cd88a1042550aa81 /dev-util/unifdef/unifdef-2.12.ebuild
parent53cba99042fa967e2a93da9f8db806fe2d035543 (diff)
gentoo (leap year) resync : 29.02.2020
Diffstat (limited to 'dev-util/unifdef/unifdef-2.12.ebuild')
-rw-r--r--dev-util/unifdef/unifdef-2.12.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-util/unifdef/unifdef-2.12.ebuild b/dev-util/unifdef/unifdef-2.12.ebuild
new file mode 100644
index 000000000000..e10516d447e9
--- /dev/null
+++ b/dev-util/unifdef/unifdef-2.12.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="remove #ifdef'ed lines from a file while otherwise leaving the file alone"
+HOMEPAGE="https://dotat.at/prog/unifdef/"
+SRC_URI="https://dotat.at/prog/unifdef/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+DOCS=( README )
+
+src_prepare() {
+ sed -i "/^prefix/s:=.*:=${EPREFIX}/usr:" Makefile || die
+ tc-export CC
+ default
+}