summaryrefslogtreecommitdiff
path: root/dev-util/unicorn
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-util/unicorn
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-util/unicorn')
-rw-r--r--dev-util/unicorn/Manifest2
-rw-r--r--dev-util/unicorn/unicorn-2.0.0_rc5.ebuild81
2 files changed, 0 insertions, 83 deletions
diff --git a/dev-util/unicorn/Manifest b/dev-util/unicorn/Manifest
index 00de1cd6e947..dcfe1da1d048 100644
--- a/dev-util/unicorn/Manifest
+++ b/dev-util/unicorn/Manifest
@@ -1,6 +1,4 @@
-DIST unicorn-2.0.0_rc5.tar.gz 3808762 BLAKE2B 02a77c46e075f67df04a9fe0b5474df9f6a6c154778de3223c6ed3c475bd4658abd7b57d351a63cfa7ef5ecbadbee12a6151957b7b47b4f6741b5e4581d13c4b SHA512 3b5118e378872a50d3aa0dca01cda69b0e7b3875da7b03c1708963848c71818dd1e120df8796acace661c6b4d63813b9acc8106ce3a94c0d40c3b50677fbaacd
DIST unicorn-2.0.0_rc6.tar.gz 3968714 BLAKE2B dcb42126b8a2b9f0780977c73f5e170b5ad438c4f0eca82293e47d52575de27f18440a2d71b9cd17d7b488ae1d46c8197eabbbf7fd92f196bfb7d46c197937fd SHA512 a80a9408bc5b41b6961049849a8a63f69399325a4e4d8e41f4512173d24a837048d9ac03064bc16eb129e5f52828507baa059fda64430ec52b4f9ef339d61f0d
-EBUILD unicorn-2.0.0_rc5.ebuild 1653 BLAKE2B 4e2af65fc24cf006e46a528be177300196af169c683b8054b4b47ca5c28bbb3615bb40a00b9d364f5e378ce849952f2d6459b42e7a8de0fb8d3b3acb18149926 SHA512 8154d003c7affc7ecfc573eded5f3d48d3a44b79b82630f38b9d5b3d962b95c41643961cb216b5c71233b9838ed08d55cb8fb7e176857eb0bfe971b9639a3d92
EBUILD unicorn-2.0.0_rc6.ebuild 1635 BLAKE2B 6b1ef99c0458971d413f0ebae78886de1c6375c3cce9edfb338b739a008cc17b1da636333d7952f95a000412a82ce4add748bcf7d32629a17257b8bc5e06bf97 SHA512 e80f886de510d66d8421d34747cce745237cd806f4cd2e286eb1cd38952553efd978ecfaf7ff0bfb4b9493a80c88e3bdb004c74a78b3c46caae792b8184adfbc
EBUILD unicorn-9999.ebuild 1635 BLAKE2B 6b1ef99c0458971d413f0ebae78886de1c6375c3cce9edfb338b739a008cc17b1da636333d7952f95a000412a82ce4add748bcf7d32629a17257b8bc5e06bf97 SHA512 e80f886de510d66d8421d34747cce745237cd806f4cd2e286eb1cd38952553efd978ecfaf7ff0bfb4b9493a80c88e3bdb004c74a78b3c46caae792b8184adfbc
MISC metadata.xml 465 BLAKE2B 939a9adeaa9402af97d46bf8c19dddeb6d732de7c748480650bda37b0320de9666e1f537b23618310c1b2d85abb3f9d5fa0d62156b2d159ea77adaa456496fb9 SHA512 d09ee2447dd71ea02ffa1b18b23e1529c9506f8418314c7fb068b76d8dab8689a777940d4683e5cd574736dd185bbdff2cbbc79b372eb02bb061798490952a9b
diff --git a/dev-util/unicorn/unicorn-2.0.0_rc5.ebuild b/dev-util/unicorn/unicorn-2.0.0_rc5.ebuild
deleted file mode 100644
index e2bdf4b08071..000000000000
--- a/dev-util/unicorn/unicorn-2.0.0_rc5.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-MY_PV=${PV/_/-}
-
-DISTUTILS_USE_PEP517=setuptools
-DISTUTILS_OPTIONAL=1
-PYTHON_COMPAT=( python3_{9..10} )
-inherit cmake distutils-r1
-
-DESCRIPTION="A lightweight multi-platform, multi-architecture CPU emulator framework"
-HOMEPAGE="https://www.unicorn-engine.org"
-
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/unicorn-engine/unicorn"
-else
- SRC_URI="https://github.com/unicorn-engine/unicorn/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-LICENSE="BSD-2 GPL-2 LGPL-2.1"
-SLOT="0/2"
-IUSE="python static-libs"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-DEPEND="${PYTHON_DEPS}
- dev-libs/glib:2"
-RDEPEND="python? ( ${PYTHON_DEPS} )"
-BDEPEND="virtual/pkgconfig
- python? ( ${DISTUTILS_DEPS} )"
-
-UNICORN_TARGETS="x86 arm aarch64 riscv mips sparc m68k ppc"
-
-wrap_python() {
- if use python; then
- # src_prepare
- # do not compile C extensions
- export LIBUNICORN_PATH=1
-
- pushd bindings/python >/dev/null || die
- distutils-r1_${1} "$@"
- popd >/dev/null || die
- fi
-}
-
-src_prepare() {
- # Build from sources
- rm -r bindings/python/prebuilt || die "failed to remove prebuilt files"
-
- cmake_src_prepare
- wrap_python ${FUNCNAME}
-}
-
-src_configure(){
- local mycmakeargs=(
- -DBUILD_SHARED_LIBS=OFF
- -DUNICORN_BUILD_SHARED=$(usex !static-libs)
- -DUNICORN_ARCH="${UNICORN_TARGETS}"
- )
-
- cmake_src_configure
-
- wrap_python ${FUNCNAME}
-}
-
-src_compile() {
- cmake_src_compile
-
- wrap_python ${FUNCNAME}
-}
-
-src_install() {
- cmake_src_install
-
- wrap_python ${FUNCNAME}
-}