summaryrefslogtreecommitdiff
path: root/dev-util/uncrustify/uncrustify-0.71.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-util/uncrustify/uncrustify-0.71.0.ebuild
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-util/uncrustify/uncrustify-0.71.0.ebuild')
-rw-r--r--dev-util/uncrustify/uncrustify-0.71.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-util/uncrustify/uncrustify-0.71.0.ebuild b/dev-util/uncrustify/uncrustify-0.71.0.ebuild
new file mode 100644
index 000000000000..ffb8d0941d9f
--- /dev/null
+++ b/dev-util/uncrustify/uncrustify-0.71.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ $PV == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
+ scm_eclass=git-r3
+else
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x64-solaris ~x86-solaris"
+ SRC_URI="https://github.com/${PN}/${PN}/archive/${P}.tar.gz"
+ S=${WORKDIR}/${PN}-${P}
+fi
+
+inherit cmake-utils ${scm_eclass}
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit python-any-r1
+
+DESCRIPTION="C/C++/C#/D/Java/Pawn code indenter and beautifier"
+HOMEPAGE="http://uncrustify.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( ${PYTHON_DEPS} )"