summaryrefslogtreecommitdiff
path: root/dev-util/uftrace
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
commit46eedbedafdb0040c37884982d4c775ce277fb7b (patch)
treedb33a91259730be84999e13a8d8168c799f50ac0 /dev-util/uftrace
parente23a08d0c97a0cc415aaa165da840b056f93c997 (diff)
gentoo resync : 20.10.2021
Diffstat (limited to 'dev-util/uftrace')
-rw-r--r--dev-util/uftrace/Manifest2
-rw-r--r--dev-util/uftrace/uftrace-0.11.ebuild70
2 files changed, 72 insertions, 0 deletions
diff --git a/dev-util/uftrace/Manifest b/dev-util/uftrace/Manifest
index 10f2faf6538c..4d9bcf606cbe 100644
--- a/dev-util/uftrace/Manifest
+++ b/dev-util/uftrace/Manifest
@@ -1,3 +1,5 @@
DIST uftrace-0.10.tar.gz 1111530 BLAKE2B 29388523e1009276ba4609d85e5979e823d028ff647239aa02ec2cac5ae21c7812c7699d47c09c0b9289a0debb39a2f502615547c8e658a821d5078e3b12c6fe SHA512 788234e4156974a70f06d02527e56e5fac821e8b66363dc5fc55d68797c374043c0b66b18b4ab1488b9647e08969e8dc94a64d6bb1a38ccad4cf98eaecc6e919
+DIST uftrace-0.11.tar.gz 1120956 BLAKE2B e3bda84a7323cc50780950e502856e28a380249a0f518ad3f7950c4147f0ab635e84b978395eb9025e6b47ecf7eefddcde59356a22f1c8a1d60ddf9820dc3d41 SHA512 519ca13665ba97cea4c349d81b4b5cacd8d3d9b2188ef5edb447f6b783cb7a92356bc0f9e63b67427a896d8df671f58091113e1de3fffd8d8000417a9fdb6e46
EBUILD uftrace-0.10-r1.ebuild 1202 BLAKE2B f9349c41687cc23c67ec8a1664074e5df3f2a9bef8cf869490a19d6f2c0c52cab466a8c25074c0eae8374171cb0da8d73daed54ad9a947912dd6562c4409257f SHA512 db312bbf04ae6e25a4a4bd4bb4634c0f824d129acf64224459182e40318475cbed0c9110e5b037f0902001aa808ac6c12a0b45f52ca109e74d7c651b4155e55e
+EBUILD uftrace-0.11.ebuild 1408 BLAKE2B 870b9a39ee078a2db5797f69e4d8f9b0412a45c81996f6e95f7b5a403dbed15dc8c0e275f75c894474f089d7f706f7d7035b88d604365a101caed81bb1cae48e SHA512 e6bda676db054afc9bd718552b4953c1a10bd442f0db9a959c26b1c440b60ec10da2942a4775fad8df851fc92195ccd5f9f9d08bf8d020831a6e7baddcd14a80
MISC metadata.xml 439 BLAKE2B 5164074d22c56fcba8f0677446484c392c347058c444e3f2760cc1e6d17e07406741f80a525ba99b575dca2d9347fe3b13b82fe5aa79bc734add9806695a5fe2 SHA512 d6e0f7ab729d6088748d5efe5c88910355f5ab7e70308b3b24f8cd27956b0ee21f8ff8bce18f9969694bd4677c229fe80317735de63e9a80b4dca638738dbe5d
diff --git a/dev-util/uftrace/uftrace-0.11.ebuild b/dev-util/uftrace/uftrace-0.11.ebuild
new file mode 100644
index 000000000000..31a949ddbd3f
--- /dev/null
+++ b/dev-util/uftrace/uftrace-0.11.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( luajit )
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit bash-completion-r1 lua-single python-single-r1 toolchain-funcs
+
+DESCRIPTION="Function (graph) tracer for user-space"
+HOMEPAGE="https://github.com/namhyung/uftrace"
+SRC_URI="https://github.com/namhyung/uftrace/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="capstone lua python unwind"
+
+REQUIRED_USE="
+ lua? ( ${LUA_REQUIRED_USE} )
+ python? ( ${PYTHON_REQUIRED_USE} )
+"
+
+RESTRICT="test"
+
+RDEPEND="
+ sys-libs/ncurses:=
+ virtual/libelf:=
+ capstone? ( dev-libs/capstone:0= )
+ lua? ( ${LUA_DEPS} )
+ python? ( ${PYTHON_DEPS} )
+ unwind? ( sys-libs/libunwind:= )
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ sed -i -e "s/ARCH/MYARCH/g" -e "/ldconfig/d" -e "/bash.completion/d" Makefile || die
+}
+
+src_configure() {
+ local myconf=(
+ --libdir="${EPREFIX}"/usr/$(get_libdir)/uftrace
+ $(use_with capstone)
+ $(use_with unwind libunwind)
+ $(use_with python libpython)
+ )
+ if use lua && use lua_single_target_luajit; then
+ myconf+=(
+ --with-libluajit
+ )
+ else
+ myconf+=(
+ --without-libluajit
+ )
+ fi
+ CC=$(tc-getCC) LD=$(tc-getLD) econf "${myconf[@]}"
+}
+
+src_compile() {
+ emake V=1
+}
+
+src_install() {
+ default
+
+ dodoc doc/*.{md,gif,png}
+ newbashcomp misc/bash-completion.sh uftrace
+}