summaryrefslogtreecommitdiff
path: root/dev-util/uftrace/uftrace-0.12.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-19 17:22:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-19 17:22:12 +0100
commitb2a3508c3634488d32ec5bbe6b4365ab27185ebd (patch)
tree408b60b91a5427cc1ecb8a441c9df1f2526eeba1 /dev-util/uftrace/uftrace-0.12.ebuild
parent8668c0f6c5fd1d084b8b2bdac1cfa1fcba412f65 (diff)
gentoo auto-resync : 19:09:2022 - 17:22:11
Diffstat (limited to 'dev-util/uftrace/uftrace-0.12.ebuild')
-rw-r--r--dev-util/uftrace/uftrace-0.12.ebuild70
1 files changed, 70 insertions, 0 deletions
diff --git a/dev-util/uftrace/uftrace-0.12.ebuild b/dev-util/uftrace/uftrace-0.12.ebuild
new file mode 100644
index 000000000000..644fc9e3f90d
--- /dev/null
+++ b/dev-util/uftrace/uftrace-0.12.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( luajit )
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit bash-completion-r1 lua-single python-single-r1 toolchain-funcs
+
+DESCRIPTION="Function (graph) tracer for user-space"
+HOMEPAGE="https://github.com/namhyung/uftrace"
+SRC_URI="https://github.com/namhyung/uftrace/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="capstone lua python unwind"
+
+REQUIRED_USE="
+ lua? ( ${LUA_REQUIRED_USE} )
+ python? ( ${PYTHON_REQUIRED_USE} )
+"
+
+RESTRICT="test"
+
+RDEPEND="
+ sys-libs/ncurses:=
+ virtual/libelf:=
+ capstone? ( dev-libs/capstone:0= )
+ lua? ( ${LUA_DEPS} )
+ python? ( ${PYTHON_DEPS} )
+ unwind? ( sys-libs/libunwind:= )
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ sed -i -e "s/ARCH/MYARCH/g" -e "/ldconfig/d" -e "/bash.completion/d" Makefile || die
+}
+
+src_configure() {
+ local myconf=(
+ --libdir="${EPREFIX}/usr/$(get_libdir)/uftrace"
+ $(use_with capstone)
+ $(use_with unwind libunwind)
+ $(use_with python libpython)
+ )
+ if use lua && use lua_single_target_luajit; then
+ myconf+=(
+ --with-libluajit
+ )
+ else
+ myconf+=(
+ --without-libluajit
+ )
+ fi
+ CC="$(tc-getCC)" LD="$(tc-getLD)" econf "${myconf[@]}"
+}
+
+src_compile() {
+ emake V=1
+}
+
+src_install() {
+ default
+
+ dodoc doc/*.{md,gif,png}
+ newbashcomp misc/bash-completion.sh uftrace
+}