summaryrefslogtreecommitdiff
path: root/dev-util/tup
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
commite3872864be25f7421015bef2732fa57c0c9fb726 (patch)
tree9cb29a544215119b5c5538e37211b994ce1c87ae /dev-util/tup
parent480486b52ea64765faf696c88b2c6a26a5a454d4 (diff)
gentoo resync : 04.08.2018
Diffstat (limited to 'dev-util/tup')
-rw-r--r--dev-util/tup/Manifest4
-rw-r--r--dev-util/tup/metadata.xml11
-rw-r--r--dev-util/tup/tup-0.7.7.ebuild98
-rw-r--r--dev-util/tup/tup-9999.ebuild98
4 files changed, 211 insertions, 0 deletions
diff --git a/dev-util/tup/Manifest b/dev-util/tup/Manifest
new file mode 100644
index 000000000000..0bd6534c1172
--- /dev/null
+++ b/dev-util/tup/Manifest
@@ -0,0 +1,4 @@
+DIST tup-0.7.7.tar.gz 4033539 BLAKE2B dc4d3fc538c76dac53629991e32de7414f35877af8bb9f2ce4a1f80252317de7b3d2ea1542ab3e58702813b297a42c95610d14122496ac7f23acc1f8f3d62461 SHA512 05407cc923b898d5dcf6652df6395e7618d43fa4e3ace905dda09bcda26f975187761a704d360fceeb38332f29d65cd3d1f9e04c87d93dcffa4e9e2be9b35aad
+EBUILD tup-0.7.7.ebuild 2183 BLAKE2B 5a87498b280616342885129ce6c395667e378c9e5f54fa6583512e2b6a662a1e15555bc7003586702125d8300b1e71b0709b42bf5117b2f5eb765fb2be50f76d SHA512 6e78d896108cb77d45f97f25ec5dfe18a6be7272c0ab6383feaef92ab41f1a58add61bfec0a87598bfec586642fe11c3d16eec40e6f37514814a9aa0b842138e
+EBUILD tup-9999.ebuild 2183 BLAKE2B 5a87498b280616342885129ce6c395667e378c9e5f54fa6583512e2b6a662a1e15555bc7003586702125d8300b1e71b0709b42bf5117b2f5eb765fb2be50f76d SHA512 6e78d896108cb77d45f97f25ec5dfe18a6be7272c0ab6383feaef92ab41f1a58add61bfec0a87598bfec586642fe11c3d16eec40e6f37514814a9aa0b842138e
+MISC metadata.xml 326 BLAKE2B edaa58be0e147ba52e73b1e4ad70250ee2ebf7c31beda95bc4f639dc4759b4a2515a3f927b4c5c3e644a66a58180df7ef6874893908d6ffc55181c8a554f3a70 SHA512 cd0c6ad8e43779608355cc4bd23a03a88d2920ff15269f2b130395f955fe58d63029d6f8567b021c4f546d0c41e8af3d866c0de4b72d042be1ec6eff72cc0154
diff --git a/dev-util/tup/metadata.xml b/dev-util/tup/metadata.xml
new file mode 100644
index 000000000000..390ab1cc5015
--- /dev/null
+++ b/dev-util/tup/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>andrey_utkin@gentoo.org</email>
+ <name>Andrey Utkin</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">gittup/tup</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-util/tup/tup-0.7.7.ebuild b/dev-util/tup/tup-0.7.7.ebuild
new file mode 100644
index 000000000000..104dd83a9dbd
--- /dev/null
+++ b/dev-util/tup/tup-0.7.7.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="A file-based build system"
+HOMEPAGE="http://gittup.org/tup"
+# Tup itself is GPLv2, but it bundles differently licensed software:
+# - lua: MIT
+# - sqlite (unused in this ebuild): public domain
+# - inih: 3-clause BSD
+# - red-black tree implementation: 2-clause BSD
+# - queue implementation: 3-clause BSD
+LICENSE="GPL-2 MIT public-domain BSD BSD-2"
+SLOT="0"
+
+if [[ "${PV}" == 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/gittup/tup.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/gittup/tup/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DEPEND="
+ dev-db/sqlite:=
+ sys-fs/fuse:=
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # Use our toolchain
+ sed -i Tuprules.tup \
+ -e "s:CC = gcc:CC = $(tc-getCC) ${CFLAGS} ${LDFLAGS}:" \
+ -e "s:ar crs:$(tc-getAR) crs:"
+
+ if [[ ${PV} != 9999 ]]; then
+ # Avoid invoking `git` to find version, use ours
+ sed -i src/tup/link.sh \
+ -e 's;`git describe`;v'"${PV};"
+ fi
+
+ default
+}
+
+src_configure () {
+ echo "CONFIG_TUP_USE_SYSTEM_SQLITE=y" >> tup.config
+}
+
+src_compile() {
+ # Disabling namespacing because it leads to accessing /proc/<pid>/setgroups
+ # which violates sandboxing.
+ export TUP_NO_NAMESPACING=1
+ ./bootstrap-nofuse.sh || die
+ unset TUP_NO_NAMESPACING
+}
+
+src_install() {
+ dobin tup
+ dolib.a libtup_client.a
+ doheader tup_client.h
+ doman tup.1
+}
+
+src_test() {
+ # tup uses fuse when tracking dependencies.
+ addwrite /dev/fuse
+
+ # Disabling namespacing because it leads to accessing /proc/<pid>/setgroups
+ # which violates sandboxing.
+ export TUP_NO_NAMESPACING=1
+
+ # Skip tests which require namespacing or root privileges.
+ SKIPPED_TESTS=(
+ t4062-full-deps.sh
+ t4063-full-deps2.sh
+ t4064-full-deps3.sh
+ t4065-full-deps-proc.sh
+ t4067-full-deps5.sh
+ t4069-gcc-coverage.sh
+ t4072-proc-self.sh
+ t4074-getpwd.sh
+ t4131-proc-self-exe.sh
+ t4132-proc-meminfo.sh
+ t4171-dev-null.sh
+ t5083-symlink-fullpath.sh
+ t5084-symlink-fullpath2.sh
+ t7048-full-deps.sh
+ )
+ pushd test || die
+ rm ${SKIPPED_TESTS[@]} || die
+ ./test.sh || die
+ popd || die
+
+ unset TUP_NO_NAMESPACING
+}
diff --git a/dev-util/tup/tup-9999.ebuild b/dev-util/tup/tup-9999.ebuild
new file mode 100644
index 000000000000..104dd83a9dbd
--- /dev/null
+++ b/dev-util/tup/tup-9999.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="A file-based build system"
+HOMEPAGE="http://gittup.org/tup"
+# Tup itself is GPLv2, but it bundles differently licensed software:
+# - lua: MIT
+# - sqlite (unused in this ebuild): public domain
+# - inih: 3-clause BSD
+# - red-black tree implementation: 2-clause BSD
+# - queue implementation: 3-clause BSD
+LICENSE="GPL-2 MIT public-domain BSD BSD-2"
+SLOT="0"
+
+if [[ "${PV}" == 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/gittup/tup.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/gittup/tup/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DEPEND="
+ dev-db/sqlite:=
+ sys-fs/fuse:=
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # Use our toolchain
+ sed -i Tuprules.tup \
+ -e "s:CC = gcc:CC = $(tc-getCC) ${CFLAGS} ${LDFLAGS}:" \
+ -e "s:ar crs:$(tc-getAR) crs:"
+
+ if [[ ${PV} != 9999 ]]; then
+ # Avoid invoking `git` to find version, use ours
+ sed -i src/tup/link.sh \
+ -e 's;`git describe`;v'"${PV};"
+ fi
+
+ default
+}
+
+src_configure () {
+ echo "CONFIG_TUP_USE_SYSTEM_SQLITE=y" >> tup.config
+}
+
+src_compile() {
+ # Disabling namespacing because it leads to accessing /proc/<pid>/setgroups
+ # which violates sandboxing.
+ export TUP_NO_NAMESPACING=1
+ ./bootstrap-nofuse.sh || die
+ unset TUP_NO_NAMESPACING
+}
+
+src_install() {
+ dobin tup
+ dolib.a libtup_client.a
+ doheader tup_client.h
+ doman tup.1
+}
+
+src_test() {
+ # tup uses fuse when tracking dependencies.
+ addwrite /dev/fuse
+
+ # Disabling namespacing because it leads to accessing /proc/<pid>/setgroups
+ # which violates sandboxing.
+ export TUP_NO_NAMESPACING=1
+
+ # Skip tests which require namespacing or root privileges.
+ SKIPPED_TESTS=(
+ t4062-full-deps.sh
+ t4063-full-deps2.sh
+ t4064-full-deps3.sh
+ t4065-full-deps-proc.sh
+ t4067-full-deps5.sh
+ t4069-gcc-coverage.sh
+ t4072-proc-self.sh
+ t4074-getpwd.sh
+ t4131-proc-self-exe.sh
+ t4132-proc-meminfo.sh
+ t4171-dev-null.sh
+ t5083-symlink-fullpath.sh
+ t5084-symlink-fullpath2.sh
+ t7048-full-deps.sh
+ )
+ pushd test || die
+ rm ${SKIPPED_TESTS[@]} || die
+ ./test.sh || die
+ popd || die
+
+ unset TUP_NO_NAMESPACING
+}