summaryrefslogtreecommitdiff
path: root/dev-util/trinity/trinity-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-util/trinity/trinity-9999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-util/trinity/trinity-9999.ebuild')
-rw-r--r--dev-util/trinity/trinity-9999.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-util/trinity/trinity-9999.ebuild b/dev-util/trinity/trinity-9999.ebuild
new file mode 100644
index 000000000000..2e263c788cee
--- /dev/null
+++ b/dev-util/trinity/trinity-9999.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs git-r3
+
+EGIT_REPO_URI="https://github.com/kernelslacker/trinity.git"
+
+DESCRIPTION="A Linux system call fuzz tester"
+HOMEPAGE="http://codemonkey.org.uk/projects/trinity/ https://github.com/kernelslacker/trinity/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="examples"
+
+DEPEND="sys-kernel/linux-headers"
+
+src_prepare() {
+ sed -e 's/-g -O2//' \
+ -e 's/-D_FORTIFY_SOURCE=2//' \
+ -e '/-o $@/s/$(LDFLAGS) //' \
+ -i Makefile || die
+
+ tc-export CC
+ default
+}
+
+src_compile() {
+ emake V=1
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc Documentation/* README
+
+ if use examples ; then
+ exeinto /usr/share/doc/${PF}/scripts
+ doexe scripts/*
+ docompress -x /usr/share/doc/${PF}/scripts
+ fi
+}