summaryrefslogtreecommitdiff
path: root/dev-util/treecc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /dev-util/treecc
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'dev-util/treecc')
-rw-r--r--dev-util/treecc/Manifest3
-rw-r--r--dev-util/treecc/treecc-0.3.10-r1.ebuild43
-rw-r--r--dev-util/treecc/treecc-0.3.10.ebuild6
3 files changed, 48 insertions, 4 deletions
diff --git a/dev-util/treecc/Manifest b/dev-util/treecc/Manifest
index 50cb52b5f08c..dd1e0930553f 100644
--- a/dev-util/treecc/Manifest
+++ b/dev-util/treecc/Manifest
@@ -1,3 +1,4 @@
DIST treecc-0.3.10.tar.gz 375762 BLAKE2B 1d4fb6905226d79bef021808639f011731cd665b76db07efbf0ab4285c35986c1efa99381694ab5ddbb20131a8bef0d26b677d1b3e5311f2fe8fa99b1a575efb SHA512 426add1a96913a169a0f03a6e3247a8b48c9073335cf967ef05d4d4188fbe3b8ebc837b38b9a4de94ccdb13685ace47a91b185c75a845cf2670e929802774b73
-EBUILD treecc-0.3.10.ebuild 1136 BLAKE2B 2ccfec687eb4d19811b7cdc3c46addf929050d65c52a09a26900fcad8687ff8f08707b4c1e2737f1ad7887309fe9cc34e390e214b2cd920b51123ad9662ec830 SHA512 7a8067318e17c4eea0262463ca1b1cb384caab13311f4d996ee0e1cc2b6723dd0f4ec3f3c6c81a5b5214b24d6b946fbbd4603a96d8280a29d14ad2b3dfbe9435
+EBUILD treecc-0.3.10-r1.ebuild 1004 BLAKE2B fd82dacd8738fa84f8aaec95cc6835205be791f3e5c9cfc2e54398a7662025e8fe72057585dab66d3a4c08d43d0b9d03a692f79e25041d714ad2f0a153dc8d1b SHA512 8698ec331ae51772cc6664516555caf5aebb52a2114aa825639272c71cd3d290c8232407682b036472dcdd42235df438f623b2d0a1c5b4d5a0254dab79e6dbac
+EBUILD treecc-0.3.10.ebuild 1135 BLAKE2B 9c4d314f1478636dce24b38bbf0bff709236a4ebe59b720973a7348e3965ce8fe1f6216ad585c23e35d6dd7623f70cc98670f233f1727eaf0f68e840f5fc39be SHA512 b84c2984feeb18e72f6c892943a7b4132bccaf8d41d78342d1657630834b1874d5d040d78b4a48cf5b7bb3ae9bc5b86e91801489156b8df04f3bfe38d1e58473
MISC metadata.xml 251 BLAKE2B 102da490c04b5ec767aebd0f076ea9aa083ec51416f584daad83e4202bd51e7182e95b7c1c98125c2a9da29eaa6b97dd4d9825c9d72e9c89d85d209e89031f48 SHA512 9b3d8ef0e933c58ceeae768b5e07fec1aba98d2f0add71719bcdec0e571b503b102610c0c4cbc322cc15638547e2f26f149d80c1498edb10b16a874014ae20d0
diff --git a/dev-util/treecc/treecc-0.3.10-r1.ebuild b/dev-util/treecc/treecc-0.3.10-r1.ebuild
new file mode 100644
index 000000000000..10b7e4a3fb6c
--- /dev/null
+++ b/dev-util/treecc/treecc-0.3.10-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Compiler-compiler tool for aspect-oriented programming"
+HOMEPAGE="https://www.gnu.org/software/dotgnu"
+SRC_URI="https://download.savannah.gnu.org/releases/dotgnu-pnet/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~amd64-linux ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sparc ~sparc-solaris ~x86 ~x86-linux"
+IUSE="doc examples"
+
+DEPEND="doc? ( app-text/texi2html )"
+
+src_compile() {
+ default
+
+ if use doc; then
+ [[ -f "${S}"/doc/treecc.texi ]] || die "treecc.texi was not generated"
+ cd "${S}"/doc || die
+ texi2html -split_chapter "${S}"/doc/treecc.texi \
+ || die "texi2html failed"
+ cd "${S}" || die
+ fi
+}
+
+src_install() {
+ default
+
+ if use examples; then
+ docinto examples
+ dodoc examples/README
+ dodoc examples/{expr_c.tc,gram_c.y,scan_c.l}
+ fi
+
+ if use doc; then
+ dodoc doc/*.{txt,html}
+ docinto html
+ dodoc -r doc/treecc/*.html
+ fi
+}
diff --git a/dev-util/treecc/treecc-0.3.10.ebuild b/dev-util/treecc/treecc-0.3.10.ebuild
index 5600422561cc..7538dd6f11f4 100644
--- a/dev-util/treecc/treecc-0.3.10.ebuild
+++ b/dev-util/treecc/treecc-0.3.10.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=0
DESCRIPTION="compiler-compiler tool for aspect-oriented programming"
HOMEPAGE="https://www.gnu.org/software/dotgnu"
-SRC_URI="http://download.savannah.gnu.org/releases/dotgnu-pnet/${P}.tar.gz"
+SRC_URI="https://download.savannah.gnu.org/releases/dotgnu-pnet/${P}.tar.gz"
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris"
IUSE="doc examples"