summaryrefslogtreecommitdiff
path: root/dev-util/treecc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-util/treecc
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/treecc')
-rw-r--r--dev-util/treecc/Manifest3
-rw-r--r--dev-util/treecc/metadata.xml8
-rw-r--r--dev-util/treecc/treecc-0.3.10.ebuild49
3 files changed, 60 insertions, 0 deletions
diff --git a/dev-util/treecc/Manifest b/dev-util/treecc/Manifest
new file mode 100644
index 000000000000..50cb52b5f08c
--- /dev/null
+++ b/dev-util/treecc/Manifest
@@ -0,0 +1,3 @@
+DIST treecc-0.3.10.tar.gz 375762 BLAKE2B 1d4fb6905226d79bef021808639f011731cd665b76db07efbf0ab4285c35986c1efa99381694ab5ddbb20131a8bef0d26b677d1b3e5311f2fe8fa99b1a575efb SHA512 426add1a96913a169a0f03a6e3247a8b48c9073335cf967ef05d4d4188fbe3b8ebc837b38b9a4de94ccdb13685ace47a91b185c75a845cf2670e929802774b73
+EBUILD treecc-0.3.10.ebuild 1136 BLAKE2B 2ccfec687eb4d19811b7cdc3c46addf929050d65c52a09a26900fcad8687ff8f08707b4c1e2737f1ad7887309fe9cc34e390e214b2cd920b51123ad9662ec830 SHA512 7a8067318e17c4eea0262463ca1b1cb384caab13311f4d996ee0e1cc2b6723dd0f4ec3f3c6c81a5b5214b24d6b946fbbd4603a96d8280a29d14ad2b3dfbe9435
+MISC metadata.xml 251 BLAKE2B 102da490c04b5ec767aebd0f076ea9aa083ec51416f584daad83e4202bd51e7182e95b7c1c98125c2a9da29eaa6b97dd4d9825c9d72e9c89d85d209e89031f48 SHA512 9b3d8ef0e933c58ceeae768b5e07fec1aba98d2f0add71719bcdec0e571b503b102610c0c4cbc322cc15638547e2f26f149d80c1498edb10b16a874014ae20d0
diff --git a/dev-util/treecc/metadata.xml b/dev-util/treecc/metadata.xml
new file mode 100644
index 000000000000..c99669dda129
--- /dev/null
+++ b/dev-util/treecc/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>dotnet@gentoo.org</email>
+ <name>Gentoo Dotnet Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-util/treecc/treecc-0.3.10.ebuild b/dev-util/treecc/treecc-0.3.10.ebuild
new file mode 100644
index 000000000000..5600422561cc
--- /dev/null
+++ b/dev-util/treecc/treecc-0.3.10.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=0
+
+DESCRIPTION="compiler-compiler tool for aspect-oriented programming"
+HOMEPAGE="https://www.gnu.org/software/dotgnu"
+SRC_URI="http://download.savannah.gnu.org/releases/dotgnu-pnet/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris"
+IUSE="doc examples"
+
+DEPEND="doc? ( app-text/texi2html )"
+
+src_compile() {
+ econf || die "econf failed"
+ emake || die "emake failed"
+
+ if use doc ; then
+ if [ ! -f "${S}"/doc/treecc.texi ] ; then
+ die "treecc.texi was not generated"
+ fi
+
+ cd "${S}"/doc
+ texi2html -split_chapter "${S}"/doc/treecc.texi \
+ || die "texi2html failed"
+ cd "${S}"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README
+
+ if use examples ; then
+ docinto examples
+ dodoc examples/README
+ dodoc examples/{expr_c.tc,gram_c.y,scan_c.l}
+ fi
+
+ if use doc ; then
+ dodoc doc/*.{txt,html}
+
+ docinto html
+ dohtml doc/treecc/*.html
+ fi
+}