summaryrefslogtreecommitdiff
path: root/dev-util/sysprof
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /dev-util/sysprof
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'dev-util/sysprof')
-rw-r--r--dev-util/sysprof/Manifest2
-rw-r--r--dev-util/sysprof/sysprof-3.44.0.ebuild81
2 files changed, 83 insertions, 0 deletions
diff --git a/dev-util/sysprof/Manifest b/dev-util/sysprof/Manifest
index 53a53054c052..0a81ad2b5986 100644
--- a/dev-util/sysprof/Manifest
+++ b/dev-util/sysprof/Manifest
@@ -1,3 +1,5 @@
DIST sysprof-3.42.1.tar.xz 484096 BLAKE2B bc1124651f6323d6757050ef3225df222039ac7a5c6a6e2a0e170354a0e89705ea03173302ac7fa2bc172b27485d4e4cdee0f7504a548d51e88b88a19cc8cc9d SHA512 15bf7efadfc88c1342200009e4b74ecd23a320ca272b4ca3736dd41baf9cb4e0a1fd75e0aa20ee784b98c6fee7f86a2b52e63bc4769b6ca9759f58b64cba0dcd
+DIST sysprof-3.44.0.tar.xz 493924 BLAKE2B c3d9558df99ba23f63fbde0df54e201afce83da8f7d64166b44fcc2c70ec9e54a4abfbd0ac64171b1538af7e9d608b0f618559aba9444a3d884cd4944c4d595f SHA512 64bfe4d39e71954f7982ef06caffc39ff60d2d6005f8392a7918f83263d7c5b11bafdf7234ed86d52063586919a4dbe742c498b6f1f9db91d481337cf568451c
EBUILD sysprof-3.42.1.ebuild 2304 BLAKE2B b7fbc87c1a56e5a83965d0c17086710aae0a6a1771cfc8e99dd452088972919bd775ab0e0534a9c9fae938c63d1de997fd67294a4b1f0fdee02d221f17a30b27 SHA512 a2adc3f5ac2845c180c2bd625d9be5927a9843b84957923ca7f5548caa8d2492ada33e276b31cbaeee404306d5b60dd7ec1bcf86da1215c22a1ad3e2f89d49d9
+EBUILD sysprof-3.44.0.ebuild 2321 BLAKE2B 6c96bb4c5d0e666d69b1110f80e55b277d93078a0aea269aeee9d8767a4429b4d64df493d3d8b260bee8095d9c8c07e260a0427bc75d67a50a7ad027cafe4396 SHA512 d22006259f4960111708f908acee62a1042a929777f0dc34bf9383906bce4e25e2a9b78403c8741038caf6fe2717396610fd532db3a50c5cd92ee5c8557a4de9
MISC metadata.xml 705 BLAKE2B 2880fd6741b2033f9b1d00ca873164d7bbf37cac8c993a83218567e13f2d7f6121419c9e79402715321b14cdbc6592a15bd567fa753dadfc61cf54c1997f8169 SHA512 b4c96e1f8a29fcbd5bd9ac7e16775b9db0f2b237767edfde42c073b4082c4428e0357c785ffbce8f6d662cb8bc9dfc23abb9ae36f3f2a2deb5a578f225dcc898
diff --git a/dev-util/sysprof/sysprof-3.44.0.ebuild b/dev-util/sysprof/sysprof-3.44.0.ebuild
new file mode 100644
index 000000000000..4d11d4646eaa
--- /dev/null
+++ b/dev-util/sysprof/sysprof-3.44.0.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson systemd xdg
+
+DESCRIPTION="System-wide Linux Profiler"
+HOMEPAGE="http://sysprof.com/"
+
+LICENSE="GPL-3+ GPL-2+"
+API_VERSION="4"
+SLOT="0/${API_VERSION}"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="gtk +unwind"
+
+RDEPEND="
+ >=dev-libs/glib-2.67.4:2
+ gtk? (
+ >=x11-libs/gtk+-3.22.0:3
+ >=dev-libs/libdazzle-3.30.0
+ )
+ dev-libs/json-glib
+ >=sys-auth/polkit-0.114
+ unwind? ( sys-libs/libunwind:= )
+ >=dev-util/sysprof-common-${PV}
+ >=dev-util/sysprof-capture-${PV}:${API_VERSION}
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-util/gdbus-codegen
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ >=sys-kernel/linux-headers-2.6.32
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ xdg_environment_reset
+ # These are installed by dev-util/sysprof-capture
+ sed -i -e '/install/d' src/libsysprof-capture/meson.build || die
+ sed -i -e 's/pkgconfig\.generate/subdir_done()\npkgconfig\.generate/' src/libsysprof-capture/meson.build || die
+ # We want to ship org.gnome.Sysprof3.Profiler.xml in sysprof-common for the benefit of x11-wm/mutter
+ sed -i -e "s|if get_option('libsysprof')|if false|g" src/meson.build || die
+}
+
+src_configure() {
+ # -Dwith_sysprofd=host currently unavailable from ebuild
+ local emesonargs=(
+ $(meson_use gtk enable_gtk)
+ -Dlibsysprof=true
+ -Dwith_sysprofd=bundled
+ -Dsystemdunitdir=$(systemd_get_systemunitdir)
+ # -Ddebugdir
+ -Dhelp=true
+ $(meson_use unwind libunwind)
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+
+ elog "On many systems, especially amd64, it is typical that with a modern"
+ elog "toolchain -fomit-frame-pointer for gcc is the default, because"
+ elog "debugging is still possible thanks to gcc4/gdb location list feature."
+ elog "However sysprof is not able to construct call trees if frame pointers"
+ elog "are not present. Therefore -fno-omit-frame-pointer CFLAGS is suggested"
+ elog "for the libraries and applications involved in the profiling. That"
+ elog "means a CPU register is used for the frame pointer instead of other"
+ elog "purposes, which means a very minimal performance loss when there is"
+ elog "register pressure."
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}