summaryrefslogtreecommitdiff
path: root/dev-util/sysprof
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-02 19:14:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-02 19:14:55 +0100
commitb24bd25253fe093f722ab576d29fdc41d04cb1ee (patch)
tree0fcf2afd9f852c4d4c291cf8afaa2c244d598105 /dev-util/sysprof
parent121ed4eec41fbf03e1998d09eede1bf449da63b9 (diff)
gentoo resync : 02.08.2019
Diffstat (limited to 'dev-util/sysprof')
-rw-r--r--dev-util/sysprof/Manifest2
-rw-r--r--dev-util/sysprof/sysprof-3.32.0.ebuild74
2 files changed, 76 insertions, 0 deletions
diff --git a/dev-util/sysprof/Manifest b/dev-util/sysprof/Manifest
index 5d35d5c95e48..a51347ff8f68 100644
--- a/dev-util/sysprof/Manifest
+++ b/dev-util/sysprof/Manifest
@@ -1,4 +1,6 @@
AUX 3.30.2-elogind.patch 1055 BLAKE2B c25d6b83d75d8155ef09d1aa5cdd8dead79a1fe796028cec79166e24ae8a579af83c396c7f4e91948a56bb2215cb180657728c35d84ee8ed09134d4ee72a17cf SHA512 6ed6fcf43238378486f430bf653cc6f209f6bd42136e14f0888b8b190a63058bfcec8777a6df0f1f454b14ef91c6075d342585a8c339a11604ffc3e712057017
DIST sysprof-3.30.2.tar.xz 393420 BLAKE2B 5e86a78c231d2d2c601198e066c463d8bec95ab1ae6d0f6678e6e80305b8a6d53c604ce54d9fc2a473e4679695cef709f0e1a9514f1091719f33a58b92c896eb SHA512 70c49f7c20742aad82c8d9b1e303d06ca5fd2d27a6868872d28affea22278d381bf3eb0d181cbd1bfa490bda2878c52748ac29273e9e608452e9bf4f29fd9e2a
+DIST sysprof-3.32.0.tar.xz 296052 BLAKE2B f409c64d40bd3451037e601683f270ff93ea2a60a2c104d22edc6bad5ff3f5c974f80137776b6329dae932852fa0871f2b7b9960a282147ddef5402ad840d9ef SHA512 7b9d84ac241d376a5e545082b1224e7db96af26ae0ee297d5f0b2d45abc4676e23009dbd560085e5d4879378a8dd79eefb4449df3961fbfd09238bd2056061d0
EBUILD sysprof-3.30.2-r1.ebuild 2211 BLAKE2B 13b96d356dbb464c6f1ed74b7f6216d28fd5a8c54a2c9f1611712a49215a9a7b0c32a7f63c949ac270ca1c12e66a49aed16ddf7b1f016175d3a4cc604de9d416 SHA512 5ccd0335b55be7357e57b82105eaecfd54e515c56ccdd63552fa78c7262d3021676a7fc983903e2819b801b56fef7c687670cd4bbbe199c33c87cb5502210c60
+EBUILD sysprof-3.32.0.ebuild 2225 BLAKE2B d51feca57cc2b24e366c1afdd7337fe92b9faee63586cdbc2dcf1c90f48dda54341bfff8428a04703be5ace41edcd411c3a91e135ee7f52e1acf26b5bfc6fd05 SHA512 688f3fdbc8b341d7d60b3536e55fbd94f7a748f393be5159fa8e9317d35b095cca59f4df2d54132230391699bb03c83177946e109b9489c87aab5748f959552d
MISC metadata.xml 886 BLAKE2B 31416bfe6eb56d58ae1c1953d19cc59ee0cff0c0aa7d6c28f6b95b7b4c9038ea9a8af5025e64f29612b6b919953671eb4940ff60d6baf1c79b8d33bdfae2beff SHA512 5514125c6a2dcb55a06bc81e52bb6c94a804b0dc41ce7d7c83e9ee94f06ddcd585716c12887a6428e1afe3a9268cdc4cd0596d7a036de08f0e70ae3d6366f502
diff --git a/dev-util/sysprof/sysprof-3.32.0.ebuild b/dev-util/sysprof/sysprof-3.32.0.ebuild
new file mode 100644
index 000000000000..16e41d082136
--- /dev/null
+++ b/dev-util/sysprof/sysprof-3.32.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org gnome2-utils meson systemd xdg
+
+DESCRIPTION="System-wide Linux Profiler"
+HOMEPAGE="http://sysprof.com/"
+
+LICENSE="GPL-3+ GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="elogind gtk systemd"
+REQUIRED_USE="?? ( elogind systemd )"
+
+RDEPEND="
+ >=dev-libs/glib-2.44:2
+ sys-auth/polkit
+ gtk? ( >=x11-libs/gtk+-3.22.0:3 )
+ elogind? ( >=sys-auth/elogind-239.3 )
+ systemd? ( >=sys-apps/systemd-222:0= )
+"
+DEPEND="${RDEPEND}"
+# libxml2 required for glib-compile-resources; appstream-glib for appdata.xml developer_name tag translation
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-libs/libxml2:2
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ >=sys-kernel/linux-headers-2.6.32
+ virtual/pkgconfig
+"
+
+PATCHES=( "${FILESDIR}"/3.30.2-elogind.patch )
+
+src_configure() {
+ # -Dwith_sysprofd=host currently unavailable from ebuild
+ local emesonargs=(
+ $(meson_use gtk enable_gtk)
+ -Dwith_sysprofd=$(usex systemd bundled $(usex elogind bundled none))
+ -Dsystemdunitdir=$(systemd_get_systemunitdir)
+ # -Ddebugdir
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+
+ elog "On many systems, especially amd64, it is typical that with a modern"
+ elog "toolchain -fomit-frame-pointer for gcc is the default, because"
+ elog "debugging is still possible thanks to gcc4/gdb location list feature."
+ elog "However sysprof is not able to construct call trees if frame pointers"
+ elog "are not present. Therefore -fno-omit-frame-pointer CFLAGS is suggested"
+ elog "for the libraries and applications involved in the profiling. That"
+ elog "means a CPU register is used for the frame pointer instead of other"
+ elog "purposes, which means a very minimal performance loss when there is"
+ elog "register pressure."
+ if ! use systemd && ! use elogind; then
+ elog ""
+ elog "Without systemd or elogind, sysprof may not function when launched as a"
+ elog "regular user, thus suboptimal running from root account may be necessary."
+ if use gtk; then
+ elog "Under wayland, that limits the recording usage to sysprof-cli utility."
+ fi
+ fi
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}