summaryrefslogtreecommitdiff
path: root/dev-util/sysprof
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /dev-util/sysprof
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'dev-util/sysprof')
-rw-r--r--dev-util/sysprof/Manifest2
-rw-r--r--dev-util/sysprof/sysprof-3.42.1.ebuild80
2 files changed, 82 insertions, 0 deletions
diff --git a/dev-util/sysprof/Manifest b/dev-util/sysprof/Manifest
index e9f1ed3f4611..d49592486c4b 100644
--- a/dev-util/sysprof/Manifest
+++ b/dev-util/sysprof/Manifest
@@ -1,3 +1,5 @@
DIST sysprof-3.40.1.tar.xz 468320 BLAKE2B fcba3b627ea32c38e621046027fced7478b6c57ba5487834d35fdde45a38bf4df66e5d696e93627217fa237978a6e7074b9e92ae89f963db7b6fca4482b59053 SHA512 ad07fd21066dfa6c7be81acdb720d97f392e1bbd05e71dd45d743b10a631b2b2c4c1177086f28e7f500271add79aa3356dd2aebdb97604357c4fef43809ead87
+DIST sysprof-3.42.1.tar.xz 484096 BLAKE2B bc1124651f6323d6757050ef3225df222039ac7a5c6a6e2a0e170354a0e89705ea03173302ac7fa2bc172b27485d4e4cdee0f7504a548d51e88b88a19cc8cc9d SHA512 15bf7efadfc88c1342200009e4b74ecd23a320ca272b4ca3736dd41baf9cb4e0a1fd75e0aa20ee784b98c6fee7f86a2b52e63bc4769b6ca9759f58b64cba0dcd
EBUILD sysprof-3.40.1-r1.ebuild 2304 BLAKE2B 18539b824c808106bf0d7628020b618c47b2312938c55a385c8ae8a54ef957af170899e4d8ed80e392c6aedf6d1ddc73554fb351301284abd8537b451f48ec12 SHA512 34186f124c49962252bf938f7ddbcb09967a8be0aa5eade53bfd7732545e1135b2653f9e1be8eb3e22d06d7ee53aee9351bac9c69f465e7e60f977e99f43f2e1
+EBUILD sysprof-3.42.1.ebuild 2306 BLAKE2B f8060ed7e42a339640ccacb770f66074368f7c1d5f29088e6cbe9326dd09b40d7d2eb740e6edb05303bb388a48fdf0893f62fa81a9deef57b8af58c2f84e32bf SHA512 0e3c17451a5cf241d543045a8d5df06d9bd600a0f5a625412af2d6b0c3fdeed03220ae2a0f3248b70a71e88db95e40dada731614eb1e103386672e4c44a8888b
MISC metadata.xml 705 BLAKE2B 2880fd6741b2033f9b1d00ca873164d7bbf37cac8c993a83218567e13f2d7f6121419c9e79402715321b14cdbc6592a15bd567fa753dadfc61cf54c1997f8169 SHA512 b4c96e1f8a29fcbd5bd9ac7e16775b9db0f2b237767edfde42c073b4082c4428e0357c785ffbce8f6d662cb8bc9dfc23abb9ae36f3f2a2deb5a578f225dcc898
diff --git a/dev-util/sysprof/sysprof-3.42.1.ebuild b/dev-util/sysprof/sysprof-3.42.1.ebuild
new file mode 100644
index 000000000000..477ae9142b54
--- /dev/null
+++ b/dev-util/sysprof/sysprof-3.42.1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org gnome2-utils meson systemd xdg
+
+DESCRIPTION="System-wide Linux Profiler"
+HOMEPAGE="http://sysprof.com/"
+
+LICENSE="GPL-3+ GPL-2+"
+API_VERSION="4"
+SLOT="0/${API_VERSION}"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="gtk +unwind"
+
+RDEPEND="
+ >=dev-libs/glib-2.67.4:2
+ gtk? (
+ >=x11-libs/gtk+-3.22.0:3
+ >=dev-libs/libdazzle-3.30.0
+ )
+ dev-libs/json-glib
+ >=sys-auth/polkit-0.114
+ unwind? ( sys-libs/libunwind:= )
+ >=dev-util/sysprof-common-${PV}
+ >=dev-util/sysprof-capture-${PV}:${API_VERSION}
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-util/gdbus-codegen
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ >=sys-kernel/linux-headers-2.6.32
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ xdg_src_prepare
+ # These are installed by dev-util/sysprof-capture
+ sed -i -e '/install/d' src/libsysprof-capture/meson.build || die
+ sed -i -e 's/pkgconfig\.generate/subdir_done()\npkgconfig\.generate/' src/libsysprof-capture/meson.build || die
+ # We want to ship org.gnome.Sysprof3.Profiler.xml in sysprof-common for the benefit of x11-wm/mutter
+ sed -i -e "s|if get_option('libsysprof')|if false|g" src/meson.build || die
+}
+
+src_configure() {
+ # -Dwith_sysprofd=host currently unavailable from ebuild
+ local emesonargs=(
+ $(meson_use gtk enable_gtk)
+ -Dlibsysprof=true
+ -Dwith_sysprofd=bundled
+ -Dsystemdunitdir=$(systemd_get_systemunitdir)
+ # -Ddebugdir
+ -Dhelp=true
+ $(meson_use unwind libunwind)
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+
+ elog "On many systems, especially amd64, it is typical that with a modern"
+ elog "toolchain -fomit-frame-pointer for gcc is the default, because"
+ elog "debugging is still possible thanks to gcc4/gdb location list feature."
+ elog "However sysprof is not able to construct call trees if frame pointers"
+ elog "are not present. Therefore -fno-omit-frame-pointer CFLAGS is suggested"
+ elog "for the libraries and applications involved in the profiling. That"
+ elog "means a CPU register is used for the frame pointer instead of other"
+ elog "purposes, which means a very minimal performance loss when there is"
+ elog "register pressure."
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}