summaryrefslogtreecommitdiff
path: root/dev-util/sysprof
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-24 23:32:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-24 23:32:34 +0100
commit83c7eb1835fcfdf7072b953d23ab34f03c7e8ed6 (patch)
treed44aefcc259a6d52e3d3b0c9929f52aedd24d001 /dev-util/sysprof
parent7138219e3c9446bf981ff17f5609f42130bec414 (diff)
gentoo auto-resync : 24:09:2022 - 23:32:34
Diffstat (limited to 'dev-util/sysprof')
-rw-r--r--dev-util/sysprof/Manifest2
-rw-r--r--dev-util/sysprof/sysprof-3.46.0.ebuild98
2 files changed, 100 insertions, 0 deletions
diff --git a/dev-util/sysprof/Manifest b/dev-util/sysprof/Manifest
index 550947d7b0a1..0aff8988dace 100644
--- a/dev-util/sysprof/Manifest
+++ b/dev-util/sysprof/Manifest
@@ -1,3 +1,5 @@
DIST sysprof-3.44.0.tar.xz 493924 BLAKE2B c3d9558df99ba23f63fbde0df54e201afce83da8f7d64166b44fcc2c70ec9e54a4abfbd0ac64171b1538af7e9d608b0f618559aba9444a3d884cd4944c4d595f SHA512 64bfe4d39e71954f7982ef06caffc39ff60d2d6005f8392a7918f83263d7c5b11bafdf7234ed86d52063586919a4dbe742c498b6f1f9db91d481337cf568451c
+DIST sysprof-3.46.0.tar.xz 518536 BLAKE2B 8925f0cbe34411cce6bd86e9f4a924d3ff627429812682898fffe0a08c2dab9228e5d8bde44b460404f90fb29961a30154af1e8240df24bfa20b70cc7a36448e SHA512 ac248e2a06d2f7905bebae4e685dd320e3ac85097e33b9c6b8482a4647a5bfcaadc4d9a1fe117b3a74cb855d6c72d9a1453a37d7b64762a223c0fe5da2653a87
EBUILD sysprof-3.44.0.ebuild 2319 BLAKE2B b14273539a8aa3c28f5ebe605387b029e5f855706bfe01bf37d2b7636ed9eb354f60003bda48fc6f123de72ed5dc33343ab2804d846bf53dbb231a8fc50ec3f3 SHA512 3390589cf964c8a41235f0c4e072bc7d80da5374304fe575e9ac68843da9ca82f84badc20c701c0b1141ec53657ba6ba854e54b9e9f2f1d3f1e7ef4687f6d451
+EBUILD sysprof-3.46.0.ebuild 2532 BLAKE2B 744e40b799dc4f0207e36f79819a1c50f0bc378e4de28cbdf1884d53c87f3272a55dda91fb84754aa5c1d33d236ba8c55e82626dd590bad224b0cf1e27020db6 SHA512 5d9bf7c6046167d8381cdf6c300ab48a492a869c58ee6ebe0a899b30e230bf02dc3f40e0d21d306450f366253676adc8b51c2626bae70136fb89a62aee229361
MISC metadata.xml 705 BLAKE2B 2880fd6741b2033f9b1d00ca873164d7bbf37cac8c993a83218567e13f2d7f6121419c9e79402715321b14cdbc6592a15bd567fa753dadfc61cf54c1997f8169 SHA512 b4c96e1f8a29fcbd5bd9ac7e16775b9db0f2b237767edfde42c073b4082c4428e0357c785ffbce8f6d662cb8bc9dfc23abb9ae36f3f2a2deb5a578f225dcc898
diff --git a/dev-util/sysprof/sysprof-3.46.0.ebuild b/dev-util/sysprof/sysprof-3.46.0.ebuild
new file mode 100644
index 000000000000..679912d796cb
--- /dev/null
+++ b/dev-util/sysprof/sysprof-3.46.0.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson systemd xdg
+
+DESCRIPTION="System-wide Linux Profiler"
+HOMEPAGE="http://sysprof.com/"
+
+LICENSE="GPL-3+ GPL-2+"
+API_VERSION="4"
+SLOT="0/${API_VERSION}"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="gtk test +unwind"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.73.0:2
+ gtk? (
+ >=gui-libs/gtk-4.6:4
+ gui-libs/libadwaita:1
+ x11-libs/cairo
+ x11-libs/pango
+ )
+ dev-libs/json-glib
+ >=sys-auth/polkit-0.114
+ unwind? ( sys-libs/libunwind:= )
+ >=dev-util/sysprof-common-${PV}
+ >=dev-util/sysprof-capture-${PV}:${API_VERSION}
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-util/gdbus-codegen
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ >=sys-kernel/linux-headers-2.6.32
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ xdg_environment_reset
+
+ # These are installed by dev-util/sysprof-capture
+ sed -i \
+ -e '/install: not meson.is_subproject/d' \
+ -e '/install.*sysprof_header_subdir/d' \
+ -e 's/pkgconfig\.generate/subdir_done()\npkgconfig\.generate/' \
+ src/libsysprof-capture/meson.build || die
+}
+
+src_configure() {
+ # -Dsysprofd=host currently unavailable from ebuild
+ local emesonargs=(
+ $(meson_use gtk)
+ -Dlibsysprof=true
+ -Dinstall-static=false
+ -Dsysprofd=bundled
+ -Dsystemdunitdir=$(systemd_get_systemunitdir)
+ # -Ddebugdir
+ -Dhelp=true
+ $(meson_use unwind libunwind)
+ -Dtools=true
+ $(meson_use test tests)
+ -Dexamples=false
+ -Dagent=true
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ # We want to ship org.gnome.Sysprof3.Profiler.xml in sysprof-common for the benefit of x11-wm/mutter
+ rm "${ED}"/usr/share/dbus-1/interfaces/org.gnome.Sysprof3.Profiler.xml || die
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+
+ elog "On many systems, especially amd64, it is typical that with a modern"
+ elog "toolchain -fomit-frame-pointer for gcc is the default, because"
+ elog "debugging is still possible thanks to gcc4/gdb location list feature."
+ elog "However sysprof is not able to construct call trees if frame pointers"
+ elog "are not present. Therefore -fno-omit-frame-pointer CFLAGS is suggested"
+ elog "for the libraries and applications involved in the profiling. That"
+ elog "means a CPU register is used for the frame pointer instead of other"
+ elog "purposes, which means a very minimal performance loss when there is"
+ elog "register pressure."
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}