summaryrefslogtreecommitdiff
path: root/dev-util/sysprof-common
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /dev-util/sysprof-common
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'dev-util/sysprof-common')
-rw-r--r--dev-util/sysprof-common/Manifest2
-rw-r--r--dev-util/sysprof-common/sysprof-common-3.42.1.ebuild24
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-util/sysprof-common/Manifest b/dev-util/sysprof-common/Manifest
index 9365b0c52e44..81403b30e5a5 100644
--- a/dev-util/sysprof-common/Manifest
+++ b/dev-util/sysprof-common/Manifest
@@ -1,3 +1,5 @@
DIST sysprof-3.40.1.tar.xz 468320 BLAKE2B fcba3b627ea32c38e621046027fced7478b6c57ba5487834d35fdde45a38bf4df66e5d696e93627217fa237978a6e7074b9e92ae89f963db7b6fca4482b59053 SHA512 ad07fd21066dfa6c7be81acdb720d97f392e1bbd05e71dd45d743b10a631b2b2c4c1177086f28e7f500271add79aa3356dd2aebdb97604357c4fef43809ead87
+DIST sysprof-3.42.1.tar.xz 484096 BLAKE2B bc1124651f6323d6757050ef3225df222039ac7a5c6a6e2a0e170354a0e89705ea03173302ac7fa2bc172b27485d4e4cdee0f7504a548d51e88b88a19cc8cc9d SHA512 15bf7efadfc88c1342200009e4b74ecd23a320ca272b4ca3736dd41baf9cb4e0a1fd75e0aa20ee784b98c6fee7f86a2b52e63bc4769b6ca9759f58b64cba0dcd
EBUILD sysprof-common-3.40.1.ebuild 506 BLAKE2B b4719544edf03c1ff5391f9d39f616ef0afcccd609e4e46118d2638a518cc0fb0120073ce78365e9ae1e8e5122863e9f776cb9ea9d6ec356030174baa19c8c1e SHA512 e9d9dcea2c6e6feb0b156568f9693fce8b2978dafad9524c433361ce920f5ab78810226e4ea69e3366b52101a22e418edc37a8316e4d362d3bfba442a20b8365
+EBUILD sysprof-common-3.42.1.ebuild 508 BLAKE2B 76c68d0cb0f7382d633a222d5598e7b9140490aee8c3682805e4bcb90c67ba2b52649b2f3b8dc246b5d2bff66e2af2330a753a776652d9212baf824a6a1e8e57 SHA512 259e75ef331d2980041abbfeb8afd6c550dce78d5ab1c0b1683473ceae86229b3bc0187405daf9ea7dfa746d78eb520f7f66e3348ef79ad6d43cf1a5077a27e9
MISC metadata.xml 250 BLAKE2B 8f7f0fe023d43e380e7861e897e6afcb5de4baefb42ea9c65a57dfc0d204c6f787a99295141832e732ebb08be218da56ba77e2dd9639e4e3aabf718ce4db1d0c SHA512 2684e772dd6d83e4b49f08f2ba22d8a0a753e7b46863489eff1b5d1f2f147ad80ffd93245ca405ac4c747249bc1b754454ec9865fe16da70f9b257051e105fd8
diff --git a/dev-util/sysprof-common/sysprof-common-3.42.1.ebuild b/dev-util/sysprof-common/sysprof-common-3.42.1.ebuild
new file mode 100644
index 000000000000..efd695413d21
--- /dev/null
+++ b/dev-util/sysprof-common/sysprof-common-3.42.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+GNOME_ORG_MODULE="sysprof"
+
+inherit gnome.org
+
+DESCRIPTION="Static library for sysprof capture data generation"
+HOMEPAGE="http://sysprof.com/"
+
+LICENSE="GPL-3+ GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ !=dev-util/sysprof-3.34.1-r0
+ !=dev-util/sysprof-capture-3.36.0-r0
+"
+
+src_install() {
+ insinto /usr/share/dbus-1/interfaces/
+ doins "${S}"/src/org.gnome.Sysprof3.Profiler.xml
+}