summaryrefslogtreecommitdiff
path: root/dev-util/sysprof-capture
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /dev-util/sysprof-capture
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'dev-util/sysprof-capture')
-rw-r--r--dev-util/sysprof-capture/Manifest4
-rw-r--r--dev-util/sysprof-capture/metadata.xml8
-rw-r--r--dev-util/sysprof-capture/sysprof-capture-3.34.1-r1.ebuild50
-rw-r--r--dev-util/sysprof-capture/sysprof-capture-3.34.1.ebuild50
4 files changed, 112 insertions, 0 deletions
diff --git a/dev-util/sysprof-capture/Manifest b/dev-util/sysprof-capture/Manifest
new file mode 100644
index 000000000000..f6b4b1c52531
--- /dev/null
+++ b/dev-util/sysprof-capture/Manifest
@@ -0,0 +1,4 @@
+DIST sysprof-3.34.1.tar.xz 372612 BLAKE2B 3a50a00f29866ae8bf03cc7a57b598e40a6a37ad88ac2159087e4f2a8a6a5cef09b345dc5332fb1df9036c4e159e98f19adda45588150b059af313878b9b554c SHA512 5f2d820935291a3b578222d5daa87b0a2f74cd16d14daca19065495be61cf7359f00f12f452a5c0b4e05dfeb94e2376017c2288cad92dc0c4bb9bca51b903d19
+EBUILD sysprof-capture-3.34.1-r1.ebuild 1160 BLAKE2B 561181c13ade5d59acdc6baaeae1a2e4343ff36dc5f9de0378a408721c51e6ddfab24d9453e21a202e8efaa1d690653a0a4bbad50261577c2f6864a1ade5b51d SHA512 989fc8217a7e4899d67124768718be14b8abfc3fbd899806c32c9707890c11a918493e0a027744a6d9f0407703b93cbf9fe791d17f7b4eb7b0720c63f2c4c445
+EBUILD sysprof-capture-3.34.1.ebuild 1209 BLAKE2B ad76bbf11652385c69eb806fded3ed8adedb8f9ec582d5da8c5e84f3141339300c965bc1cde3a6b9fce99647b53fe464e57277b72dcdb631bb343a0cac7e54da SHA512 4aa74a8f178fd7b04677e999357aa554ad4dfbe2e46208f9bcbd625221851906226549923a166ece49252145b52522e443f82e0e7d26cbf7e3c7f459c45cd770
+MISC metadata.xml 249 BLAKE2B e71e1b95fee768c696704acbf7e3cf0e599ed2bc8de92bae0141d1194ef9e842bdc292798904487a9b90ddfda9b0e84abd3b76b1518576c1d288240e4e46f110 SHA512 c40662134899a5c9f0369a1017806f35adf3280a0b3c91726f7a8ca6012a073a8b471583f5bfb6fe95faac1dcf607e8e2e43f8c91d48ec46f4a8824e2f551506
diff --git a/dev-util/sysprof-capture/metadata.xml b/dev-util/sysprof-capture/metadata.xml
new file mode 100644
index 000000000000..39980802b1da
--- /dev/null
+++ b/dev-util/sysprof-capture/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-util/sysprof-capture/sysprof-capture-3.34.1-r1.ebuild b/dev-util/sysprof-capture/sysprof-capture-3.34.1-r1.ebuild
new file mode 100644
index 000000000000..7e76591dccd0
--- /dev/null
+++ b/dev-util/sysprof-capture/sysprof-capture-3.34.1-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+GNOME_ORG_MODULE="sysprof"
+
+inherit gnome.org meson systemd
+
+DESCRIPTION="Static library for sysprof capture data generation"
+HOMEPAGE="http://sysprof.com/"
+
+LICENSE="GPL-3+ GPL-2+"
+SLOT="3"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.61.3:2
+ !=dev-util/sysprof-3.34.1-r0"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/gdbus-codegen
+ >=sys-kernel/linux-headers-2.6.32
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ # In 3.34.1 -Dlibsysprof=false still installs various data files related with it;
+ # some of these seem fixed by 3.36
+ sed -i -e '/subdir.*data/d' meson.build || die
+}
+
+src_configure() {
+ local emesonargs=(
+ -Denable_gtk=false
+ -Dlibsysprof=false
+ -Dwith_sysprofd=none
+ -Dsystemdunitdir=$(systemd_get_systemunitdir)
+ # -Ddebugdir
+ -Dhelp=false
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ # In 3.36 these shouldn't be needed with with_sysprofd=none
+ rm "${ED}"/usr/share/dbus-1/interfaces/org.gnome.Sysprof2.xml || die
+ rm "${ED}"/usr/share/dbus-1/interfaces/org.gnome.Sysprof3.Service.xml || die
+}
diff --git a/dev-util/sysprof-capture/sysprof-capture-3.34.1.ebuild b/dev-util/sysprof-capture/sysprof-capture-3.34.1.ebuild
new file mode 100644
index 000000000000..fb4cdee37666
--- /dev/null
+++ b/dev-util/sysprof-capture/sysprof-capture-3.34.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+GNOME_ORG_MODULE="sysprof"
+
+inherit gnome.org meson systemd
+
+DESCRIPTION="Static library for sysprof capture data generation"
+HOMEPAGE="http://sysprof.com/"
+
+LICENSE="GPL-3+ GPL-2+"
+SLOT="3"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.61.3:2"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/gdbus-codegen
+ >=sys-kernel/linux-headers-2.6.32
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ # In 3.34.1 -Dlibsysprof=false still installs various data files related with it;
+ # some of these seem fixed by 3.36
+ sed -i -e '/subdir.*data/d' meson.build || die
+}
+
+src_configure() {
+ local emesonargs=(
+ -Denable_gtk=false
+ -Dlibsysprof=false
+ -Dwith_sysprofd=none
+ -Dsystemdunitdir=$(systemd_get_systemunitdir)
+ # -Ddebugdir
+ -Dhelp=false
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ # In 3.36 these shouldn't be needed with with_sysprofd=none
+ rm "${ED}"/usr/share/dbus-1/interfaces/org.gnome.Sysprof2.xml || die
+ rm "${ED}"/usr/share/dbus-1/interfaces/org.gnome.Sysprof3.Service.xml || die
+ rm "${ED}"/usr/share/dbus-1/interfaces/org.gnome.Sysprof3.Profiler.xml || die
+}