summaryrefslogtreecommitdiff
path: root/dev-util/sysprof-capture
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-18 06:30:37 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-18 06:30:37 +0000
commit12c505f7fcc9ddc89e96ed178df05aceec162d92 (patch)
treee86f8947a554ad913c7a767ea9486b60d3bff912 /dev-util/sysprof-capture
parent467e2131896a3030032cd5b0fab2094a045bf9d0 (diff)
gentoo auto-resync : 18:03:2023 - 06:30:37
Diffstat (limited to 'dev-util/sysprof-capture')
-rw-r--r--dev-util/sysprof-capture/Manifest2
-rw-r--r--dev-util/sysprof-capture/sysprof-capture-3.48.0.ebuild40
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-util/sysprof-capture/Manifest b/dev-util/sysprof-capture/Manifest
index 62247ce7116b..6ead38b49794 100644
--- a/dev-util/sysprof-capture/Manifest
+++ b/dev-util/sysprof-capture/Manifest
@@ -1,5 +1,7 @@
DIST sysprof-3.36.0.tar.xz 435956 BLAKE2B 990a6c6c28339594df915ed1fb98f504bf6b080a5e3c31af0cc4bcfd208027361f02a9068291692d082787a6fd42ab414079122a63e4706aee2511040379f0c8 SHA512 41f99cc3446a6624ea74fcdecd7a29a2e5e2d4086383d59a9064c4a3df5d9b8d08f4903ff4dcc85ffa9c6d42bd84dec5c03f6010fffd4415cc8fecf4dc0b23f4
DIST sysprof-3.46.0.tar.xz 518536 BLAKE2B 8925f0cbe34411cce6bd86e9f4a924d3ff627429812682898fffe0a08c2dab9228e5d8bde44b460404f90fb29961a30154af1e8240df24bfa20b70cc7a36448e SHA512 ac248e2a06d2f7905bebae4e685dd320e3ac85097e33b9c6b8482a4647a5bfcaadc4d9a1fe117b3a74cb855d6c72d9a1453a37d7b64762a223c0fe5da2653a87
+DIST sysprof-3.48.0.tar.xz 533092 BLAKE2B 5af48d9216f13ffcc8824b0ba6a4e0ff931c903991953e66c2b50534399320d3d3fccd6e8478b10dc895d19544f9c08733565d95fe9c2c70d64f2294ccce2330 SHA512 100b79fabee005b5445dab3ad78d43facf375a488aa6513e987deecd6a3036cc43bfd78db106a4b8a15b4280dcd975872784c839f560779183adb5a339b0648c
EBUILD sysprof-capture-3.36.0-r1.ebuild 744 BLAKE2B 433bfab5288a22ec0ff380cbc1a7c557acc803910be35b6545b1fda0103c6497140857a6bb79128c8e54909be9d4976f5184b2ef75fe572f8529ea47444f62ae SHA512 3ac57dd089f38aa713353e258f1414d2fe7e2f17c53a8ad3c38330751ec377086862a930b8c8d42fc5fb8549477ec49f376ebf3bd53a460f4fa2ce6adbc90bb9
EBUILD sysprof-capture-3.46.0.ebuild 778 BLAKE2B 18d1e2a5e29f9a4c0f016a4a953b553253c73392e38d4753dd1edf51e2081b004294b722050bac315f823edc86ff9def1231bf4118e2b686f34348fc1c787a5b SHA512 4cbda26df918fef6fd59d1c260db74f83798d2f2343c11200bcc740d962241d130082a598783b39de8b9578fc9bcacd236f1bf7327c26d3fe34f35bd72ea3479
+EBUILD sysprof-capture-3.48.0.ebuild 780 BLAKE2B 8e5d8b1ef38d1e3ed2bc88338f3ed93820d90d68c4da1c21888e61f758c805c022f79f3abec5628374d72297f27ae74b9b6bcb1bfb8cffcaee88b23fbdd27fe9 SHA512 62f294843d6eeb2c58f06d64a4e6ad0f2cc1064211c107c66d298e62efcc0877dc4dd69fa8e9e9fe68471bdb9f773fc32632da82a529136bf684fc428ec64429
MISC metadata.xml 348 BLAKE2B 6d20b95f03e7ae7ac3bc5e3633757cef8d68a914da52b6d6fab3c16af3abc54e3d571c770a16772e755c4246a611d3ae20b31a2bfe5d9acf934aa28c0e64719d SHA512 b5132c2bea9fc617ac3732001154e5000c37ff1034ddc904875d8d807aeec5dec3c8d7c0a36bd3ad26bc0310a70842daae96d743d9f82a4b2f1057ef8d65e406
diff --git a/dev-util/sysprof-capture/sysprof-capture-3.48.0.ebuild b/dev-util/sysprof-capture/sysprof-capture-3.48.0.ebuild
new file mode 100644
index 000000000000..f2e417f40bd4
--- /dev/null
+++ b/dev-util/sysprof-capture/sysprof-capture-3.48.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+GNOME_ORG_MODULE="sysprof"
+
+inherit gnome.org meson-multilib systemd
+
+DESCRIPTION="Static library for sysprof capture data generation"
+HOMEPAGE="http://sysprof.com/"
+
+LICENSE="GPL-3+ GPL-2+"
+SLOT="4"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/gdbus-codegen
+ >=sys-kernel/linux-headers-2.6.32
+ virtual/pkgconfig
+"
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Dgtk=false
+ -Dlibsysprof=false
+ -Dinstall-static=true
+ -Dsysprofd=none
+ -Dsystemdunitdir=$(systemd_get_systemunitdir)
+ # -Ddebugdir
+ -Dhelp=false
+ -Dlibunwind=false
+ -Dtools=false
+ -Dtests=false
+ -Dexamples=false
+ -Dagent=false
+ )
+ meson_src_configure
+}