summaryrefslogtreecommitdiff
path: root/dev-util/sysdig
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-31 10:55:17 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-03-31 10:55:17 +0100
commit75fc75ae1f0481ffdb78450e801a9b443ba641bd (patch)
treecef96ea0860ae39a202bbf1e226100335209627d /dev-util/sysdig
parent1173ad5704ce725916e0c332416aff326d850d06 (diff)
gentoo resync : 31.03.2018
Diffstat (limited to 'dev-util/sysdig')
-rw-r--r--dev-util/sysdig/Manifest2
-rw-r--r--dev-util/sysdig/sysdig-0.21.0.ebuild92
2 files changed, 94 insertions, 0 deletions
diff --git a/dev-util/sysdig/Manifest b/dev-util/sysdig/Manifest
index ddf8314ca06c..bc1094b91a82 100644
--- a/dev-util/sysdig/Manifest
+++ b/dev-util/sysdig/Manifest
@@ -1,3 +1,5 @@
DIST sysdig-0.20.0.tar.gz 750798 BLAKE2B 9e5c57abf81531f6643c661e539b06b33bda352eb3072e1ed686da3dc68550d90c94a4273554c2dd4752c73357f0bfe52bcbd10ad8551d8a2876552acf31292a SHA512 2549c8e2d0db0abd95e31272837fe5072c4c26926b2d17348bd8d73177bc024bab0a8503aa427f9134d8ca0a0bbc05fe97495933c3b8236db5fcb74df7c1efb2
+DIST sysdig-0.21.0.tar.gz 756010 BLAKE2B 0dfcc3e7f5c830e8b250e4edd9d470764ea6be25804fefbc59b020f208edc313a51b3fb783e538d2acb520c56ad7c8555f224fb90999c87b89125394a90d54a1 SHA512 73c516c9fccb504d4ccd37384aee37ece542d29f82d696acf7c90df18b3a1538faf8d2b29065eae1f3dca7c04c6c2dbe93ed9369bc1340216482c4af2f61d23a
EBUILD sysdig-0.20.0.ebuild 1881 BLAKE2B 13b91e07489dc8dd42a88fdccffe3f122f59a8b6256bca5b1559f95d9b3bbd34e1a6248dc1b98e241bd146103798bdfa2967230a88326ae1cdae4117892d492a SHA512 db667f8017f3f11ff462d79725c092c68e63adc87e970346831d93945ac2e5fdcaa8e97b7ac8d59a159e52d1a290b74554fee27b5e46569f57326c6c40c6a39f
+EBUILD sysdig-0.21.0.ebuild 1881 BLAKE2B 13b91e07489dc8dd42a88fdccffe3f122f59a8b6256bca5b1559f95d9b3bbd34e1a6248dc1b98e241bd146103798bdfa2967230a88326ae1cdae4117892d492a SHA512 db667f8017f3f11ff462d79725c092c68e63adc87e970346831d93945ac2e5fdcaa8e97b7ac8d59a159e52d1a290b74554fee27b5e46569f57326c6c40c6a39f
MISC metadata.xml 507 BLAKE2B 4e19c0d3370019c80eda625ae812a4485139ab8a83285946ebc6ef62abad280beaefaaac29d7a57e14b5ca5448bd9d1c23a8cf6a4f783149633dd09e7ae1465c SHA512 d218731de7acfbbfa3c3043b2d942c00b7f5aff1a020b6dca2019f202be3a5390f44337e04691a0d4641e661f7581f703db5fda3d2a116c0d63fb7d9da25ed06
diff --git a/dev-util/sysdig/sysdig-0.21.0.ebuild b/dev-util/sysdig/sysdig-0.21.0.ebuild
new file mode 100644
index 000000000000..e366e6626308
--- /dev/null
+++ b/dev-util/sysdig/sysdig-0.21.0.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
+MODULES_OPTIONAL_USE=modules
+inherit linux-mod bash-completion-r1 cmake-utils
+
+DESCRIPTION="A system exploration and troubleshooting tool"
+HOMEPAGE="https://www.sysdig.org/"
+SRC_URI="https://github.com/draios/sysdig/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libressl +modules"
+
+RDEPEND="
+ app-misc/jq:0=
+ dev-lang/luajit:2=
+ >=dev-libs/jsoncpp-0.6_pre:0=
+ dev-libs/libb64:0=
+ sys-libs/ncurses:0=
+ sys-libs/zlib:0=
+ libressl? ( dev-libs/libressl:0= )
+ !libressl? ( dev-libs/openssl:0= )
+ net-misc/curl:0="
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ virtual/os-headers"
+
+# needed for the kernel module
+CONFIG_CHECK="HAVE_SYSCALL_TRACEPOINTS ~TRACEPOINTS"
+
+pkg_pretend() {
+ linux-mod_pkg_setup
+}
+
+pkg_setup() {
+ linux-mod_pkg_setup
+}
+
+src_prepare() {
+ sed -i -e 's:-ggdb::' CMakeLists.txt || die
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ # we will use linux-mod for that
+ -DBUILD_DRIVER=OFF
+ # libscap examples are not installed or really useful
+ -DBUILD_LIBSCAP_EXAMPLES=OFF
+
+ # unbundle the deps
+ -DUSE_BUNDLED_DEPS=OFF
+ )
+
+ cmake-utils_src_configure
+
+ # setup linux-mod ugliness
+ MODULE_NAMES="sysdig-probe(extra:${S}/driver:)"
+ BUILD_PARAMS='KERNELDIR="${KERNEL_DIR}"'
+ BUILD_TARGETS="all"
+
+ if use modules; then
+ cmake-utils_src_make configure_driver
+
+ cp "${BUILD_DIR}"/driver/Makefile.dkms driver/Makefile || die
+ fi
+}
+
+src_compile() {
+ cmake-utils_src_compile
+
+ linux-mod_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ linux-mod_src_install
+
+ # remove sources
+ rm -r "${ED%/}"/usr/src || die
+
+ # move bashcomp to the proper location
+ dobashcomp "${ED%/}"/usr/etc/bash_completion.d/sysdig || die
+ rm -r "${ED%/}"/usr/etc || die
+}