summaryrefslogtreecommitdiff
path: root/dev-util/sysdig/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-03 14:26:22 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-03 14:26:22 +0000
commit5aede38e7304fc5c3bd8a2034b25758b15a19fa0 (patch)
tree95f6b79a072854ddd86f7932f876acb7fbaf7752 /dev-util/sysdig/files
parent2f28d79786e67cf29825843d6d04d4591a27f9cf (diff)
gentoo auto-resync : 03:01:2023 - 14:26:21
Diffstat (limited to 'dev-util/sysdig/files')
-rw-r--r--dev-util/sysdig/files/sysdig-0.27.1-grpc-absl-sync.patch25
-rw-r--r--dev-util/sysdig/files/sysdig-0.27.1-luajit-2.1.patch99
2 files changed, 0 insertions, 124 deletions
diff --git a/dev-util/sysdig/files/sysdig-0.27.1-grpc-absl-sync.patch b/dev-util/sysdig/files/sysdig-0.27.1-grpc-absl-sync.patch
deleted file mode 100644
index eaf689a54d0d..000000000000
--- a/dev-util/sysdig/files/sysdig-0.27.1-grpc-absl-sync.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-https://bugs.gentoo.org/817128
-https://github.com/hhoffstaette/portage/blob/master/dev-util/sysdig/files/0.27.1-grpc-absl-sync.patch
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -552,6 +552,7 @@ if(NOT WIN32 AND NOT APPLE)
- else()
- message(FATAL_ERROR "Couldn't find system grpc")
- endif()
-+ find_library(ABSL_SYNC_LIB NAMES absl_synchronization)
- find_program(GRPC_CPP_PLUGIN grpc_cpp_plugin)
- if(NOT GRPC_CPP_PLUGIN)
- message(FATAL_ERROR "System grpc_cpp_plugin not found")
---- a/userspace/libsinsp/CMakeLists.txt
-+++ b/userspace/libsinsp/CMakeLists.txt
-@@ -214,6 +214,10 @@ if(NOT WIN32)
- "${JQ_LIB}"
- "${B64_LIB}")
-
-+ if(ABSL_SYNC_LIB)
-+ target_link_libraries(sinsp "${ABSL_SYNC_LIB}")
-+ endif()
-+
- if(NOT MUSL_OPTIMIZED_BUILD)
- target_link_libraries(sinsp
- rt
diff --git a/dev-util/sysdig/files/sysdig-0.27.1-luajit-2.1.patch b/dev-util/sysdig/files/sysdig-0.27.1-luajit-2.1.patch
deleted file mode 100644
index b0d5c9dc724c..000000000000
--- a/dev-util/sysdig/files/sysdig-0.27.1-luajit-2.1.patch
+++ /dev/null
@@ -1,99 +0,0 @@
-
-https://bugs.gentoo.org/834664
-https://github.com/draios/sysdig/pull/921
-
-Backport for 0.27.1 in lua_parser_api.cpp by:
-Holger Hoffstätte <holger@applied-asynchrony.com>
-
-From 1147b9a4f6f1f9e97b43735e7980da387837de4a Mon Sep 17 00:00:00 2001
-From: Evgeni Golov <evgeni@golov.de>
-Date: Sun, 27 Aug 2017 13:51:19 +0200
-Subject: [PATCH] fix build with LuaJIT 2.1 betas
-
-LuaJIT 2.1 drops some compat symbols [1]. And while I think that this is
-wrong, as it breaks compatibility with Lua 5.1 [2], it is quite easy to
-adopt the code to work with both versions (2.0 and 2.1) of LuaJIT and
-remain Lua 5.1 compatible.
-
-[1] https://github.com/LuaJIT/LuaJIT/commit/dc320ca70f2c5bb3977b82853bcee6dad2523d01
-[2] https://github.com/LuaJIT/LuaJIT/issues/325
-
-Signed-off-by: Evgeni Golov <evgeni@golov.de>
-sysdig-CLA-1.0-signed-off-by: Evgeni Golov <evgeni@golov.de>
----
- CMakeLists.txt | 2 +-
- userspace/libsinsp/chisel.cpp | 6 +++---
- userspace/libsinsp/lua_parser.cpp | 2 +-
- userspace/libsinsp/lua_parser_api.cpp | 2 +-
- 4 files changed, 6 insertions(+), 6 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 8613a774d..4f27db9b3 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -103,7 +103,7 @@ option(USE_BUNDLED_DEPS "Enable bundled dependencies instead of using the system
- option(USE_BUNDLED_LUAJIT "Enable building of the bundled LuaJIT" ${USE_BUNDLED_DEPS})
-
- if(NOT USE_BUNDLED_LUAJIT)
-- find_path(LUAJIT_INCLUDE luajit.h PATH_SUFFIXES luajit-2.0 luajit)
-+ find_path(LUAJIT_INCLUDE luajit.h PATH_SUFFIXES luajit-2.1 luajit-2.0 luajit)
- find_library(LUAJIT_LIB NAMES luajit luajit-5.1)
- if(LUAJIT_INCLUDE AND LUAJIT_LIB)
- message(STATUS "Found LuaJIT: include: ${LUAJIT_INCLUDE}, lib: ${LUAJIT_LIB}")
-diff --git a/userspace/libsinsp/chisel.cpp b/userspace/libsinsp/chisel.cpp
-index 048bedc4e..b2bb8e872 100644
---- a/userspace/libsinsp/chisel.cpp
-+++ b/userspace/libsinsp/chisel.cpp
-@@ -96,7 +96,7 @@ void lua_stackdump(lua_State *L)
- // Lua callbacks
- ///////////////////////////////////////////////////////////////////////////////
- #ifdef HAS_LUA_CHISELS
--const static struct luaL_reg ll_sysdig [] =
-+const static struct luaL_Reg ll_sysdig [] =
- {
- {"set_filter", &lua_cbacks::set_global_filter},
- {"set_snaplen", &lua_cbacks::set_snaplen},
-@@ -124,7 +124,7 @@ const static struct luaL_reg ll_sysdig [] =
- {NULL,NULL}
- };
-
--const static struct luaL_reg ll_chisel [] =
-+const static struct luaL_Reg ll_chisel [] =
- {
- {"request_field", &lua_cbacks::request_field},
- {"set_filter", &lua_cbacks::set_filter},
-@@ -135,7 +135,7 @@ const static struct luaL_reg ll_chisel [] =
- {NULL,NULL}
- };
-
--const static struct luaL_reg ll_evt [] =
-+const static struct luaL_Reg ll_evt [] =
- {
- {"field", &lua_cbacks::field},
- {"get_num", &lua_cbacks::get_num},
-diff --git a/userspace/libsinsp/lua_parser.cpp b/userspace/libsinsp/lua_parser.cpp
-index 90a2c664f..55096d157 100644
---- a/userspace/libsinsp/lua_parser.cpp
-+++ b/userspace/libsinsp/lua_parser.cpp
-@@ -14,7 +14,7 @@ extern "C" {
- #include "lauxlib.h"
- }
-
--const static struct luaL_reg ll_filter [] =
-+const static struct luaL_Reg ll_filter [] =
- {
- {"rel_expr", &lua_parser_cbacks::rel_expr},
- {"bool_op", &lua_parser_cbacks::bool_op},
-diff --git a/userspace/libsinsp/lua_parser_api.cpp b/userspace/libsinsp/lua_parser_api.cpp
-index 7511814e3..90a3a9fb4 100644
---- a/userspace/libsinsp/lua_parser_api.cpp
-+++ b/userspace/libsinsp/lua_parser_api.cpp
-@@ -228,7 +228,7 @@ int lua_parser_cbacks::rel_expr(lua_State *ls)
- string err = "Got non-table as in-expression operand\n";
- throw sinsp_exception("parser API error");
- }
-- int n = luaL_getn(ls, 4); /* get size of table */
-+ int n = (int)lua_objlen(ls, 4); /* get size of table */
- for (i=1; i<=n; i++)
- {
- lua_rawgeti(ls, 4, i);