summaryrefslogtreecommitdiff
path: root/dev-util/stripe-mock/stripe-mock-0.110.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-24 11:59:22 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-24 11:59:22 +0100
commit6abaca02d36f161c81e2d5ee467719a89f88b2c5 (patch)
tree3caa7c096e2eccd186e20aa71bda508c5c50fb23 /dev-util/stripe-mock/stripe-mock-0.110.0.ebuild
parentb49088575eb777ced2551f484da86317332d6087 (diff)
gentoo resync (2) : 24.07.2021
Diffstat (limited to 'dev-util/stripe-mock/stripe-mock-0.110.0.ebuild')
-rw-r--r--dev-util/stripe-mock/stripe-mock-0.110.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-util/stripe-mock/stripe-mock-0.110.0.ebuild b/dev-util/stripe-mock/stripe-mock-0.110.0.ebuild
new file mode 100644
index 000000000000..05a7220e34b0
--- /dev/null
+++ b/dev-util/stripe-mock/stripe-mock-0.110.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGO_SRC="github.com/stripe/stripe-mock"
+EGO_PN=${EGO_SRC}/...
+inherit golang-build golang-vcs-snapshot
+
+DESCRIPTION="Mock HTTP server that responds like the real Stripe API"
+HOMEPAGE="https://github.com/stripe/stripe-mock"
+SRC_URI="https://github.com/stripe/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="MIT ISC BSD-2"
+SLOT="0"
+
+src_install() {
+ golang-build_src_install
+ dobin bin/stripe-mock
+ rm -rf "${D}$(get_golibdir_gopath)" || die
+}