summaryrefslogtreecommitdiff
path: root/dev-util/strace/strace-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-19 13:06:44 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-19 13:06:44 +0100
commit97967bbbae8f43c98315b079178f1717f130e302 (patch)
tree27523f8cbd75ed85f33294862514b786a30dd6e5 /dev-util/strace/strace-9999.ebuild
parent30c53e395853f5bfe805a1e429fcf26666eed8f8 (diff)
gentoo resync : 19.05.2018
Diffstat (limited to 'dev-util/strace/strace-9999.ebuild')
-rw-r--r--dev-util/strace/strace-9999.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/dev-util/strace/strace-9999.ebuild b/dev-util/strace/strace-9999.ebuild
index 8e7cd87aff5f..f9e3966c500e 100644
--- a/dev-util/strace/strace-9999.ebuild
+++ b/dev-util/strace/strace-9999.ebuild
@@ -9,13 +9,12 @@ if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/strace/strace.git"
inherit git-r3 autotools
else
- #SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.xz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~arm-linux ~x86-linux"
fi
DESCRIPTION="A useful diagnostic, instructional, and debugging tool"
-HOMEPAGE="https://sourceforge.net/projects/strace/"
+HOMEPAGE="https://strace.io/"
LICENSE="BSD"
SLOT="0"
@@ -45,7 +44,8 @@ src_prepare() {
fi
filter-lfs-flags # configure handles this sanely
- use static && append-ldflags -static
+ # Add -pthread since strace wants -lrt for timer_create, and -lrt uses -lpthread.
+ use static && append-ldflags -static -pthread
export ac_cv_header_libaio_h=$(usex aio)
use elibc_musl && export ac_cv_header_stdc=no
@@ -63,7 +63,10 @@ src_configure() {
export "${v}_FOR_BUILD=${!bv}"
done
- econf $(use_with unwind libunwind)
+ # Don't require mpers support on non-multilib systems. #649560
+ econf \
+ --enable-mpers=check \
+ $(use_with unwind libunwind)
}
src_test() {