summaryrefslogtreecommitdiff
path: root/dev-util/statifier
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-util/statifier
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/statifier')
-rw-r--r--dev-util/statifier/Manifest3
-rw-r--r--dev-util/statifier/metadata.xml12
-rw-r--r--dev-util/statifier/statifier-1.7.4.ebuild53
3 files changed, 68 insertions, 0 deletions
diff --git a/dev-util/statifier/Manifest b/dev-util/statifier/Manifest
new file mode 100644
index 000000000000..9fbb2a7c62b5
--- /dev/null
+++ b/dev-util/statifier/Manifest
@@ -0,0 +1,3 @@
+DIST statifier-1.7.4.tar.gz 73245 BLAKE2B 897b78b31aa4f148b6a6a986251ba9d4f40ebad3209f71896ffffb71e06ab25d337a4a79adc0217592051f917bc71428d3032f6216ec053f62c4632edef474d5 SHA512 22d4873130bafe06144c8f6ce7089aa25e3eb047bbee5709344fee1e8d85b24aac689c88d34537fe4a690e231d768e56a2fa13672b9eccf27d945b3f8bcda756
+EBUILD statifier-1.7.4.ebuild 1129 BLAKE2B 925e516a8711b4c71e39e0f77160f9f144d66139536a86a4daec55ee2debb29369d9cb87ea67463295ee0aa42c2ae8ca8ddcd7fe13a61ac0f58bfc0875b91914 SHA512 43321c83d8fbd0228f91f6dacdae168db1fe7fd1f73b5c41d42c731182e2bb5e7a9dd1508c1ccaea85bac16fdac3675e454bccfc637ce50682bbd337a3ced075
+MISC metadata.xml 369 BLAKE2B 99bc89ce5469bce6e867ce73fa66fee3fa41bf2166453c3606b03b1f3879f837c46d41068430e217a7ab4b0d0096650762095ffe5f13382ab055e5815f90ebb1 SHA512 5d49b66d13a6055421fc9e9a180d6d5657e367cfdc6e74a13c16955cc1bfda765605f0ab7c0d7d5f67ce847e09306fef52a2fb621eccdf358e5d21e82129a2b3
diff --git a/dev-util/statifier/metadata.xml b/dev-util/statifier/metadata.xml
new file mode 100644
index 000000000000..54d5423c4060
--- /dev/null
+++ b/dev-util/statifier/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>ck+gentoo@bl4ckb0x.de</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-util/statifier/statifier-1.7.4.ebuild b/dev-util/statifier/statifier-1.7.4.ebuild
new file mode 100644
index 000000000000..08b4f7afec9b
--- /dev/null
+++ b/dev-util/statifier/statifier-1.7.4.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+MULTILIB_COMPAT=( abi_x86_{32,64} )
+
+inherit multilib-build
+
+DESCRIPTION="Statifier is a tool for creating portable, self-containing Linux executables"
+HOMEPAGE="http://statifier.sourceforge.net"
+SRC_URI="https://sourceforge.net/projects/${PN}/files/${PN}/${PV}/${P}.tar.gz"
+
+KEYWORDS="amd64 x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+RDEPEND="app-shells/bash
+ sys-apps/coreutils
+ virtual/awk"
+
+src_prepare() {
+ # Respect users CFLAGS and LDFLAGS
+ sed -i -e 's/-Wall -O2/$(CFLAGS) $(LDFLAGS)/g' src/Makefile || die
+
+ # Don't compile 32-bit on amd64 no-multilib profile
+ if ! use abi_x86_32; then
+ sed -i -e 's/ELF32 .*/ELF32 := no/g' configs/config.x86_64 || die
+ fi
+
+ # Apply user patches
+ eapply_user
+}
+
+src_configure() {
+ # Fix permissions, as configure is not marked executable
+ chmod +x configure || die
+ econf
+}
+
+src_compile() {
+ # Package complains with MAKEOPTS > -j1
+ emake -j1
+}
+
+src_install() {
+ # Package complains with MAKEOPTS > -j1
+ emake -j1 DESTDIR="${D}" install
+
+ # Install docs
+ einstalldocs
+}