summaryrefslogtreecommitdiff
path: root/dev-util/statifier
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-util/statifier
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-util/statifier')
-rw-r--r--dev-util/statifier/Manifest1
-rw-r--r--dev-util/statifier/statifier-1.7.4-r1.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-util/statifier/Manifest b/dev-util/statifier/Manifest
index f4a609136a6d..e6a765a285f9 100644
--- a/dev-util/statifier/Manifest
+++ b/dev-util/statifier/Manifest
@@ -1,4 +1,5 @@
AUX statifier-1.7.4-fix-build-system.patch 2104 BLAKE2B 019248feff682a75b90d1aca7eea425aded1b0f01e8dff4bd24410a474ef1350ed8215803915cb52df53866f6dc996428742d0a9187f55bbff17ce30894dd6b3 SHA512 a9bf5adf1206bbca84084df0680785e1f31902fb7ce4d455593ee35e0195ef9546de641d2f5372843afb7c8584fb04b1b13ee7973813ee8561a2282f2162cc87
DIST statifier-1.7.4.tar.gz 73245 BLAKE2B 897b78b31aa4f148b6a6a986251ba9d4f40ebad3209f71896ffffb71e06ab25d337a4a79adc0217592051f917bc71428d3032f6216ec053f62c4632edef474d5 SHA512 22d4873130bafe06144c8f6ce7089aa25e3eb047bbee5709344fee1e8d85b24aac689c88d34537fe4a690e231d768e56a2fa13672b9eccf27d945b3f8bcda756
+EBUILD statifier-1.7.4-r1.ebuild 1121 BLAKE2B 65e776a2db0b4fceb22d8c74924b917be7e014cab3283abd547bf828d06c0ce58056a23857a67f965cec652438c192e0155e527f9dd832f5d721d4a244649c7d SHA512 560cfa83d8ae2586fec125c759f2a81055cbd464749d305a435b563f5b1ab258370d10056dc2415a8f22604ace32ba9c45f65235f3dd1bd7b11791502f99c832
EBUILD statifier-1.7.4.ebuild 1125 BLAKE2B b0b81af822f90d001cc7509a74334e8149bcc26d0f106d84aaa2ca27d5d79b033da1813d60bb37119c604eaf0f007f6c2a6c3553fedcadaacb53fbc49be116eb SHA512 9a8749dfce5361eb7771e0f330b300c1ce56f08ff6cd93abf1457a2ddcb81b3016c14c54df0fdb602f20b72c97d7f799ae496043024ddae347f3af43da19923e
MISC metadata.xml 250 BLAKE2B d57634b040c498296655940e3ee580c8580075a4190e2600113cee5548ff44a2025568380f3d5d9f3ca0fcd1ea5d41c9871395ffbcf4bd32d8df6a494852a885 SHA512 c225bdf339347a1768b255d905f3831904cdc375f3d4e90e41c68645b8bcfe2dfdf8e6aa4c67063103f459808a387c8edd9b35b073b8be175f7a3bd490fe3dca
diff --git a/dev-util/statifier/statifier-1.7.4-r1.ebuild b/dev-util/statifier/statifier-1.7.4-r1.ebuild
new file mode 100644
index 000000000000..046c0699da96
--- /dev/null
+++ b/dev-util/statifier/statifier-1.7.4-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MULTILIB_COMPAT=( abi_x86_{32,64} )
+
+inherit multilib-build toolchain-funcs
+
+DESCRIPTION="Statifier is a tool for creating portable, self-containing Linux executables"
+HOMEPAGE="http://statifier.sourceforge.net"
+SRC_URI="https://sourceforge.net/projects/${PN}/files/${PN}/${PV}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+
+RDEPEND="
+ app-shells/bash
+ sys-apps/coreutils
+ virtual/awk
+"
+
+PATCHES=(
+ # Respect users CFLAGS and LDFLAGS
+ "${FILESDIR}"/${PN}-1.7.4-fix-build-system.patch
+)
+
+src_prepare() {
+ default
+
+ # Don't compile 32-bit on amd64 no-multilib profile
+ if ! use abi_x86_32; then
+ sed -i -e 's/ELF32 .*/ELF32 := no/g' configs/config.x86_64 || die
+ fi
+}
+
+src_configure() {
+ tc-export CC
+
+ # Fix permissions, as configure is not marked executable
+ chmod +x configure || die
+ econf
+}
+
+src_compile() {
+ # Package complains with MAKEOPTS > -j1
+ emake -j1
+}
+
+src_install() {
+ # Package complains with MAKEOPTS > -j1
+ emake -j1 DESTDIR="${ED}" install
+
+ # Install docs
+ einstalldocs
+}