summaryrefslogtreecommitdiff
path: root/dev-util/squashdelta/squashdelta-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-util/squashdelta/squashdelta-9999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-util/squashdelta/squashdelta-9999.ebuild')
-rw-r--r--dev-util/squashdelta/squashdelta-9999.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-util/squashdelta/squashdelta-9999.ebuild b/dev-util/squashdelta/squashdelta-9999.ebuild
new file mode 100644
index 000000000000..fd19fe305141
--- /dev/null
+++ b/dev-util/squashdelta/squashdelta-9999.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGIT_REPO_URI="https://github.com/mgorny/${PN}.git"
+inherit autotools git-r3
+
+DESCRIPTION="Efficient (partially uncompressed) SquashFS binary delta tool"
+HOMEPAGE="https://github.com/mgorny/squashdelta/"
+SRC_URI=""
+
+# uses public-domain murmurhash3
+LICENSE="BSD public-domain"
+SLOT="0"
+KEYWORDS=""
+IUSE="lz4 +lzo"
+
+COMMON_DEPEND="
+ lz4? ( app-arch/lz4:0= )
+ lzo? ( dev-libs/lzo:2= )"
+RDEPEND="${COMMON_DEPEND}
+ dev-util/xdelta:3"
+DEPEND=${COMMON_DEPEND}
+
+# SquashDelta does not make much sense without a compression algo.
+REQUIRED_USE="|| ( lz4 lzo )"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ $(use_enable lz4)
+ $(use_enable lzo)
+ )
+
+ econf "${myconf[@]}"
+}