summaryrefslogtreecommitdiff
path: root/dev-util/squashdelta/squashdelta-0.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-30 11:19:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-30 11:19:18 +0100
commit62f67115b5c46134c34f88f4b1cbdacc19384c0a (patch)
tree0a76b14de203a4c23040e5665e39df8de9867745 /dev-util/squashdelta/squashdelta-0.1.1.ebuild
parent265dbe5dbc14c199299496c6db8fce3f76647015 (diff)
gentoo resync : 30.09.2018
Diffstat (limited to 'dev-util/squashdelta/squashdelta-0.1.1.ebuild')
-rw-r--r--dev-util/squashdelta/squashdelta-0.1.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-util/squashdelta/squashdelta-0.1.1.ebuild b/dev-util/squashdelta/squashdelta-0.1.1.ebuild
new file mode 100644
index 000000000000..9883a7ef38f0
--- /dev/null
+++ b/dev-util/squashdelta/squashdelta-0.1.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Efficient (partially uncompressed) SquashFS binary delta tool"
+HOMEPAGE="https://github.com/mgorny/squashdelta/"
+SRC_URI="https://www.github.com/mgorny/squashdelta/releases/download/v${PV}/${P}.tar.bz2"
+
+# uses public-domain murmurhash3
+LICENSE="BSD public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="lz4 +lzo"
+
+COMMON_DEPEND="
+ lz4? ( app-arch/lz4:0= )
+ lzo? ( dev-libs/lzo:2= )"
+RDEPEND="${COMMON_DEPEND}
+ dev-util/xdelta:3"
+DEPEND=${COMMON_DEPEND}
+
+# SquashDelta does not make much sense without a compression algo.
+REQUIRED_USE="|| ( lz4 lzo )"
+
+src_configure() {
+ local myconf=(
+ $(use_enable lz4)
+ $(use_enable lzo)
+ )
+
+ econf "${myconf[@]}"
+}