summaryrefslogtreecommitdiff
path: root/dev-util/splint/splint-3.1.2-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-util/splint/splint-3.1.2-r2.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/splint/splint-3.1.2-r2.ebuild')
-rw-r--r--dev-util/splint/splint-3.1.2-r2.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-util/splint/splint-3.1.2-r2.ebuild b/dev-util/splint/splint-3.1.2-r2.ebuild
new file mode 100644
index 000000000000..1549f142bdb8
--- /dev/null
+++ b/dev-util/splint/splint-3.1.2-r2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="Check C programs for vulnerabilities and programming mistakes"
+HOMEPAGE="http://lclint.cs.virginia.edu/"
+SRC_URI="http://www.splint.org/downloads/${P}.src.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~ppc-macos ~x64-macos ~x86-macos"
+
+DEPEND="
+ sys-devel/flex
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.1.2-musl.patch
+
+ # verbose compiler calls
+ sed -i -e '/Compiling/d' src/Makefile.am || die
+ # automake complains about trailing \
+ sed -i -e '1600d' test/Makefile.am || die
+ # do not install these header files twice
+ sed -i -e '/\$(UnixHeaders)/s|stdio.h stdlib.h||g' lib/Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ # We do not need bison/yacc at all here
+ # We definitely need libfl
+ BISON=no LEXLIB=-lfl econf
+}
+
+src_compile() {
+ local subdir
+ # skip test/ subdir
+ for subdir in src lib imports doc; do
+ emake -j1 -C ${subdir}
+ done
+}
+
+src_test() {
+ emake -C test
+}