summaryrefslogtreecommitdiff
path: root/dev-util/spirv-tools/spirv-tools-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-util/spirv-tools/spirv-tools-9999.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/spirv-tools/spirv-tools-9999.ebuild')
-rw-r--r--dev-util/spirv-tools/spirv-tools-9999.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-util/spirv-tools/spirv-tools-9999.ebuild b/dev-util/spirv-tools/spirv-tools-9999.ebuild
new file mode 100644
index 000000000000..029556876e65
--- /dev/null
+++ b/dev-util/spirv-tools/spirv-tools-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-multilib cmake-utils git-r3
+
+DESCRIPTION="Provides an API and commands for processing SPIR-V modules"
+HOMEPAGE="https://github.com/KhronosGroup/SPIRV-Tools"
+EGIT_REPO_URI="https://github.com/KhronosGroup/SPIRV-Tools.git"
+SRC_URI=""
+
+LICENSE="Apache-2.0"
+SLOT="0"
+# Tests fail upon finding symbols that do not match a regular expression
+# in the generated library. Easily hit with non-standard compiler flags
+RESTRICT="test"
+
+RDEPEND=""
+DEPEND=">=dev-util/spirv-headers-1.3.1_pre20180710"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ "-DSPIRV-Headers_SOURCE_DIR=/usr/"
+ )
+
+ cmake-utils_src_configure
+}
+
+multilib_src_install() {
+ default
+
+ # create a header file with the commit hash of the current revision
+ # vulkan-tools needs this to build
+ echo "${EGIT_VERSION}" > "${D}/usr/include/${PN}/${PN}-commit.h" || die
+}