summaryrefslogtreecommitdiff
path: root/dev-util/spirv-llvm-translator/spirv-llvm-translator-9.0.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
commit29aabba0ea759c6a2864ff5631735b67ee38e5e0 (patch)
treeab466b4dfa7abecb401b2f8039d08af4689306bb /dev-util/spirv-llvm-translator/spirv-llvm-translator-9.0.0.1.ebuild
parentd42200bec37eef2a7478d88988ff00addd0a9202 (diff)
gentoo resync : 05.02.2020
Diffstat (limited to 'dev-util/spirv-llvm-translator/spirv-llvm-translator-9.0.0.1.ebuild')
-rw-r--r--dev-util/spirv-llvm-translator/spirv-llvm-translator-9.0.0.1.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-util/spirv-llvm-translator/spirv-llvm-translator-9.0.0.1.ebuild b/dev-util/spirv-llvm-translator/spirv-llvm-translator-9.0.0.1.ebuild
index dd616822e690..4feef376c920 100644
--- a/dev-util/spirv-llvm-translator/spirv-llvm-translator-9.0.0.1.ebuild
+++ b/dev-util/spirv-llvm-translator/spirv-llvm-translator-9.0.0.1.ebuild
@@ -3,6 +3,7 @@
EAPI=7
+CMAKE_ECLASS=cmake
inherit cmake-multilib flag-o-matic llvm
MY_PN="SPIRV-LLVM-Translator"
@@ -37,7 +38,7 @@ PATCHES=(
src_prepare() {
append-flags -fPIC
- cmake-utils_src_prepare
+ cmake_src_prepare
}
multilib_src_configure() {
@@ -46,7 +47,7 @@ multilib_src_configure() {
-DLLVM_BUILD_TOOLS=$(usex tools "ON" "OFF")
$(usex test "-DLLVM_INCLUDE_TESTS=ON" "")
)
- cmake-utils_src_configure
+ cmake_src_configure
}
multilib_src_test() {